summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-03-30 17:48:10 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-04-03 12:10:15 +0200
commit501e07acd803df6f9264c4206b4b9529006f287a (patch)
tree20e5bd1f9b3ffd4f230c9c9f5ac87fa85e626617 /recipes-sota/ostree/ostree_git.bb
parent95b5db5a2714d429d31c42d079b192e8edb1a079 (diff)
downloadmeta-updater-501e07acd803df6f9264c4206b4b9529006f287a.tar.gz
Merge from meta-agl-extra
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb20
1 files changed, 13 insertions, 7 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 5775dfa..102b70f 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -8,7 +8,9 @@ INHERIT_remove_class-native = "systemd"
8 8
9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
10 10
11SRCREV="6517a8a27a1386e7cb5482e7cb2919fe92721ccf" 11SRCREV="3b09620c2738bce4ed45e099cf2e4c5df7671d39"
12
13PV = "2017.3-31-g3b09620c"
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
@@ -16,16 +18,20 @@ BBCLASSEXTEND = "native"
16 18
17DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native" 19DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native"
18DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 20DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
19
20DEPENDS_remove_class-native = "systemd-native" 21DEPENDS_remove_class-native = "systemd-native"
21 22
22RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz os-release ca-certificates" 23RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz bash"
23RDEPENDS_${PN}_remove_class-native = "python-native os-release-native" 24RDEPENDS_${PN}_remove_class-native = "python-native"
24 25
25EXTRA_OECONF = "CFLAGS='-g' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man" 26EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig"
26EXTRA_OEMAKE = "CFLAGS='-g'"
27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" 27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
28 28
29# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
30# do_configure stage so we do depend on it
31SYSROOT_DIR = "${STAGING_DIR_TARGET}"
32SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
33do_configure[vardeps] += "SYSROOT_DIR"
34
29SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" 35SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
30SYSTEMD_REQUIRED_class-native = "" 36SYSTEMD_REQUIRED_class-native = ""
31 37
@@ -55,7 +61,7 @@ do_compile_prepend() {
55export SYSTEMD_REQUIRED 61export SYSTEMD_REQUIRED
56 62
57do_install_append() { 63do_install_append() {
58 if [ -n $SYSTEMD_REQUIRED ]; then 64 if [ -n ${SYSTEMD_REQUIRED} ]; then
59 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service 65 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
60 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service 66 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
61 fi 67 fi