summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree-booted_1.0.bb
diff options
context:
space:
mode:
authorEugene Smirnov <evgenii.smirnov@here.com>2019-10-23 17:34:19 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-11-20 10:42:32 +0100
commit0a6fccd03ef8d93cce9b5d96d87a87fb9350d94e (patch)
treeb5f1148ce301cd517c76567fa9ffa06931180641 /recipes-sota/ostree/ostree-booted_1.0.bb
parent8b6ed98e2cb33a2f678e61ffd40c638052ba98b9 (diff)
downloadmeta-updater-0a6fccd03ef8d93cce9b5d96d87a87fb9350d94e.tar.gz
Indicate an OSTree boot on start
Signed-off-by: Mykhaylo Sul <ext-mykhaylo.sul@here.com> Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-sota/ostree/ostree-booted_1.0.bb')
-rw-r--r--recipes-sota/ostree/ostree-booted_1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-sota/ostree/ostree-booted_1.0.bb b/recipes-sota/ostree/ostree-booted_1.0.bb
new file mode 100644
index 0000000..d74cf24
--- /dev/null
+++ b/recipes-sota/ostree/ostree-booted_1.0.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Indicate an OSTree boot"
2DESCRIPTION = "Indicate an OSTree boot"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
5SRC_URI = "file://touch-ostree"
6
7inherit allarch update-rc.d
8
9INITSCRIPT_NAME = "touch-ostree"
10INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ."
11
12do_install() {
13 install -d ${D}${sysconfdir}/init.d
14 install -m 0755 ${WORKDIR}/touch-ostree ${D}${sysconfdir}/init.d/touch-ostree
15}