summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree-initrd/ostree-initrd.bb
diff options
context:
space:
mode:
authorPhil Wise <phil@advancedtelematic.com>2017-04-21 09:57:01 +0200
committerPhil Wise <phil@advancedtelematic.com>2017-04-21 09:57:01 +0200
commit47921feae0a5eaa41b18c5d15da9c1f6619b40c5 (patch)
tree05e707e646281d0af228c511fed8dfeb0ca67099 /recipes-sota/ostree-initrd/ostree-initrd.bb
parentc5ca4c893bf6336bb3675b2aa24dc8c6e44fc82f (diff)
downloadmeta-updater-47921feae0a5eaa41b18c5d15da9c1f6619b40c5.tar.gz
Mount the root filesystem by label rather than path
Support identifying the root filesystem via a kernel command line like 'ostree_root=LABEL=mylabel'. Also make it mount a filesystem labeled 'otaroot' by default. This means it is possible to test the Minnowboard build in Qemu.
Diffstat (limited to 'recipes-sota/ostree-initrd/ostree-initrd.bb')
-rw-r--r--recipes-sota/ostree-initrd/ostree-initrd.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb
index 5c85bee..b721405 100644
--- a/recipes-sota/ostree-initrd/ostree-initrd.bb
+++ b/recipes-sota/ostree-initrd/ostree-initrd.bb
@@ -5,15 +5,16 @@ SRC_URI = "file://init.sh"
5 5
6S = "${WORKDIR}" 6S = "${WORKDIR}"
7 7
8PV = "2"
9
8do_install() { 10do_install() {
9 install -dm 0755 ${D}/etc 11 install -dm 0755 ${D}/etc
10 touch ${D}/etc/initrd-release 12 touch ${D}/etc/initrd-release
11 install -dm 0755 ${D}/dev 13 install -dm 0755 ${D}/dev
12 install -dm 0755 ${D}/sbin 14 install -dm 0755 ${D}/sbin
13 install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init 15 install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init
14} 16}
15 17
16inherit allarch 18inherit allarch
17 19
18FILES_${PN} += " /dev /etc/initrd-release /sbin/init " 20FILES_${PN} += " /dev /etc/initrd-release /sbin/init "
19