diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2018-05-03 12:22:52 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2018-05-04 14:47:42 +0200 |
commit | f01b2b06c6fb76cd5d83f5e23643a399d7f41606 (patch) | |
tree | 284ed53990b2699c3895310aa681380e47874b71 /recipes-sota/config | |
parent | 0c40c88798b9b36eae8af28424899d76ed321758 (diff) | |
download | meta-updater-f01b2b06c6fb76cd5d83f5e23643a399d7f41606.tar.gz |
Update aktualizr config to use default locations.
Fix permissions, drop explicit aktualizr dependency, put everything in
/usr/lib/sota/conf.d, rename with numeric prefixes to make precedence
more clear.
Diffstat (limited to 'recipes-sota/config')
-rw-r--r-- | recipes-sota/config/aktualizr-disable-send-ip.bb | 5 | ||||
-rw-r--r-- | recipes-sota/config/aktualizr-example-interface.bb | 5 | ||||
-rw-r--r-- | recipes-sota/config/aktualizr-log-debug.bb | 5 |
3 files changed, 6 insertions, 9 deletions
diff --git a/recipes-sota/config/aktualizr-disable-send-ip.bb b/recipes-sota/config/aktualizr-disable-send-ip.bb index 32c55f3..ce492e9 100644 --- a/recipes-sota/config/aktualizr-disable-send-ip.bb +++ b/recipes-sota/config/aktualizr-disable-send-ip.bb | |||
@@ -5,18 +5,17 @@ SECTION = "base" | |||
5 | LICENSE = "MPL-2.0" | 5 | LICENSE = "MPL-2.0" |
6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | 6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" |
7 | 7 | ||
8 | DEPENDS = "aktualizr " | ||
9 | SRC_URI = " \ | 8 | SRC_URI = " \ |
10 | file://LICENSE \ | 9 | file://LICENSE \ |
11 | " | 10 | " |
12 | 11 | ||
13 | do_install_append () { | 12 | do_install_append () { |
14 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 13 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
15 | echo "[telemetry]\nreport_network = false\n" > ${D}${libdir}/sota/conf.d/disable-send-ip.toml | 14 | echo "[telemetry]\nreport_network = false\n" > ${D}${libdir}/sota/conf.d/30-disable-send-ip.toml |
16 | } | 15 | } |
17 | 16 | ||
18 | FILES_${PN} = " \ | 17 | FILES_${PN} = " \ |
19 | ${libdir}/sota/conf.d/disable-send-ip.toml \ | 18 | ${libdir}/sota/conf.d/30-disable-send-ip.toml \ |
20 | " | 19 | " |
21 | 20 | ||
22 | # vim:set ts=4 sw=4 sts=4 expandtab: | 21 | # vim:set ts=4 sw=4 sts=4 expandtab: |
diff --git a/recipes-sota/config/aktualizr-example-interface.bb b/recipes-sota/config/aktualizr-example-interface.bb index 05f63bf..52ebe1c 100644 --- a/recipes-sota/config/aktualizr-example-interface.bb +++ b/recipes-sota/config/aktualizr-example-interface.bb | |||
@@ -5,18 +5,17 @@ SECTION = "base" | |||
5 | LICENSE = "MPL-2.0" | 5 | LICENSE = "MPL-2.0" |
6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | 6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" |
7 | 7 | ||
8 | DEPENDS = "aktualizr " | ||
9 | SRC_URI = " \ | 8 | SRC_URI = " \ |
10 | file://LICENSE \ | 9 | file://LICENSE \ |
11 | " | 10 | " |
12 | 11 | ||
13 | do_install_append () { | 12 | do_install_append () { |
14 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 13 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
15 | echo "[uptane]\nlegacy_interface = \"/usr/bin/example-interface\"\n" > ${D}${libdir}/sota/conf.d/example-interface.toml | 14 | echo "[uptane]\nlegacy_interface = \"/usr/bin/example-interface\"\n" > ${D}${libdir}/sota/conf.d/30-example-interface.toml |
16 | } | 15 | } |
17 | 16 | ||
18 | FILES_${PN} = " \ | 17 | FILES_${PN} = " \ |
19 | ${libdir}/sota/conf.d/example-interface.toml \ | 18 | ${libdir}/sota/conf.d/30-example-interface.toml \ |
20 | " | 19 | " |
21 | 20 | ||
22 | # vim:set ts=4 sw=4 sts=4 expandtab: | 21 | # vim:set ts=4 sw=4 sts=4 expandtab: |
diff --git a/recipes-sota/config/aktualizr-log-debug.bb b/recipes-sota/config/aktualizr-log-debug.bb index 512599f..e32a414 100644 --- a/recipes-sota/config/aktualizr-log-debug.bb +++ b/recipes-sota/config/aktualizr-log-debug.bb | |||
@@ -5,18 +5,17 @@ SECTION = "base" | |||
5 | LICENSE = "MPL-2.0" | 5 | LICENSE = "MPL-2.0" |
6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | 6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" |
7 | 7 | ||
8 | DEPENDS = "aktualizr " | ||
9 | SRC_URI = " \ | 8 | SRC_URI = " \ |
10 | file://LICENSE \ | 9 | file://LICENSE \ |
11 | " | 10 | " |
12 | 11 | ||
13 | do_install_append () { | 12 | do_install_append () { |
14 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 13 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
15 | echo "[logger]\nloglevel = 0\n" > ${D}${libdir}/sota/conf.d/log-debug.toml | 14 | echo "[logger]\nloglevel = 0\n" > ${D}${libdir}/sota/conf.d/90-log-debug.toml |
16 | } | 15 | } |
17 | 16 | ||
18 | FILES_${PN} = " \ | 17 | FILES_${PN} = " \ |
19 | ${libdir}/sota/conf.d/log-debug.toml \ | 18 | ${libdir}/sota/conf.d/90-log-debug.toml \ |
20 | " | 19 | " |
21 | 20 | ||
22 | # vim:set ts=4 sw=4 sts=4 expandtab: | 21 | # vim:set ts=4 sw=4 sts=4 expandtab: |