diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2020-10-21 10:11:04 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2020-10-21 10:11:04 +0200 |
commit | a1af0b446e33a4f409fb7c93861248dddc237546 (patch) | |
tree | e33c30c224a52bc2f39e87226fbe5ca26c0b112e /recipes-sota/aktualizr | |
parent | 10cba0d844894daf421665dcf5ed8cf5a77e1f63 (diff) | |
download | meta-updater-a1af0b446e33a4f409fb7c93861248dddc237546.tar.gz |
aktualizr: Don't put unused configs in the image.fix/unused-configs
Because every aktualizr package was depending on aktualizr-configs, all
of the default configs were getting installed to /usr/lib/sota, despite
that by default none of them were ever used on the device. That
dependency has been removed.
The provisioning recipes still install the recipes they need to the
default location that aktualizr actually uses (/usr/lib/sota/conf.d). If
you want to use anything else, a specific recipe should be created to do
so.
This change rendered the aktualizr-host-tools package useless, so it has
been removed.
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-sota/aktualizr')
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-device-prov.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-shared-prov.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 9 |
4 files changed, 6 insertions, 9 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb index 8f28c03..7239bfd 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
10 | # We need to get the config files from the aktualizr-host-tools package built by | 10 | # We need to get the config files from the aktualizr-configs package built by |
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | 13 | ||
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb index 55f398d..391b098 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
10 | # We need to get the config files from the aktualizr-host-tools package built by | 10 | # We need to get the config files from the aktualizr-configs package built by |
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | 13 | ||
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/recipes-sota/aktualizr/aktualizr-shared-prov.bb index 0f712df..0c54f32 100644 --- a/recipes-sota/aktualizr/aktualizr-shared-prov.bb +++ b/recipes-sota/aktualizr/aktualizr-shared-prov.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
10 | # We need to get the config files from the aktualizr-host-tools package built by | 10 | # We need to get the config files from the aktualizr-configs package built by |
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}" | 13 | RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}" |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 69beb4b..d7d9392 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -7,8 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad" | |||
7 | 7 | ||
8 | DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" | 8 | DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" |
9 | DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" | 9 | DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" |
10 | RDEPENDS_${PN}_class-target = "${PN}-configs ${PN}-hwid lshw" | 10 | RDEPENDS_${PN}_class-target = "${PN}-hwid lshw" |
11 | RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" | ||
12 | 11 | ||
13 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" | 12 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" |
14 | 13 | ||
@@ -133,14 +132,12 @@ python split_hosttools_packages () { | |||
133 | bindir = d.getVar('bindir') | 132 | bindir = d.getVar('bindir') |
134 | 133 | ||
135 | # Split all binaries to their own packages. | 134 | # Split all binaries to their own packages. |
136 | do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) | 135 | do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='', prepend=False) |
137 | } | 136 | } |
138 | 137 | ||
139 | PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" | 138 | PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" |
140 | 139 | ||
141 | PACKAGES =+ "${PN}-host-tools ${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" | 140 | PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" |
142 | |||
143 | ALLOW_EMPTY_${PN}-host-tools = "1" | ||
144 | 141 | ||
145 | FILES_${PN} = " \ | 142 | FILES_${PN} = " \ |
146 | ${bindir}/aktualizr \ | 143 | ${bindir}/aktualizr \ |