summaryrefslogtreecommitdiffstats
path: root/recipes-sota/aktualizr/aktualizr-device-prov.bb
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-10-14 12:06:23 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-10-21 13:02:11 +0200
commit0f25771be55a3c7daf9eded720bf2868b04becde (patch)
tree97639c172f2fe89e3ed25c4443f687c099ddfaa6 /recipes-sota/aktualizr/aktualizr-device-prov.bb
parent1f7ff1fa5b72a20471eb9deb13d3ff5b06ec446d (diff)
downloadmeta-updater-0f25771be55a3c7daf9eded720bf2868b04becde.tar.gz
aktualizr: use SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS for config recipes.
This is a bit of a compromise. These recipes are allarch, since they do not depend on an architecture, but they depend on aktualizr, which is definitely not allarch. Therefore, we must tell bitbake not to treat the aktualizr architecture as a dependency of these recipes. However, this means that if one of the config files changes in the aktualizr repo, we need to bump the version of the recipe that uses it to make sure bitbake picks up that change. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-sota/aktualizr/aktualizr-device-prov.bb')
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb
index fbe29a1..e8c75bb 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb
@@ -12,9 +12,13 @@ inherit allarch
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" 13RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}"
14 14
15# If the config file from aktualizr used here is changed, you will need to bump
16# the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS!
15PV = "1.0" 17PV = "1.0"
16PR = "1" 18PR = "1"
17 19
20SRC_URI = ""
21
18do_install() { 22do_install() {
19 install -m 0700 -d ${D}${libdir}/sota/conf.d 23 install -m 0700 -d ${D}${libdir}/sota/conf.d
20 install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred.toml \ 24 install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred.toml \