summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-09-26 15:44:53 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-09-26 15:44:53 +0200
commit844ddcf4496edfdb9b682f712ab1ae1cd16f1f97 (patch)
tree5cb9794fb8630c32797b9687cd847d7b954b55cd /recipes-core
parent0983092cf61779b70cb41741bd4913b0f0f0fbac (diff)
downloadmeta-updater-844ddcf4496edfdb9b682f712ab1ae1cd16f1f97.tar.gz
Added initramfs image and fixed several error to make AGL rootfs
bootable as an OSTree deployment Bug-AGL: SPEC-253 Change-Id: If636a282d51a64c73c46ce70a361518c1f70cdd6 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
new file mode 100644
index 0000000..71aa631
--- /dev/null
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -0,0 +1,23 @@
1# Netboot initramfs image.
2DESCRIPTION = "OSTree initramfs image"
3
4PACKAGE_INSTALL = "ostree ostree-initramfs systemd-initramfs busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
5
6SYSTEMD_DEFAULT_TARGET = "initrd.target"
7
8# Do not pollute the initrd image with rootfs features
9IMAGE_FEATURES = ""
10
11export IMAGE_BASENAME = "initramfs-ostree-image"
12IMAGE_LINGUAS = ""
13
14LICENSE = "MIT"
15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
17inherit core-image
18
19IMAGE_ROOTFS_SIZE = "8192"
20
21BAD_RECOMMENDATIONS += "busybox-syslog"
22
23