summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-05-11 20:16:05 +0200
committerMing Liu <ming.liu@toradex.com>2020-06-18 19:48:12 +0200
commit6eecf1593d31dc04566c646717f248b3fb0aa40d (patch)
treed686211b05ba0d99c3e52cccc5278c36e2941129 /recipes-core
parent80072521db9312965d8c52a09bbfb29a633d2274 (diff)
downloadmeta-updater-6eecf1593d31dc04566c646717f248b3fb0aa40d.tar.gz
meta: introduce ostree-kernel-initramfs recipe
We package kernel image, devicetrees, initramfs and install them to /usr/lib/modules/${KERNEL_VERSION}, which is the preferred location according to ostree's new implementation, this could simplify the deployment. Reference: https://github.com/ostreedev/ostree/commit/3ab0d5e6644885440bac6abd17b6d2637df5435f To let initramfs-ostree-image be able to be depended by ostree-kernel-initramfs, it must inherit nopackages to avoid a annoying QA warning like the follows: | WARNING: initramfs-ostree-image-0.0.1-r0 do_package: Manifest ...initramfs-ostree-image.packagedata | not found in colibri_imx6 armv7ahf-neon-imx armv7at2hf-neon-imx armv7at2hf-neon armv7ahf-neon armv7at2hf-vfp | armv7ahf-vfp armv6thf-vfp armv6hf-vfp armv5tehf-vfp armv5ehf-vfp armv5thf-vfp armv5hf-vfp allarch | x86_64_x86_64-nativesdk (variant '')? Also we need define OSTREE_KERNEL, OSTREE_DEPLOY_DEVICETREE and OSTREE_DEVICETREE in sota.bbclass so they could be accessed in other recipes as well as in image recipes. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
index bc21ed3..4af1548 100644
--- a/recipes-core/images/initramfs-ostree-image.bb
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -20,7 +20,7 @@ IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
20# Avoid circular dependencies 20# Avoid circular dependencies
21EXTRA_IMAGEDEPENDS = "" 21EXTRA_IMAGEDEPENDS = ""
22 22
23inherit core-image 23inherit core-image nopackages
24 24
25IMAGE_ROOTFS_SIZE = "8192" 25IMAGE_ROOTFS_SIZE = "8192"
26 26