summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-03-05 18:02:10 +0100
committerLaurent Bonnans <laurent.bonnans@here.com>2019-03-05 18:35:15 +0100
commit9ff6efc8864d020b17e05a0e59e266081af4b7b3 (patch)
tree6ebd7aece5fa94efec01a584de514bfa08f59544 /recipes-connectivity
parentb9abe3de1b58034604411b6a0821ccce83481272 (diff)
downloadmeta-updater-9ff6efc8864d020b17e05a0e59e266081af4b7b3.tar.gz
Replace connman with systemd-networkd on qemux86-64
Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network5
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb23
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network b/recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network
new file mode 100644
index 0000000..aec1849
--- /dev/null
+++ b/recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network
@@ -0,0 +1,5 @@
1[Match]
2Name=en*
3
4[Network]
5DHCP=yes
diff --git a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
new file mode 100644
index 0000000..60eae44
--- /dev/null
+++ b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
@@ -0,0 +1,23 @@
1SUMMARY = "systemd-networkd config to setup wired interface with dhcp"
2DESCRIPTION = "Provides automatic dhcp network configuration for wired \
3interfaces through systemd-networkd"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
6
7inherit systemd
8
9SRC_URI_append = " file://20-wired-dhcp.network"
10PR = "r1"
11
12RDEPENDS_${PN} = "systemd"
13
14S = "${WORKDIR}"
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18FILES_${PN} = "${systemd_unitdir}/network/*"
19
20do_install() {
21 install -d ${D}/${systemd_unitdir}/network
22 install -m 0644 ${WORKDIR}/20-wired-dhcp.network ${D}/${systemd_unitdir}/network
23}