summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-03-05 18:02:10 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2019-04-26 15:57:44 +0200
commit6e9c599f8c7408b7ffa719649b03524683898e9c (patch)
tree2d6e9b61efb275438287f61dda39f9ba73a33aac /recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
parent6d3d6b5ab6761b27a638bf56f3c9e0ff8c09c300 (diff)
downloadmeta-updater-6e9c599f8c7408b7ffa719649b03524683898e9c.tar.gz
Replace connman with systemd-networkd on qemux86-64
Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
Diffstat (limited to 'recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb')
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
new file mode 100644
index 0000000..60eae44
--- /dev/null
+++ b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
@@ -0,0 +1,23 @@
1SUMMARY = "systemd-networkd config to setup wired interface with dhcp"
2DESCRIPTION = "Provides automatic dhcp network configuration for wired \
3interfaces through systemd-networkd"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
6
7inherit systemd
8
9SRC_URI_append = " file://20-wired-dhcp.network"
10PR = "r1"
11
12RDEPENDS_${PN} = "systemd"
13
14S = "${WORKDIR}"
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18FILES_${PN} = "${systemd_unitdir}/network/*"
19
20do_install() {
21 install -d ${D}/${systemd_unitdir}/network
22 install -m 0644 ${WORKDIR}/20-wired-dhcp.network ${D}/${systemd_unitdir}/network
23}