diff options
author | Anton Gerasimov <anton@advancedtelematic.com> | 2017-01-04 10:38:07 +0100 |
---|---|---|
committer | Anton Gerasimov <anton@advancedtelematic.com> | 2017-01-04 10:38:07 +0100 |
commit | 83ad1a2a44e4490eecbb74f04f43e4c3f0b00cc2 (patch) | |
tree | aaf3c9d0e1e0ca91382ed3b84cc9fe6517526950 /recipes-bsp | |
parent | 6e60a8585f68edde7bdab461139efec35f33161c (diff) | |
download | meta-updater-83ad1a2a44e4490eecbb74f04f43e4c3f0b00cc2.tar.gz |
Move RPi-specific u-boot script to meta-updater-raspberrypi
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot-otascript/u-boot-otascript.bb | 26 | ||||
-rw-r--r-- | recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr | 3 | ||||
-rw-r--r-- | recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt | 7 |
3 files changed, 0 insertions, 36 deletions
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/recipes-bsp/u-boot-otascript/u-boot-otascript.bb deleted file mode 100644 index 9f5f0ca..0000000 --- a/recipes-bsp/u-boot-otascript/u-boot-otascript.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
4 | |||
5 | DEPENDS = "u-boot-mkimage-native" | ||
6 | |||
7 | COMPATIBLE_MACHINE = "raspberrypi" | ||
8 | |||
9 | SRC_URI = "file://boot.scr \ | ||
10 | file://uEnv.txt" | ||
11 | |||
12 | S = "${WORKDIR}" | ||
13 | |||
14 | inherit deploy | ||
15 | |||
16 | do_deploy() { | ||
17 | install -d ${DEPLOYDIR}/bcm2835-bootfiles | ||
18 | |||
19 | mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr | ||
20 | install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt | ||
21 | } | ||
22 | |||
23 | addtask deploy before do_package after do_install | ||
24 | do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles" | ||
25 | |||
26 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr b/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr deleted file mode 100644 index dc13f85..0000000 --- a/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | fatload mmc 0:1 $loadaddr /uEnv.txt | ||
2 | env import -t $loadaddr $filesize | ||
3 | run bootcmd | ||
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt b/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt deleted file mode 100644 index f6c0570..0000000 --- a/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | fdt_addr_r=0x0c800000 | ||
2 | bootcmd_dtb=fdt addr $fdt_addr_r; fdt get value bootargs_fdt /chosen bootargs | ||
3 | bootcmd_otenv=ext2load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize | ||
4 | bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192" | ||
5 | bootcmd_load=ext2load mmc 0:2 $kernel_addr_r "/boot"$kernel_image; ext2load mmc 0:2 $ramdisk_addr_r "/boot"$ramdisk_image | ||
6 | bootcmd_run=bootm $kernel_addr_r $ramdisk_addr_r $fdt_addr_r | ||
7 | bootcmd=run bootcmd_dtb; run bootcmd_otenv; run bootcmd_args; run bootcmd_load; run bootcmd_run | ||