summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-08-16 12:17:17 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-08-16 12:26:30 +0200
commit4b9938d16e06ce05b8bdefd1f48f2e9bd85fca5a (patch)
tree1e5064d11f7db1625063fa73f32c4788cba8abff /recipes-bsp
parent291d597cf414f1a69ed7999f0a86689e657adcca (diff)
downloadmeta-updater-4b9938d16e06ce05b8bdefd1f48f2e9bd85fca5a.tar.gz
Add support for emulating OSTree updates in qemux86: new live image,
u-boot that can be used as BIOS, machine that uses both and fork of poky runqemu supporting the new live image. Bug-AGL: SPEC-236 Change-Id: Id99d122c05a00eb94902e8f6907455a1e681f2a3 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch36
-rw-r--r--recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb19
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch b/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch
new file mode 100644
index 0000000..c33d40c
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch
@@ -0,0 +1,36 @@
1From 2b4d519bef51d9bfb646588aa5198f71022a867b Mon Sep 17 00:00:00 2001
2From: Anton Gerasimov <anton@advancedtelematic.com>
3Date: Mon, 15 Aug 2016 15:54:20 +0200
4Subject: [PATCH] Set up environment for OSTree integration
5
6---
7 include/configs/qemu-x86.h | 15 +++++++++++++++
8 1 file changed, 15 insertions(+)
9
10diff --git a/include/configs/qemu-x86.h b/include/configs/qemu-x86.h
11index 476d37d..f49e2a5 100644
12--- a/include/configs/qemu-x86.h
13+++ b/include/configs/qemu-x86.h
14@@ -56,4 +56,19 @@
15 #undef CONFIG_ENV_IS_IN_SPI_FLASH
16 #define CONFIG_ENV_IS_NOWHERE
17
18+#undef CONFIG_BOOTARGS
19+#define CONFIG_BOOTARGS "root=/dev/hda2 console=ttyS0"
20+
21+#undef CONFIG_BOOTCOMMAND
22+#define CONFIG_BOOTCOMMAND "run loadenv;" \
23+ "ext2load ide 0:1 $loadaddr $kernel_image;" \
24+ "ext2load ide 0:1 $ramdiskaddr $ramdisk_image;" \
25+ "zboot $loadaddr - $ramdiskaddr $filesize"
26+
27+#undef CONFIG_EXTRA_ENV_SETTINGS
28+#define CONFIG_EXTRA_ENV_SETTINGS "kernel_image=/bzImage\0" \
29+ "ramdisk_image=/initrd\0" \
30+ "ramdiskaddr=0x4000000\0" \
31+ "loadenv=if ext2ls ide 0:1 /loader.0/uEnv.txt; then ext2load ide 0:1 $loadaddr uEnv.txt; env import -t $loadaddr $filesize; fi;"
32+
33 #endif /* __CONFIG_H */
34--
352.8.3
36
diff --git a/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb b/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb
new file mode 100644
index 0000000..7e3c67f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb
@@ -0,0 +1,19 @@
1include recipes-bsp/u-boot/u-boot.inc
2DEPENDS += "dtc-native"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
6
7# This revision corresponds to the tag "v2016.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "25922d42f8e9e7ae503ae55a972ba1404e5b6a8c"
11
12SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch"
13
14PV = "v2016.07+git${SRCPV}"
15
16EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
17
18UBOOT_SUFFIX = "rom"
19