summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Smirnov <evgenii.smirnov@here.com>2019-10-23 16:34:49 +0200
committerEugene Smirnov <evgenii.smirnov@here.com>2020-06-30 14:07:27 +0200
commit5b75b280f9c1edf0c9c22dc82c0f37017e8bc42f (patch)
tree67bc2899f961398304fce2888da10054632e30b6
parentdf3d58ab8e6d54f5ae945869efbf4d2cbfdb9612 (diff)
downloadmeta-updater-5b75b280f9c1edf0c9c22dc82c0f37017e8bc42f.tar.gz
Resolve multiple conflicts of NXP layers with usrmerge
Signed-off-by: Eugene Smirnov <evgenii.smirnov@here.com>
-rw-r--r--conf/layer.conf11
-rw-r--r--dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-qoriq_%.bbappend13
-rw-r--r--dynamic-layers/freescale-layer/recipes-dpaa2/dce/dce_%.bbappend4
-rw-r--r--dynamic-layers/freescale-layer/recipes-extended/dpdk/dpdk_%.bbappend39
-rw-r--r--dynamic-layers/freescale-layer/recipes-security/optee/optee-os-qoriq_%.bbappend24
-rw-r--r--dynamic-layers/freescale-layer/recipes-security/optee/optee-test-qoriq_%.bbappend11
-rw-r--r--dynamic-layers/qoriq-demos/recipes-extended/crconf/crconf_%.bbappend4
-rw-r--r--dynamic-layers/virtualization-layer/recipes-containers/cgroup-lite/cgroup-lite_%.bbappend12
-rw-r--r--recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend1
9 files changed, 119 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 035a46b..44db931 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -21,3 +21,14 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
21 aktualizr-shared-prov-creds->aktualizr \ 21 aktualizr-shared-prov-creds->aktualizr \
22 aktualizr-uboot-env-rollback->aktualizr \ 22 aktualizr-uboot-env-rollback->aktualizr \
23" 23"
24
25BBFILES_DYNAMIC += " \
26 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bb \
27 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bbappend \
28 \
29 freescale-layer:${LAYERDIR}/dynamic-layers/freescale-layer/*/*/*.bb \
30 freescale-layer:${LAYERDIR}/dynamic-layers/freescale-layer/*/*/*.bbappend \
31 \
32 qoriq-demos:${LAYERDIR}/dynamic-layers/qoriq-demos/*/*/*.bb \
33 qoriq-demos:${LAYERDIR}/dynamic-layers/qoriq-demos/*/*/*.bbappend \
34"
diff --git a/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-qoriq_%.bbappend b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-qoriq_%.bbappend
new file mode 100644
index 0000000..1b66418
--- /dev/null
+++ b/dynamic-layers/freescale-layer/recipes-bsp/u-boot/u-boot-qoriq_%.bbappend
@@ -0,0 +1,13 @@
1DEPENDS += "u-boot-mkimage-native"
2
3do_deploy_append_qoriq() {
4
5 cat > ${DEPLOYDIR}/ls1043ardb_boot.txt << EOF
6load mmc 0:2 \${load_addr} /boot/loader/uEnv.txt
7env import -t \${fileaddr} \${filesize}
8load mmc 0:2 \${load_addr} /boot\${kernel_image}
9bootm \${load_addr}
10EOF
11
12 mkimage -A arm64 -O linux -T script -d ${DEPLOYDIR}/ls1043ardb_boot.txt ${DEPLOYDIR}/ls1043ardb_boot.scr
13}
diff --git a/dynamic-layers/freescale-layer/recipes-dpaa2/dce/dce_%.bbappend b/dynamic-layers/freescale-layer/recipes-dpaa2/dce/dce_%.bbappend
new file mode 100644
index 0000000..85b55de
--- /dev/null
+++ b/dynamic-layers/freescale-layer/recipes-dpaa2/dce/dce_%.bbappend
@@ -0,0 +1,4 @@
1
2do_install () {
3 oe_runmake install DESTDIR=${D}${root_prefix}
4}
diff --git a/dynamic-layers/freescale-layer/recipes-extended/dpdk/dpdk_%.bbappend b/dynamic-layers/freescale-layer/recipes-extended/dpdk/dpdk_%.bbappend
new file mode 100644
index 0000000..994c6b2
--- /dev/null
+++ b/dynamic-layers/freescale-layer/recipes-extended/dpdk/dpdk_%.bbappend
@@ -0,0 +1,39 @@
1
2do_install() {
3 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS
4
5 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" WERROR_FLAGS="-w" V=1 T="${RTE_TARGET}" DESTDIR="${D}" install CONFIG_RTE_EAL_IGB_UIO=n CONFIG_RTE_KNI_KMOD=y CONFIG_RTE_LIBRTE_PMD_OPENSSL=y
6
7 # Build and install the DPDK examples
8 for APP in examples/l2fwd examples/l3fwd examples/l2fwd-qdma examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do
9 temp=`basename ${APP}`
10 if [ ${temp} = "ipsec-secgw" ] || [ ${temp} = "l2fwd-crypto" ]; then
11 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} CONFIG_RTE_LIBRTE_PMD_OPENSSL=y
12 else
13 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" EXTRA_CFLAGS="--sysroot=${STAGING_DIR_HOST} -I${STAGING_INCDIR}" -C ${APP}
14 fi
15
16 [ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example
17 install -m 0755 ${S}/examples/`basename ${APP}`/build/`basename ${APP}` \
18 ${D}/${bindir}/dpdk-example/
19 done
20 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C examples/vhost
21 install -m 0755 ${S}/examples/vhost/build/vhost-switch ${D}/${bindir}/dpdk-example/
22 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C examples/cmdif
23
24 install -d 0644 ${D}/usr/share/dpdk/cmdif/include
25 install -d 0644 ${D}/usr/share/dpdk/cmdif/lib
26 cp examples/cmdif/lib/client/fsl_cmdif_client.h examples/cmdif/lib/server/fsl_cmdif_server.h \
27 examples/cmdif/lib/shbp/fsl_shbp.h ${D}/usr/share/dpdk/cmdif/include
28 cp examples/cmdif/lib/${RTE_TARGET}/librte_cmdif.a ${D}/usr/share/dpdk/cmdif/lib
29
30 install -m 0755 ${S}/${RTE_TARGET}/app/testpmd ${D}/${bindir}/dpdk-example/
31 rm -fr ${D}/lib
32 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/dpdk
33 install -m 0755 ${S}/${RTE_TARGET}/kmod/rte_kni.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/dpdk
34 install -d ${D}/${bindir}/dpdk-example/extras
35 cp -rf ${S}/nxp/* ${D}/${bindir}/dpdk-example/extras/
36 rm ${D}/${datadir}/${RTE_TARGET}/app/dpdk-pmdinfogen
37
38 chown root:root -R ${D}
39}
diff --git a/dynamic-layers/freescale-layer/recipes-security/optee/optee-os-qoriq_%.bbappend b/dynamic-layers/freescale-layer/recipes-security/optee/optee-os-qoriq_%.bbappend
new file mode 100644
index 0000000..20e6216
--- /dev/null
+++ b/dynamic-layers/freescale-layer/recipes-security/optee/optee-os-qoriq_%.bbappend
@@ -0,0 +1,24 @@
1
2do_install() {
3 #install core on boot directory
4 install -d ${D}/${libdir}/firmware/
5 if [ ${MACHINE} = ls1012afrwy ]; then
6 install -m 644 ${B}/out/arm-plat-ls/core/tee_512mb.bin ${D}/${libdir}/firmware/tee_${MACHINE}_512mb.bin
7 fi
8 install -m 644 ${B}/out/arm-plat-ls/core/tee.bin ${D}/${libdir}/firmware/tee_${MACHINE}.bin
9 #install TA devkit
10 install -d ${D}/usr/include/optee/export-user_ta/
11
12 for f in ${B}/out/arm-plat-ls/export-ta_${OPTEE_ARCH}/* ; do
13 cp -aR $f ${D}/usr/include/optee/export-user_ta/
14 done
15}
16
17do_deploy() {
18 install -d ${DEPLOYDIR}/optee
19 for f in ${D}/${libdir}/firmware/*; do
20 cp $f ${DEPLOYDIR}/optee/
21 done
22}
23
24FILES_${PN} = "${libdir}/firmware/"
diff --git a/dynamic-layers/freescale-layer/recipes-security/optee/optee-test-qoriq_%.bbappend b/dynamic-layers/freescale-layer/recipes-security/optee/optee-test-qoriq_%.bbappend
new file mode 100644
index 0000000..81f1905
--- /dev/null
+++ b/dynamic-layers/freescale-layer/recipes-security/optee/optee-test-qoriq_%.bbappend
@@ -0,0 +1,11 @@
1
2do_install () {
3 install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest
4
5 # install path should match the value set in optee-client/tee-supplicant
6 # default TEEC_LOAD_PATH is /lib
7 mkdir -p ${D}/${libdir}/optee_armtz/
8 install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/${libdir}/optee_armtz/
9}
10
11FILES_${PN} += "${libdir}/optee_armtz/"
diff --git a/dynamic-layers/qoriq-demos/recipes-extended/crconf/crconf_%.bbappend b/dynamic-layers/qoriq-demos/recipes-extended/crconf/crconf_%.bbappend
new file mode 100644
index 0000000..911a20c
--- /dev/null
+++ b/dynamic-layers/qoriq-demos/recipes-extended/crconf/crconf_%.bbappend
@@ -0,0 +1,4 @@
1
2do_install () {
3 oe_runmake install DESTDIR=${D}${root_prefix}
4}
diff --git a/dynamic-layers/virtualization-layer/recipes-containers/cgroup-lite/cgroup-lite_%.bbappend b/dynamic-layers/virtualization-layer/recipes-containers/cgroup-lite/cgroup-lite_%.bbappend
new file mode 100644
index 0000000..e6c843f
--- /dev/null
+++ b/dynamic-layers/virtualization-layer/recipes-containers/cgroup-lite/cgroup-lite_%.bbappend
@@ -0,0 +1,12 @@
1
2do_install() {
3 install -d ${D}/${bindir}
4 install -m 0755 ${S}/scripts/cgroups-mount ${D}/${bindir}
5 install -m 0755 ${S}/scripts/cgroups-umount ${D}/${bindir}
6
7 install -d ${D}${sysconfdir}/init.d
8 install -m 0755 ${WORKDIR}/cgroups-init ${D}${sysconfdir}/init.d/cgroups-init
9
10 install -d ${D}${systemd_unitdir}/system
11 ln -sf /dev/null ${D}${systemd_unitdir}/system/cgroups-init.service
12}
diff --git a/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
new file mode 100644
index 0000000..5f29e63
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -0,0 +1 @@
SYSTEMTAP = ""