summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-09-03 14:01:39 +0200
committerGitHub <noreply@github.com>2020-09-03 14:01:39 +0200
commit28a16ab89ca251748faef601e05764424b9defb3 (patch)
tree8ed954e24872b644e712c334860feb36b40dbdf8
parent4e747ef6d04bab27a035c166c336a9e0e653bf94 (diff)
parent78a52b17118ec99581db175ec1173cb1ec78257f (diff)
downloadmeta-updater-28a16ab89ca251748faef601e05764424b9defb3.tar.gz
Merge pull request #769 from advancedtelematic/feat/warrior/2020.9
Feat/warrior/2020.9
-rw-r--r--classes/image_repo_manifest.bbclass7
-rw-r--r--conf/distro/sota.conf.inc2
-rw-r--r--recipes-connectivity/nfs-utils/nfs-utils/nfs-home-mount.service13
-rw-r--r--recipes-connectivity/nfs-utils/nfs-utils_%.bbappend25
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb12
-rw-r--r--recipes-test/big-update/big-update_1.0.bb2
-rw-r--r--recipes-test/big-update/big-update_2.0.bb2
-rw-r--r--scripts/qemucommand.py5
8 files changed, 59 insertions, 9 deletions
diff --git a/classes/image_repo_manifest.bbclass b/classes/image_repo_manifest.bbclass
index 72dc28f..12f56f0 100644
--- a/classes/image_repo_manifest.bbclass
+++ b/classes/image_repo_manifest.bbclass
@@ -9,10 +9,13 @@
9# For more information, see: 9# For more information, see:
10# https://web.archive.org/web/20161224194009/https://wiki.cyanogenmod.org/w/Doc:_Using_manifests 10# https://web.archive.org/web/20161224194009/https://wiki.cyanogenmod.org/w/Doc:_Using_manifests
11 11
12inherit python3native
13
12# Write build information to target filesystem 14# Write build information to target filesystem
13buildinfo_manifest () { 15buildinfo_manifest () {
14 if [ $(which repo) ]; then 16 repotool=`which repo || true`
15 repo manifest --revision-as-HEAD -o ${IMAGE_ROOTFS}${sysconfdir}/manifest.xml || bbwarn "Android repo tool failed to run; manifest not copied" 17 if [ -n "$repotool" ]; then
18 python3 $repotool manifest --revision-as-HEAD -o ${IMAGE_ROOTFS}${sysconfdir}/manifest.xml || bbwarn "Android repo tool failed to run; manifest not copied"
16 else 19 else
17 bbwarn "Android repo tool not found; manifest not copied." 20 bbwarn "Android repo tool not found; manifest not copied."
18 fi 21 fi
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index 1d5f8df..7a0ac66 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -17,4 +17,4 @@ export SOURCE_DATE_EPOCH ?= "0"
17REPRODUCIBLE_TIMESTAMP_ROOTFS ?= "0" 17REPRODUCIBLE_TIMESTAMP_ROOTFS ?= "0"
18 18
19HOSTTOOLS += "git sync sha256sum" 19HOSTTOOLS += "git sync sha256sum"
20HOSTTOOLS_NONFATAL += "java repo python" 20HOSTTOOLS_NONFATAL += "java repo"
diff --git a/recipes-connectivity/nfs-utils/nfs-utils/nfs-home-mount.service b/recipes-connectivity/nfs-utils/nfs-utils/nfs-home-mount.service
new file mode 100644
index 0000000..514151a
--- /dev/null
+++ b/recipes-connectivity/nfs-utils/nfs-utils/nfs-home-mount.service
@@ -0,0 +1,13 @@
1[Unit]
2Description=NFS home mount @LOCALSTATEDIR@/local/lib/nfs -> @LOCALSTATEDIR@/lib/nfs.
3DefaultDependencies=no
4Conflicts=umount.target
5After=local-fs.target
6
7[Service]
8ExecStartPre=@BASE_BINDIR@/mkdir -p @LOCALSTATEDIR@/lib/nfs
9ExecStart=@BASE_BINDIR@/mount -o bind @LOCALSTATEDIR@/local/lib/nfs @LOCALSTATEDIR@/lib/nfs
10RemainAfterExit=yes
11
12[Install]
13WantedBy=multi-user.target
diff --git a/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend b/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend
new file mode 100644
index 0000000..7cce775
--- /dev/null
+++ b/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend
@@ -0,0 +1,25 @@
1FILESEXTRAPATHS_prepend_sota := "${THISDIR}/${BPN}:"
2
3SRC_URI_append_sota = " file://nfs-home-mount.service"
4
5SYSTEMD_SERVICE_${PN}_append_sota = " nfs-home-mount.service"
6
7CONFFILES_${PN}-client_append_sota = " ${localstatedir}/local/lib"
8
9do_install_append_sota () {
10 install -d ${D}${localstatedir}/local
11 cp -aPR ${D}${localstatedir}/lib ${D}${localstatedir}/local
12
13 install -m 0644 ${WORKDIR}/nfs-home-mount.service ${D}${systemd_unitdir}/system/
14 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
15 -e 's,@LOCALSTATEDIR@,${localstatedir},g' \
16 ${D}${systemd_unitdir}/system/nfs-home-mount.service
17
18 sed -i -e '0,/Requires=/{s,Requires=\(.*\),Requires=\1 nfs-home-mount.service,}' \
19 -e '0,/After=/{s,After=\(.*\),After=\1 nfs-home-mount.service,}' \
20 ${D}${systemd_unitdir}/system/nfs-statd.service
21
22 sed -i -e '0,/Requires=/{s,Requires=\(.*\),Requires=\1 nfs-home-mount.service,}' \
23 -e '0,/After=/{s,After=\(.*\),After=\1 nfs-home-mount.service,}' \
24 ${D}${systemd_unitdir}/system/nfs-mountd.service
25}
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index d9b464f..69beb4b 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -17,7 +17,7 @@ PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so"
17PV = "1.0+git${SRCPV}" 17PV = "1.0+git${SRCPV}"
18PR = "7" 18PR = "7"
19 19
20GARAGE_SIGN_PV = "0.7.1-10-ga0a099a" 20GARAGE_SIGN_PV = "0.7.1-22-g1d0d714"
21 21
22SRC_URI = " \ 22SRC_URI = " \
23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ 23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \
@@ -29,10 +29,10 @@ SRC_URI = " \
29 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \ 29 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \
30 " 30 "
31 31
32SRC_URI[garagesign.md5sum] = "e2354fb75ae56c2d253be26617b2bd10" 32SRC_URI[garagesign.md5sum] = "7be214beb64ce4ae443f7a4288b6d491"
33SRC_URI[garagesign.sha256sum] = "2ddb26b19090a42d7aeeda287ed40123ffa3ab55b5dcc4ea4c9320d0a0fd59a0" 33SRC_URI[garagesign.sha256sum] = "b8524a03bb31551889790eca4ed44070f679d33a98b09e8220d7e0e965de68d8"
34 34
35SRCREV = "4169157a1874fca3fb55571c60507c1aefd4e1e5" 35SRCREV = "d4811f900c765f3b4e5b9ea76531bad7d830a691"
36BRANCH ?= "master" 36BRANCH ?= "master"
37 37
38S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
@@ -178,7 +178,9 @@ FILES_${PN}-sotatools-lib = " \
178 ${libdir}/libsota_tools.so \ 178 ${libdir}/libsota_tools.so \
179 " 179 "
180 180
181FILES_${PN}-dev = "" 181FILES_${PN}-dev = " \
182 ${includedir}/lib${PN} \
183 "
182 184
183BBCLASSEXTEND = "native" 185BBCLASSEXTEND = "native"
184 186
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb
index 3b1d652..dfb3a96 100644
--- a/recipes-test/big-update/big-update_1.0.bb
+++ b/recipes-test/big-update/big-update_1.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M)
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 7cb6e94..6fffbc1 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M)
diff --git a/scripts/qemucommand.py b/scripts/qemucommand.py
index 30929ac..9658fcd 100644
--- a/scripts/qemucommand.py
+++ b/scripts/qemucommand.py
@@ -75,7 +75,10 @@ class QemuCommand(object):
75 if args.efi: 75 if args.efi:
76 self.bios = 'OVMF.fd' 76 self.bios = 'OVMF.fd'
77 elif self.enable_u_boot: 77 elif self.enable_u_boot:
78 uboot_path = abspath(join(args.dir, self.machine, 'u-boot-qemux86-64.rom')) 78 if args.bootloader:
79 uboot_path = args.bootloader
80 else:
81 uboot_path = abspath(join(args.dir, self.machine, 'u-boot-qemux86-64.rom'))
79 if self.overlay: 82 if self.overlay:
80 new_uboot_path = self.overlay + '.u-boot.rom' 83 new_uboot_path = self.overlay + '.u-boot.rom'
81 if not exists(self.overlay): 84 if not exists(self.overlay):