summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatoliy Odukha <aodukha@gmail.com>2020-11-02 18:02:51 +0200
committerGitHub <noreply@github.com>2020-11-02 18:02:51 +0200
commitb2d70898cc09d8edbf474d09cd74b8e0cbc50d4f (patch)
treeaa8030318e8d29c8a0c04a92ce543fc56b345dfd
parentfbc67c12879d1797873b56d8f29012c69e84dae9 (diff)
parentab4f02a233efebb038cadd73e9cbaab4428b155c (diff)
downloadmeta-updater-b2d70898cc09d8edbf474d09cd74b8e0cbc50d4f.tar.gz
Merge pull request #784 from advancedtelematic/feat/thud/2020.10
aktualizr: Upgrade thud to 2020.10 release
-rw-r--r--classes/image_types_ostree.bbclass8
-rw-r--r--classes/sota.bbclass3
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb2
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov.bb2
-rw-r--r--recipes-sota/aktualizr/aktualizr-shared-prov.bb2
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb17
-rw-r--r--recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb8
-rw-r--r--recipes-support/gpgme/gpgme_%.bbappend1
-rw-r--r--recipes-support/lshw/files/cross-compile.patch39
-rw-r--r--recipes-support/lshw/files/ldflags.patch42
-rw-r--r--recipes-support/lshw/lshw_02.17.bb36
11 files changed, 22 insertions, 138 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass
index 392a42a..4fe37a3 100644
--- a/classes/image_types_ostree.bbclass
+++ b/classes/image_types_ostree.bbclass
@@ -88,7 +88,7 @@ IMAGE_CMD_ostree () {
88 if [ -n "${SYSTEMD_USED}" ]; then 88 if [ -n "${SYSTEMD_USED}" ]; then
89 echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf} 89 echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf}
90 else 90 else
91 echo "mkdir -p /var/rootdirs/${dir}; chown 755 /var/rootdirs/${dir}" >>${tmpfiles_conf} 91 echo "mkdir -p /var/rootdirs/${dir}; chmod 755 /var/rootdirs/${dir}" >>${tmpfiles_conf}
92 fi 92 fi
93 ln -sf var/rootdirs/${dir} ${dir} 93 ln -sf var/rootdirs/${dir} ${dir}
94 done 94 done
@@ -101,7 +101,7 @@ IMAGE_CMD_ostree () {
101 if [ -n "${SYSTEMD_USED}" ]; then 101 if [ -n "${SYSTEMD_USED}" ]; then
102 echo "d /var/roothome 0700 root root -" >>${tmpfiles_conf} 102 echo "d /var/roothome 0700 root root -" >>${tmpfiles_conf}
103 else 103 else
104 echo "mkdir -p /var/roothome; chown 700 /var/roothome" >>${tmpfiles_conf} 104 echo "mkdir -p /var/roothome; chmod 700 /var/roothome" >>${tmpfiles_conf}
105 fi 105 fi
106 106
107 rm -rf root 107 rm -rf root
@@ -118,7 +118,7 @@ IMAGE_CMD_ostree () {
118 if [ -n "${SYSTEMD_USED}" ]; then 118 if [ -n "${SYSTEMD_USED}" ]; then
119 echo "d /var/usrlocal 0755 root root -" >>${tmpfiles_conf} 119 echo "d /var/usrlocal 0755 root root -" >>${tmpfiles_conf}
120 else 120 else
121 echo "mkdir -p /var/usrlocal; chown 755 /var/usrlocal" >>${tmpfiles_conf} 121 echo "mkdir -p /var/usrlocal; chmod 755 /var/usrlocal" >>${tmpfiles_conf}
122 fi 122 fi
123 123
124 dirs="bin etc games include lib man sbin share src" 124 dirs="bin etc games include lib man sbin share src"
@@ -127,7 +127,7 @@ IMAGE_CMD_ostree () {
127 if [ -n "${SYSTEMD_USED}" ]; then 127 if [ -n "${SYSTEMD_USED}" ]; then
128 echo "d /var/usrlocal/${dir} 0755 root root -" >>${tmpfiles_conf} 128 echo "d /var/usrlocal/${dir} 0755 root root -" >>${tmpfiles_conf}
129 else 129 else
130 echo "mkdir -p /var/usrlocal/${dir}; chown 755 /var/usrlocal/${dir}" >>${tmpfiles_conf} 130 echo "mkdir -p /var/usrlocal/${dir}; chmod 755 /var/usrlocal/${dir}" >>${tmpfiles_conf}
131 fi 131 fi
132 done 132 done
133 133
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index fbd92b5..9241952 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -6,8 +6,7 @@ SOTA_HARDWARE_ID ??= "${MACHINE}"
6 6
7IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" 7IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest"
8IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \ 8IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \
9 ostree os-release ostree-kernel \ 9 ostree os-release ostree-kernel ostree-initramfs \
10 ${@'ostree-initramfs' if d.getVar('KERNEL_IMAGETYPE') != 'fitImage' else ''} \
11 ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" 10 ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}"
12 11
13IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}" 12IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}"
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
index 8f28c03..7239bfd 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
7 7
8inherit allarch 8inherit allarch
9 9
10# We need to get the config files from the aktualizr-host-tools package built by 10# We need to get the config files from the aktualizr-configs package built by
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13 13
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb
index 55f398d..391b098 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
7 7
8inherit allarch 8inherit allarch
9 9
10# We need to get the config files from the aktualizr-host-tools package built by 10# We need to get the config files from the aktualizr-configs package built by
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13 13
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/recipes-sota/aktualizr/aktualizr-shared-prov.bb
index 0f712df..0c54f32 100644
--- a/recipes-sota/aktualizr/aktualizr-shared-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-shared-prov.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
7 7
8inherit allarch 8inherit allarch
9 9
10# We need to get the config files from the aktualizr-host-tools package built by 10# We need to get the config files from the aktualizr-configs package built by
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}" 13RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}"
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index c73947c..1e5aa18 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -7,8 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
7 7
8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" 8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native"
9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" 9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}"
10RDEPENDS_${PN}_class-target = "${PN}-configs ${PN}-hwid lshw" 10RDEPENDS_${PN}_class-target = "${PN}-hwid lshw"
11RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}"
12 11
13RDEPENDS_${PN}-ptest += "bash cmake curl python3-misc python3-modules openssl-bin sqlite3 valgrind" 12RDEPENDS_${PN}-ptest += "bash cmake curl python3-misc python3-modules openssl-bin sqlite3 valgrind"
14 13
@@ -17,7 +16,7 @@ PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so"
17PV = "1.0+git${SRCPV}" 16PV = "1.0+git${SRCPV}"
18PR = "7" 17PR = "7"
19 18
20GARAGE_SIGN_PV = "0.7.1-22-g1d0d714" 19GARAGE_SIGN_PV = "0.7.2-9-g80ae114"
21 20
22SRC_URI = " \ 21SRC_URI = " \
23 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ 22 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \
@@ -29,10 +28,10 @@ SRC_URI = " \
29 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \ 28 ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \
30 " 29 "
31 30
32SRC_URI[garagesign.md5sum] = "7be214beb64ce4ae443f7a4288b6d491" 31SRC_URI[garagesign.md5sum] = "2598ce3a468c40a58df3304fb71ea14b"
33SRC_URI[garagesign.sha256sum] = "b8524a03bb31551889790eca4ed44070f679d33a98b09e8220d7e0e965de68d8" 32SRC_URI[garagesign.sha256sum] = "acbc814a9ed962a0d3b5bc397b14fef6a139e874e6cc3075671dab69bc8541fd"
34 33
35SRCREV = "d4811f900c765f3b4e5b9ea76531bad7d830a691" 34SRCREV = "1255aa24fe55f99b606027c8acc8cd80db29a282"
36BRANCH ?= "master" 35BRANCH ?= "master"
37 36
38S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
@@ -133,14 +132,12 @@ python split_hosttools_packages () {
133 bindir = d.getVar('bindir') 132 bindir = d.getVar('bindir')
134 133
135 # Split all binaries to their own packages. 134 # Split all binaries to their own packages.
136 do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) 135 do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='', prepend=False)
137} 136}
138 137
139PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" 138PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*"
140 139
141PACKAGES =+ "${PN}-host-tools ${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" 140PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib"
142
143ALLOW_EMPTY_${PN}-host-tools = "1"
144 141
145FILES_${PN} = " \ 142FILES_${PN} = " \
146 ${bindir}/aktualizr \ 143 ${bindir}/aktualizr \
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
index 136bb22..94010f7 100644
--- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
+++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
@@ -36,7 +36,13 @@ do_install() {
36 36
37 cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz 37 cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz
38 38
39 if [ "${KERNEL_IMAGETYPE}" != "fitImage" ]; then 39 if [ "${KERNEL_IMAGETYPE}" = "fitImage" ]; then
40 if [ -n "${INITRAMFS_IMAGE}" ]; then
41 # this is a hack for ostree not to override init= in kernel cmdline -
42 # make it think that the initramfs is present (while it is in FIT image)
43 touch $kerneldir/initramfs.img
44 fi
45 else
40 if [ -n "${INITRAMFS_IMAGE}" ]; then 46 if [ -n "${INITRAMFS_IMAGE}" ]; then
41 cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img 47 cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img
42 fi 48 fi
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend
deleted file mode 100644
index fccb949..0000000
--- a/recipes-support/gpgme/gpgme_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1BBCLASSEXTEND_append_sota = " native"
diff --git a/recipes-support/lshw/files/cross-compile.patch b/recipes-support/lshw/files/cross-compile.patch
deleted file mode 100644
index 221b7e5..0000000
--- a/recipes-support/lshw/files/cross-compile.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1---
2 src/Makefile | 2 +-
3 src/core/Makefile | 2 +-
4 src/gui/Makefile | 4 ++--
5 3 files changed, 4 insertions(+), 4 deletions(-)
6
7--- a/src/Makefile
8+++ b/src/Makefile
9@@ -18,7 +18,7 @@ export MANDIR
10 export DATADIR
11 export SQLITE
12
13-CXX?=c++
14+CXX?=$(CROSS_COMPILE)c++
15 INCLUDES=-I./core/
16 DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
17 CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
18--- a/src/core/Makefile
19+++ b/src/core/Makefile
20@@ -1,6 +1,6 @@
21 PACKAGENAME?=lshw
22
23-CXX=c++
24+CXX?=$(CROSS_COMPILE)c++
25 INCLUDES=
26 DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
27 CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
28--- a/src/gui/Makefile
29+++ b/src/gui/Makefile
30@@ -1,7 +1,7 @@
31 PACKAGENAME?=lshw
32
33-CXX?=c++
34-CC?=cc
35+CXX?=$(CROSS_COMPILE)c++
36+CC?=$(CROSS_COMPILE)cc
37 STRIP?=strip
38 OBJCOPY?=objcopy
39
diff --git a/recipes-support/lshw/files/ldflags.patch b/recipes-support/lshw/files/ldflags.patch
deleted file mode 100644
index d95699d..0000000
--- a/recipes-support/lshw/files/ldflags.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.17/src/Makefile
2--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
3+++ lshw-B.02.17/src/Makefile 2017-02-07 16:22:45.578588072 +0100
4@@ -25,9 +25,9 @@
5 ifeq ($(SQLITE), 1)
6 CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
7 endif
8-LDFLAGS=-L./core/ -g
9+LDEXTRAS=-L./core/ -g
10 ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
11- LDFLAGS+= -Wl,--as-needed
12+ LDEXTRAS+= -Wl,--as-needed
13 endif
14 LDSTATIC=-static
15 LIBS=-llshw -lresolv
16@@ -37,7 +37,7 @@
17
18 export CXXFLAGS
19 export LIBS
20-export LDFLAGS
21+export LDEXTRAS
22
23 DATAFILES = pci.ids usb.ids oui.txt manuf.txt
24
25@@ -51,7 +51,7 @@
26 +make -C core all
27
28 $(PACKAGENAME): core $(PACKAGENAME).o
29- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
30+ $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
31
32 .PHONY: po
33 po:
34@@ -69,7 +69,7 @@
35 static: $(PACKAGENAME)-static
36
37 $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
38- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
39+ $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
40 $(STRIP) $@
41
42 .PHONY: compressed
diff --git a/recipes-support/lshw/lshw_02.17.bb b/recipes-support/lshw/lshw_02.17.bb
deleted file mode 100644
index 1ecc4c1..0000000
--- a/recipes-support/lshw/lshw_02.17.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1# From meta-linaro
2# http://git.linaro.org/openembedded/meta-linaro.git
3
4DESCRIPTION = "A small tool to provide detailed information on the hardware \
5configuration of the machine. It can report exact memory configuration, \
6firmware version, mainboard configuration, CPU version and speed, cache \
7configuration, bus speed, etc. on DMI-capable or EFI systems."
8SUMMARY = "Hardware lister"
9HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
10SECTION = "console/tools"
11LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
13DEPENDS = "pciutils \
14 usbutils"
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
18 file://cross-compile.patch \
19 file://ldflags.patch \
20 "
21
22SRC_URI[md5sum] = "a5feb796cb302850eaf5b4530888e3ed"
23SRC_URI[sha256sum] = "eb9cc053fa0f1e78685cb695596e73931bfb55d2377e3bc3b8b94aff4c5a489c"
24
25S="${WORKDIR}/lshw-B.${PV}"
26
27do_compile() {
28 # build core only - don't ship gui
29 oe_runmake -C src core
30}
31
32do_install() {
33 oe_runmake install DESTDIR=${D}
34 # data files provided by dependencies
35 rm -rf ${D}/usr/share/lshw
36}