summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-03-06 10:58:00 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2019-04-26 15:58:23 +0200
commitda055c42501553fe5a6220023ff03b8dfd6ca6b8 (patch)
tree765d5a5778323b00ce4d5d03a5eeeabdf876eda0
parent6e9c599f8c7408b7ffa719649b03524683898e9c (diff)
downloadmeta-updater-da055c42501553fe5a6220023ff03b8dfd6ca6b8.tar.gz
Define virtual/network-configuration
Now provided by connman and networkd-dhcp-conf, added to images in our supported platforms Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rw-r--r--classes/sota_m3ulcb.bbclass3
-rw-r--r--classes/sota_minnowboard.bbclass5
-rw-r--r--classes/sota_porter.bbclass3
-rw-r--r--classes/sota_qemux86-64.bbclass2
-rw-r--r--classes/sota_raspberrypi.bbclass4
-rw-r--r--conf/distro/poky-sota-systemd.conf1
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend1
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb2
-rw-r--r--recipes-test/images/secondary-image.bb4
9 files changed, 16 insertions, 9 deletions
diff --git a/classes/sota_m3ulcb.bbclass b/classes/sota_m3ulcb.bbclass
index 9bbd5c2..b93cc40 100644
--- a/classes/sota_m3ulcb.bbclass
+++ b/classes/sota_m3ulcb.bbclass
@@ -7,4 +7,5 @@ IMAGE_BOOT_FILES_sota += "m3ulcb-ota-bootfiles/*"
7OSTREE_BOOTLOADER ?= "u-boot" 7OSTREE_BOOTLOADER ?= "u-boot"
8UBOOT_MACHINE_sota = "m3ulcb_defconfig" 8UBOOT_MACHINE_sota = "m3ulcb_defconfig"
9 9
10IMAGE_INSTALL_append_sota = " connman connman-client" 10PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman"
11IMAGE_INSTALL_append_sota = " virtual/network-configuration "
diff --git a/classes/sota_minnowboard.bbclass b/classes/sota_minnowboard.bbclass
index 0304ef3..a907217 100644
--- a/classes/sota_minnowboard.bbclass
+++ b/classes/sota_minnowboard.bbclass
@@ -6,6 +6,7 @@ IMAGE_BOOT_FILES_sota = ""
6 6
7IMAGE_FSTYPES_remove_sota = "live hddimg" 7IMAGE_FSTYPES_remove_sota = "live hddimg"
8OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0" 8OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0"
9
10IMAGE_INSTALL_append_sota = " connman connman-client"
11IMAGE_INSTALL_append = " minnowboard-efi-startup" 9IMAGE_INSTALL_append = " minnowboard-efi-startup"
10
11PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman"
12IMAGE_INSTALL_append_sota = " virtual/network-configuration "
diff --git a/classes/sota_porter.bbclass b/classes/sota_porter.bbclass
index 9beea33..80062e1 100644
--- a/classes/sota_porter.bbclass
+++ b/classes/sota_porter.bbclass
@@ -7,4 +7,5 @@ IMAGE_BOOT_FILES_sota += "porter-bootfiles/*"
7OSTREE_BOOTLOADER ?= "u-boot" 7OSTREE_BOOTLOADER ?= "u-boot"
8UBOOT_MACHINE_sota = "porter_config" 8UBOOT_MACHINE_sota = "porter_config"
9 9
10IMAGE_INSTALL_append_sota = " connman connman-client" 10PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman"
11IMAGE_INSTALL_append_sota = " virtual/network-configuration "
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass
index 8dae0c5..fc4aa7c 100644
--- a/classes/sota_qemux86-64.bbclass
+++ b/classes/sota_qemux86-64.bbclass
@@ -13,4 +13,4 @@ IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '655
13# fix for u-boot/swig build issue 13# fix for u-boot/swig build issue
14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc" 14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc"
15 15
16IMAGE_INSTALL_append_sota = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'networkd-dhcp-conf', '', d)} " 16IMAGE_INSTALL_append_sota = " virtual/network-configuration "
diff --git a/classes/sota_raspberrypi.bbclass b/classes/sota_raspberrypi.bbclass
index c603b23..1b54558 100644
--- a/classes/sota_raspberrypi.bbclass
+++ b/classes/sota_raspberrypi.bbclass
@@ -11,7 +11,9 @@ UBOOT_DTBO_LOADADDRESS = "0x06000000"
11 11
12# Deploy config fragment list to OSTree root fs 12# Deploy config fragment list to OSTree root fs
13IMAGE_INSTALL_append = " fit-conf" 13IMAGE_INSTALL_append = " fit-conf"
14IMAGE_INSTALL_append_sota = " connman connman-client" 14
15PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman"
16IMAGE_INSTALL_append_sota = " virtual/network-configuration "
15 17
16PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot" 18PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot"
17UBOOT_ENTRYPOINT_sota ?= "0x00008000" 19UBOOT_ENTRYPOINT_sota ?= "0x00008000"
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf
index 3b7de35..b30b322 100644
--- a/conf/distro/poky-sota-systemd.conf
+++ b/conf/distro/poky-sota-systemd.conf
@@ -9,3 +9,4 @@ DISTRO_CODENAME = "sota"
9 9
10DISTRO_FEATURES_append = " systemd" 10DISTRO_FEATURES_append = " systemd"
11VIRTUAL-RUNTIME_init_manager = "systemd" 11VIRTUAL-RUNTIME_init_manager = "systemd"
12PREFERRED_RPROVIDER_virtual/network-configuration ??= "networkd-dhcp-conf"
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
new file mode 100644
index 0000000..b3633cc
--- /dev/null
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -0,0 +1 @@
RPROVIDES_${PN} += "virtual/network-configuration"
diff --git a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
index 60eae44..39500c7 100644
--- a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
+++ b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
@@ -6,6 +6,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
6 6
7inherit systemd 7inherit systemd
8 8
9RPROVIDES_${PN} = "virtual/network-configuration"
10
9SRC_URI_append = " file://20-wired-dhcp.network" 11SRC_URI_append = " file://20-wired-dhcp.network"
10PR = "r1" 12PR = "r1"
11 13
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb
index 371d517..61df85b 100644
--- a/recipes-test/images/secondary-image.bb
+++ b/recipes-test/images/secondary-image.bb
@@ -15,9 +15,7 @@ IMAGE_INSTALL_remove = " \
15 aktualizr-ca-implicit-prov-creds \ 15 aktualizr-ca-implicit-prov-creds \
16 aktualizr-hsm-prov \ 16 aktualizr-hsm-prov \
17 aktualizr-uboot-env-rollback \ 17 aktualizr-uboot-env-rollback \
18 connman \ 18 virtual/network-configuration \
19 connman-client \
20 networkd-dhcp-conf \
21 " 19 "
22 20
23IMAGE_INSTALL_append = " \ 21IMAGE_INSTALL_append = " \