summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-01-02 18:59:00 +0200
committerLeon Anavi <leon.anavi@konsulko.com>2019-01-02 18:59:00 +0200
commitf937a223136ec2e1f7699dd6621539aca950d633 (patch)
tree70ca9465a7fe478e110d2d991955fdcb1fdccaad
parent891b967bc74ec8873081d019eda8bbfbb2bc52b7 (diff)
downloadmeta-updater-f937a223136ec2e1f7699dd6621539aca950d633.tar.gz
ostree: Bump to v2018.7
Upgrade ostree version from v2017.3 to v2018.7 because this version is known to work with the latest version of Aktualizr. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--recipes-sota/ostree/ostree_git.bb32
1 files changed, 21 insertions, 11 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 8937e5e..a5cdc9a 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -2,15 +2,15 @@ SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 4
5inherit autotools-brokensep pkgconfig systemd gobject-introspection 5inherit autotools-brokensep pkgconfig systemd bash-completion gobject-introspection
6 6
7INHERIT_remove_class-native = "systemd" 7INHERIT_remove_class-native = "systemd"
8 8
9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
10 10
11SRCREV="3b09620c2738bce4ed45e099cf2e4c5df7671d39" 11SRCREV="3e96ec9811b5cfc5481f8b6b06c8d34d9a35408e"
12 12
13PV = "2017.3-31-g3b09620c" 13PV = "v2018.7"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
@@ -22,6 +22,7 @@ DEPENDS_remove_class-native = "systemd-native"
22 22
23RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" 23RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash"
24RDEPENDS_${PN}_remove_class-native = "python-native" 24RDEPENDS_${PN}_remove_class-native = "python-native"
25RDEPENDS_${PN}-dracut = "bash"
25 26
26EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl" 27EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl"
27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" 28EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
@@ -58,6 +59,8 @@ do_compile_prepend() {
58 export HOST_SYS="${HOST_SYS}" 59 export HOST_SYS="${HOST_SYS}"
59} 60}
60 61
62SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service ostree-finalize-staged.service"
63
61export SYSTEMD_REQUIRED 64export SYSTEMD_REQUIRED
62 65
63do_install_append() { 66do_install_append() {
@@ -73,17 +76,24 @@ do_install_append_class-native() {
73 76
74 77
75FILES_${PN} += " \ 78FILES_${PN} += " \
76 ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \ 79 {bindir} \
77 ${@'${libdir}/dracut/modules.d/98ostree/module-setup.sh' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \ 80 ${sysconfdir}/ostree \
78 ${datadir}/gir-1.0 \ 81 ${datadir}/ostree \
79 ${datadir}/gir-1.0/OSTree-1.0.gir \ 82 ${libdir}/*.so.* \
80 ${libdir}/girepository-1.0 \ 83 ${libdir}/ostree/ostree-grub-generator \
81 ${libdir}/girepository-1.0/OSTree-1.0.typelib \ 84 ${libdir}/ostree/ostree-remount \
85 ${libdir}/girepository-1.0/* \
86 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \
87 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \
82" 88"
83 89
84PACKAGES =+ "${PN}-switchroot" 90PACKAGES =+ " \
91 ${PN}-switchroot \
92 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \
93"
85 94
86FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" 95FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"
87RDEPENDS_${PN}-switchroot = "" 96RDEPENDS_${PN}-switchroot = ""
88DEPENDS_remove_class-native = "systemd-native" 97DEPENDS_remove_class-native = "systemd-native"
89 98FILES_${PN}-dev += " ${datadir}/gir-1.0"
99FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut"