summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-01-24 13:29:04 +0200
committerLeon Anavi <leon.anavi@konsulko.com>2019-01-24 23:14:12 +0200
commit36c90965b1ade296c6ac69e4ba86ee353dae0ba6 (patch)
tree413c4c3767e9e0e5ac0a047c185fa7e6be5478d3
parent573dcfea040c33cf06c4ca315a8211eec9d67063 (diff)
downloadmeta-updater-36c90965b1ade296c6ac69e4ba86ee353dae0ba6.tar.gz
aktualizr: handle SOTA_HARDWARE_ID
Backport the brief bit of logic for handling SOTA_HARDWARE_ID from the recipe in the branches for newer releases. Suggested-by: Patrick Vacek <patrickvacek@gmail.com> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index e62bdf1..ced8388 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -71,6 +71,10 @@ do_install_append () {
71 install -m 0700 -d ${D}${libdir}/sota/conf.d 71 install -m 0700 -d ${D}${libdir}/sota/conf.d
72 install -m 0700 -d ${D}${sysconfdir}/sota/conf.d 72 install -m 0700 -d ${D}${sysconfdir}/sota/conf.d
73 73
74 if [ -n "${SOTA_HARDWARE_ID}" ]; then
75 echo "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml
76 fi
77
74 if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then 78 if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then
75 if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then 79 if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then
76 install -m 0700 -d ${D}${sysconfdir}/sota/ecus 80 install -m 0700 -d ${D}${sysconfdir}/sota/ecus