summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-05-21 16:59:59 +0200
committerMykhaylo Sul <ext-mykhaylo.sul@here.com>2019-07-19 20:44:15 +0200
commite63e56a3af303acec7544c4b2163fbd8f5a118e7 (patch)
tree952b0330588ba9d2daf1bd38bf68ff91c5cf4cac
parent66a93474ee59faa2ddddca574724d11c6e715967 (diff)
downloadmeta-updater-e63e56a3af303acec7544c4b2163fbd8f5a118e7.tar.gz
Add example recipe for systemd-journald configuration
Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rw-r--r--recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf3
-rw-r--r--recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb20
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf b/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf
new file mode 100644
index 0000000..a56527c
--- /dev/null
+++ b/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf
@@ -0,0 +1,3 @@
1[Journal]
2Storage=persistent
3SystemMaxUse=64M
diff --git a/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
new file mode 100644
index 0000000..1715fe1
--- /dev/null
+++ b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Configuration for systemd-journald"
2DESCRIPTION = "Provides configuration for systemd-journald, so that logs are \
3stored on persistent storage"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
6
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9SRC_URI_append = " file://10-persistent-journal.conf"
10PR = "r1"
11
12S = "${WORKDIR}"
13
14FILES_${PN} = "${systemd_unitdir}/journald.conf.d/*"
15
16do_install() {
17 install -d ${D}/${systemd_unitdir}/journald.conf.d
18 install -m 0644 ${WORKDIR}/10-persistent-journal.conf ${D}/${systemd_unitdir}/journald.conf.d
19}
20