summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Oster <jon@advancedtelematic.com>2017-05-26 11:45:19 +0200
committerJon Oster <jon@advancedtelematic.com>2017-05-29 15:46:55 +0200
commit4629b90ec53b465221ae4c72781b381b02c32dd4 (patch)
tree896e4ecc8d31649e9280bbf939220fc4dac4eac1
parent8379268522e453923514cc74ef37b9585ab4bde7 (diff)
downloadmeta-updater-4629b90ec53b465221ae4c72781b381b02c32dd4.tar.gz
PRO-3157 Add recipe for friendly name generator
-rw-r--r--recipes-sota/rvi-sota-client/rvi-sota-client_git.bb1
-rw-r--r--recipes-support/python-petname/python-petname.bb15
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index 9ba11ea..8936156 100644
--- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -151,6 +151,7 @@ RDEPENDS_${PN} = " libcrypto \
151 python \ 151 python \
152 python-canonicaljson \ 152 python-canonicaljson \
153 python-json \ 153 python-json \
154 python-petname \
154 " 155 "
155 156
156export SOTA_PACKED_CREDENTIALS 157export SOTA_PACKED_CREDENTIALS
diff --git a/recipes-support/python-petname/python-petname.bb b/recipes-support/python-petname/python-petname.bb
new file mode 100644
index 0000000..b8a7b88
--- /dev/null
+++ b/recipes-support/python-petname/python-petname.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "python-petname recipe"
2
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRCREV = "d0b767cdb1567defb104f29c3fd022239a7f231e"
7SRC_URI = "git://github.com/dustinkirkland/python-petname.git"
8S = "${WORKDIR}/git"
9
10PV = "2.2"
11inherit setuptools
12RDEPENDS_${PN} = " python-setuptools \
13 python-argparse \
14 "
15