summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-07-01 17:24:59 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2020-07-08 15:53:38 +0200
commitdecd9bcf1f613702d59dec4d0d539d60c5fa2d9d (patch)
treee5c7db1698439e5d1709f28fa6ca995f1e6670b3
parent762a4ccbeb271da9a38db41330d70cdae8eca2d3 (diff)
downloadmeta-updater-decd9bcf1f613702d59dec4d0d539d60c5fa2d9d.tar.gz
ostree-kernel-initramfs: skip recipe when OSTREE_KERNEL is not defined
* otherwise it fails with useless error: ostree-kernel-initramfs/0.0.1-r0/temp/run.do_install.3011' failed with exit code 1: cp: -r not specified; omitting directory 'tmp-glibc/deploy/images/qemux86/' WARNING: exit code 1 from a shell command. because of cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz in do_install will try to copy whole ${DEPLOY_DIR_IMAGE}/ when ${OSTREE_KERNEL} is empty as reported in: https://github.com/advancedtelematic/meta-updater/pull/740#issuecomment-651952735 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
index 1b9c0ad..6159f00 100644
--- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
+++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
@@ -51,3 +51,8 @@ do_install() {
51do_install[vardepsexclude] = "KERNEL_VERSION" 51do_install[vardepsexclude] = "KERNEL_VERSION"
52INITRAMFS_IMAGE ?= "" 52INITRAMFS_IMAGE ?= ""
53do_install[depends] = "virtual/kernel:do_deploy ${@['${INITRAMFS_IMAGE}:do_image_complete', ''][d.getVar('INITRAMFS_IMAGE') == '']}" 53do_install[depends] = "virtual/kernel:do_deploy ${@['${INITRAMFS_IMAGE}:do_image_complete', ''][d.getVar('INITRAMFS_IMAGE') == '']}"
54
55python() {
56 if not d.getVar('OSTREE_KERNEL'):
57 raise bb.parse.SkipRecipe('OSTREE_KERNEL is not defined, maybe your MACHINE config does not inherit sota.bbclass?')
58}