summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-05-04 22:45:25 -0300
committerPatrick Vacek <patrickvacek@gmail.com>2018-10-10 12:35:22 +0200
commit62cdd9f8cb1c93c2c6202e7054b678ff8a17461c (patch)
tree3fa6df2cf9fdd2121e9f69a2faf4fe30aa132642
parent9d32184d13cb0e468b0ef534b17c86c03c79e2fe (diff)
downloadmeta-updater-62cdd9f8cb1c93c2c6202e7054b678ff8a17461c.tar.gz
ostree: use do_configure_prepend and avoid customizing do_compile
Prefer prepend (autogen) and also avoid customizing do_compile as exporting BUILD_SYS and HOST_SYS is already enough. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r--recipes-sota/ostree/ostree_git.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 112d05c..240860a 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -45,18 +45,14 @@ PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/
45 45
46FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" 46FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
47 47
48export BUILD_SYS
49export HOST_SYS
48export STAGING_INCDIR 50export STAGING_INCDIR
49export STAGING_LIBDIR 51export STAGING_LIBDIR
50 52
51do_configure() { 53do_configure_prepend() {
52 unset docdir 54 unset docdir
53 NOCONFIGURE=1 "${S}/autogen.sh" 55 NOCONFIGURE=1 "${S}/autogen.sh"
54 oe_runconf
55}
56
57do_compile_prepend() {
58 export BUILD_SYS="${BUILD_SYS}"
59 export HOST_SYS="${HOST_SYS}"
60} 56}
61 57
62export SYSTEMD_REQUIRED 58export SYSTEMD_REQUIRED