summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-12-28 14:18:28 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2016-12-28 14:18:28 +0100
commit9a33370f3529c147d2ce3c3d9a8d007a95b5970e (patch)
tree190e2c7a81ed48a94a4b7f2071aaf54282daf0d4
parentd4eebc9586518a042880dc51dce16ceb1fa8ec9a (diff)
downloadmeta-updater-9a33370f3529c147d2ce3c3d9a8d007a95b5970e.tar.gz
Fixed u-boot, now can load non-OSTree image
-rw-r--r--meta-sota-minnowboard/recipes-bsp/intel-fsp/intel-fsp-native.bb3
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch18
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb (renamed from meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb)20
3 files changed, 23 insertions, 18 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/intel-fsp/intel-fsp-native.bb b/meta-sota-minnowboard/recipes-bsp/intel-fsp/intel-fsp-native.bb
index 6f87ffb..a360ae1 100644
--- a/meta-sota-minnowboard/recipes-bsp/intel-fsp/intel-fsp-native.bb
+++ b/meta-sota-minnowboard/recipes-bsp/intel-fsp/intel-fsp-native.bb
@@ -8,7 +8,8 @@ SRCREV="187409120bcba0ccc3fb514deb3bb923e9723c0c"
8 8
9inherit native 9inherit native
10 10
11FILES_${PN} = "${datadir}/IntelFsp/BayTrailFSP.fd" 11FILES_${PN} = "${datadir}/IntelFsp/BayTrailFSP.fd \
12 ${datadir}/IntelFsp/Vga.dat"
12 13
13do_install() { 14do_install() {
14 install -d ${D}${datadir}/IntelFsp 15 install -d ${D}${datadir}/IntelFsp
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
index 7540b74..f1fcd06 100644
--- a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
+++ b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
@@ -5,20 +5,24 @@ Subject: [PATCH 2/2] Replace wraps with built-in code to remove dependency on
5 multilib 5 multilib
6 6
7--- 7---
8 arch/x86/config.mk | 2 -- 8 arch/x86/config.mk | 3 ---
9 arch/x86/lib/gcc.c | 104 ++++++++++++++++++++++++++++++++++++++++++++--------- 9 arch/x86/lib/gcc.c | 104 ++++++++++++++++++++++++++++++++++++++++++++---------
10 2 files changed, 87 insertions(+), 19 deletions(-) 10 2 files changed, 87 insertions(+), 20 deletions(-)
11 11
12diff --git a/arch/x86/config.mk b/arch/x86/config.mk 12diff --git a/arch/x86/config.mk b/arch/x86/config.mk
13index 999143e..139576e 100644 13index d7addd8..892e0fc 100644
14--- a/arch/x86/config.mk 14--- a/arch/x86/config.mk
15+++ b/arch/x86/config.mk 15+++ b/arch/x86/config.mk
16@@ -22,5 +22,3 @@ PLATFORM_RELFLAGS += -ffunction-sections -fvisibility=hidden 16@@ -21,9 +21,6 @@ PLATFORM_RELFLAGS += -ffunction-sections -fvisibility=hidden
17 PLATFORM_LDFLAGS += --emit-relocs -Bsymbolic -Bsymbolic-functions -m elf_i386 17
18 18 PLATFORM_LDFLAGS += -Bsymbolic -Bsymbolic-functions -m elf_i386
19 LDFLAGS_FINAL += --gc-sections -pie 19
20-LDFLAGS_FINAL += --wrap=__divdi3 --wrap=__udivdi3 20-LDFLAGS_FINAL += --wrap=__divdi3 --wrap=__udivdi3
21-LDFLAGS_FINAL += --wrap=__moddi3 --wrap=__umoddi3 21-LDFLAGS_FINAL += --wrap=__moddi3 --wrap=__umoddi3
22-
23 # This is used in the top-level Makefile which does not include
24 # PLATFORM_LDFLAGS
25 LDFLAGS_EFI_PAYLOAD := -Bsymbolic -Bsymbolic-functions -shared --no-undefined
22diff --git a/arch/x86/lib/gcc.c b/arch/x86/lib/gcc.c 26diff --git a/arch/x86/lib/gcc.c b/arch/x86/lib/gcc.c
23index 497ad75..c321b11 100644 27index 497ad75..c321b11 100644
24--- a/arch/x86/lib/gcc.c 28--- a/arch/x86/lib/gcc.c
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
index 28b9369..fe60489 100644
--- a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb
+++ b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
@@ -1,23 +1,23 @@
1include recipes-bsp/u-boot/u-boot.inc 1include recipes-bsp/u-boot/u-boot.inc
2DEPENDS += "dtc-native intel-fsp-native" 2DEPENDS += "dtc-native intel-fsp-native iasl-native"
3 3
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" 5LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
6 6
7# This revision corresponds to the tag "v2015.07" 7# This revision corresponds to the tag "v2016.11"
8# We use the revision in order to avoid having to fetch it from the 8# We use the revision in order to avoid having to fetch it from the
9# repo during parse 9# repo during parse
10SRCREV = "baba2f57e8f4ed3fa67fe213d22da0de5e00f204" 10SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
11 11
12SRC_URI += "file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \ 12SRC_URI += "file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \
13 http://firmware.intel.com/sites/default/files/2014-WW42.4-MinnowBoardMax.73-64-bit.bin_Release.zip \ 13 http://firmware.intel.com/sites/default/files/MinnowBoard.MAX_.X64.92.R01.zip \
14 " 14 "
15 15
16# Hashes for 2014-WW42.4-MinnowBoardMax.73-64-bit.bin_Release.zip 16# Hashes for MinnowBoard.MAX_.X64.92.R01.zip
17SRC_URI[md5sum] = "1a4256c64a0d846b81d2adf7ce07cce5" 17SRC_URI[md5sum] = "236070e3d0fb193e03a102939822cf59"
18SRC_URI[sha256sum] = "883b1399b89e8e13033367e911a1e69423dffa9a6c4b5d306fc070d9ed7412b7" 18SRC_URI[sha256sum] = "708f00d835cc9c49df4e937ef59852ccb6b95026291ac9779b5411dd09baed1f"
19 19
20PV = "v2015.07+git${SRCPV}" 20PV = "v2016.11+git${SRCPV}"
21 21
22EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y" 22EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
23 23
@@ -26,7 +26,7 @@ UBOOT_SUFFIX = "rom"
26do_configure_prepend() { 26do_configure_prepend() {
27 make ${UBOOT_MACHINE} 27 make ${UBOOT_MACHINE}
28 make tools 28 make tools
29 ./tools/ifdtool -x ${WORKDIR}/MNW2MAX1.X64.0073.R02.1409160934.bin 29 ./tools/ifdtool -x ${WORKDIR}/MNW2MAX1.X64.0092.R01.1605221712.bin
30 cp flashregion_0_flashdescriptor.bin ./board/intel/minnowmax/descriptor.bin 30 cp flashregion_0_flashdescriptor.bin ./board/intel/minnowmax/descriptor.bin
31 cp flashregion_2_intel_me.bin ./board/intel/minnowmax/me.bin 31 cp flashregion_2_intel_me.bin ./board/intel/minnowmax/me.bin
32 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/BayTrailFSP.fd ./board/intel/minnowmax/fsp.bin 32 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/BayTrailFSP.fd ./board/intel/minnowmax/fsp.bin