summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbonn <lbonn@users.noreply.github.com>2018-05-18 13:29:30 +0200
committerGitHub <noreply@github.com>2018-05-18 13:29:30 +0200
commit87b0596d3c6150b9db637e1e4521123883876e2c (patch)
treeeb9ba9a4147969d411cac6ea1f74477ea8b0921d
parent872be984eadd9d57815eec8de0f2d226a68d44cd (diff)
parent496bb502458ff1f209732e91112a2ce887e34887 (diff)
downloadmeta-updater-87b0596d3c6150b9db637e1e4521123883876e2c.tar.gz
Merge pull request #20 from advancedtelematic/rocko-to-master
Rocko to master
-rw-r--r--meta-sota-raspberrypi/conf/layer.conf1
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend6
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt4
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch23
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend3
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Smack-File-receive-for-sockets.patch65
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-faytech-fix-rpi.patch33
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-smack-fix-cache-of-access-labels.patch43
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0003-Smack-ignore-null-signal-in-smack_task_kill.patch39
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch49
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend65
-rw-r--r--meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend6
-rwxr-xr-xmeta-sota-raspberrypi/scripts/flash-image.sh4
13 files changed, 31 insertions, 310 deletions
diff --git a/meta-sota-raspberrypi/conf/layer.conf b/meta-sota-raspberrypi/conf/layer.conf
index c2c3542..29e9a6c 100644
--- a/meta-sota-raspberrypi/conf/layer.conf
+++ b/meta-sota-raspberrypi/conf/layer.conf
@@ -9,3 +9,4 @@ BBFILE_COLLECTIONS += "updater-raspberrypi"
9BBFILE_PATTERN_updater-raspberrypi = "^${LAYERDIR}/" 9BBFILE_PATTERN_updater-raspberrypi = "^${LAYERDIR}/"
10BBFILE_PRIORITY_updater-raspberrypi = "7" 10BBFILE_PRIORITY_updater-raspberrypi = "7"
11 11
12LAYERSERIES_COMPAT_updater-raspberrypi = "sumo"
diff --git a/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 9222fd5..5073560 100644
--- a/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -11,13 +11,7 @@ do_deploy_append() {
11 11
12 echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 12 echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
13 echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 13 echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
14 echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
15 echo "dtoverlay=rpi-ft5406-overlay" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
16 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 14 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
17} 15}
18 16
19do_deploy_append_sota() {
20 echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
21}
22
23ENABLE_UART_raspberrypi3 = "1" 17ENABLE_UART_raspberrypi3 = "1"
diff --git a/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt b/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
index f6c0570..ede4234 100644
--- a/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
+++ b/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
@@ -3,5 +3,5 @@ bootcmd_dtb=fdt addr $fdt_addr_r; fdt get value bootargs_fdt /chosen bootargs
3bootcmd_otenv=ext2load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize 3bootcmd_otenv=ext2load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
4bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192" 4bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192"
5bootcmd_load=ext2load mmc 0:2 $kernel_addr_r "/boot"$kernel_image; ext2load mmc 0:2 $ramdisk_addr_r "/boot"$ramdisk_image 5bootcmd_load=ext2load mmc 0:2 $kernel_addr_r "/boot"$kernel_image; ext2load mmc 0:2 $ramdisk_addr_r "/boot"$ramdisk_image
6bootcmd_run=bootm $kernel_addr_r $ramdisk_addr_r $fdt_addr_r 6bootcmd_run=bootm $kernel_addr_r $ramdisk_addr_r
7bootcmd=run bootcmd_dtb; run bootcmd_otenv; run bootcmd_args; run bootcmd_load; run bootcmd_run 7bootcmd=run bootcmd_otenv; run bootcmd_args; run bootcmd_load; run bootcmd_run
diff --git a/meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch b/meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch
new file mode 100644
index 0000000..fb8fa09
--- /dev/null
+++ b/meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch
@@ -0,0 +1,23 @@
1From d6323c4aacff2922051cf801eb7c2661b437baf6 Mon Sep 17 00:00:00 2001
2From: Anton Gerasimov <anton@advancedtelematic.com>
3Date: Tue, 13 Feb 2018 15:16:00 +0100
4Subject: [PATCH] Enable FIT
5
6---
7 configs/rpi_3_32b_defconfig | 3 +++
8 1 file changed, 3 insertions(+)
9
10diff --git a/configs/rpi_3_32b_defconfig b/configs/rpi_3_32b_defconfig
11index bb56a9e4e1..b366a3a061 100644
12--- a/configs/rpi_3_32b_defconfig
13+++ b/configs/rpi_3_32b_defconfig
14@@ -36,3 +36,6 @@ CONFIG_SYS_WHITE_ON_BLACK=y
15 CONFIG_CONSOLE_SCROLL_LINES=10
16 CONFIG_PHYS_TO_BUS=y
17 CONFIG_OF_LIBFDT_OVERLAY=y
18+
19+CONFIG_FIT=y
20+CONFIG_FIT_VERBOSE=y
21--
222.15.1
23
diff --git a/meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..b99397b
--- /dev/null
+++ b/meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append = " file://0001-Enable-FIT.patch "
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Smack-File-receive-for-sockets.patch b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Smack-File-receive-for-sockets.patch
deleted file mode 100644
index 4021e5d..0000000
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-Smack-File-receive-for-sockets.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1From 2b206c36b16e72cfe41cd22448d8527359ffd962 Mon Sep 17 00:00:00 2001
2From: Casey Schaufler <casey@schaufler-ca.com>
3Date: Mon, 7 Dec 2015 14:34:32 -0800
4Subject: [PATCH 1/4] Smack: File receive for sockets
5
6The existing file receive hook checks for access on
7the file inode even for UDS. This is not right, as
8the inode is not used by Smack to make access checks
9for sockets. This change checks for an appropriate
10access relationship between the receiving (current)
11process and the socket. If the process can't write
12to the socket's send label or the socket's receive
13label can't write to the process fail.
14
15This will allow the legitimate cases, where the
16socket sender and socket receiver can freely communicate.
17Only strangly set socket labels should cause a problem.
18
19Signed-off-by: Casey Schaufler <casey@schaufler-ca.com>
20---
21 security/smack/smack_lsm.c | 22 ++++++++++++++++++++++
22 1 file changed, 22 insertions(+)
23
24diff --git a/security/smack/smack_lsm.c b/security/smack/smack_lsm.c
25index ff81026..b20ef06 100644
26--- a/security/smack/smack_lsm.c
27+++ b/security/smack/smack_lsm.c
28@@ -1860,12 +1860,34 @@ static int smack_file_receive(struct file *file)
29 int may = 0;
30 struct smk_audit_info ad;
31 struct inode *inode = file_inode(file);
32+ struct socket *sock;
33+ struct task_smack *tsp;
34+ struct socket_smack *ssp;
35
36 if (unlikely(IS_PRIVATE(inode)))
37 return 0;
38
39 smk_ad_init(&ad, __func__, LSM_AUDIT_DATA_PATH);
40 smk_ad_setfield_u_fs_path(&ad, file->f_path);
41+
42+ if (S_ISSOCK(inode->i_mode)) {
43+ sock = SOCKET_I(inode);
44+ ssp = sock->sk->sk_security;
45+ tsp = current_security();
46+ /*
47+ * If the receiving process can't write to the
48+ * passed socket or if the passed socket can't
49+ * write to the receiving process don't accept
50+ * the passed socket.
51+ */
52+ rc = smk_access(tsp->smk_task, ssp->smk_out, MAY_WRITE, &ad);
53+ rc = smk_bu_file(file, may, rc);
54+ if (rc < 0)
55+ return rc;
56+ rc = smk_access(ssp->smk_in, tsp->smk_task, MAY_WRITE, &ad);
57+ rc = smk_bu_file(file, may, rc);
58+ return rc;
59+ }
60 /*
61 * This code relies on bitmasks.
62 */
63--
642.7.4
65
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-faytech-fix-rpi.patch b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-faytech-fix-rpi.patch
deleted file mode 100644
index 00e3692..0000000
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-faytech-fix-rpi.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From f9fefc63456dd50eeec727ae2fbc13b0d84eb44e Mon Sep 17 00:00:00 2001
2From: Tom Pollard <tom.pollard@codethink.co.uk>
3Date: Wed, 6 Apr 2016 07:47:25 +0000
4Subject: [PATCH 1/1] Fix lack of touch up for Faytech 10" Touchscreen MonitorV2
5
6NOTE: This is a very temporary hack that is not in a state to be upstreamed yet.
7---
8Index: a/drivers/hid/hid-multitouch.c
9===================================================================
10--- a/drivers/hid/hid-multitouch.c 2016-07-05 08:45:06.006466000 +0000
11+++ b/drivers/hid/hid-multitouch.c 2016-07-05 08:48:44.574466000 +0000
12@@ -205,7 +205,6 @@
13 { .name = MT_CLS_WIN_8,
14 .quirks = MT_QUIRK_ALWAYS_VALID |
15 MT_QUIRK_IGNORE_DUPLICATES |
16- MT_QUIRK_HOVERING |
17 MT_QUIRK_CONTACT_CNT_ACCURATE },
18 { .name = MT_CLS_EXPORT_ALL_INPUTS,
19 .quirks = MT_QUIRK_ALWAYS_VALID |
20@@ -396,11 +395,6 @@
21 td->is_buttonpad = true;
22
23 break;
24- case 0xff0000c5:
25- /* Retrieve the Win8 blob once to enable some devices */
26- if (usage->usage_index == 0)
27- mt_get_feature(hdev, field->report);
28- break;
29 }
30 }
31
32--
331.9.1
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-smack-fix-cache-of-access-labels.patch b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-smack-fix-cache-of-access-labels.patch
deleted file mode 100644
index c516f3a..0000000
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0002-smack-fix-cache-of-access-labels.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 99267706991ab84bd44ceaea9a7ec886bbdd58e0 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Jos=C3=A9=20Bollo?= <jobol@nonadev.net>
3Date: Tue, 12 Jan 2016 21:23:40 +0100
4Subject: [PATCH 2/4] smack: fix cache of access labels
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Before this commit, removing the access property of
10a file, aka, the extended attribute security.SMACK64
11was not effictive until the cache had been cleaned.
12
13This patch fixes that problem.
14
15Signed-off-by: José Bollo <jobol@nonadev.net>
16Acked-by: Casey Schaufler <casey@schaufler-ca.com>
17---
18 security/smack/smack_lsm.c | 8 ++++++--
19 1 file changed, 6 insertions(+), 2 deletions(-)
20
21diff --git a/security/smack/smack_lsm.c b/security/smack/smack_lsm.c
22index b20ef06..b2bcb14 100644
23--- a/security/smack/smack_lsm.c
24+++ b/security/smack/smack_lsm.c
25@@ -1444,9 +1444,13 @@ static int smack_inode_removexattr(struct dentry *dentry, const char *name)
26 * Don't do anything special for these.
27 * XATTR_NAME_SMACKIPIN
28 * XATTR_NAME_SMACKIPOUT
29- * XATTR_NAME_SMACKEXEC
30 */
31- if (strcmp(name, XATTR_NAME_SMACK) == 0)
32+ if (strcmp(name, XATTR_NAME_SMACK) == 0) {
33+ struct super_block *sbp = d_backing_inode(dentry)->i_sb;
34+ struct superblock_smack *sbsp = sbp->s_security;
35+
36+ isp->smk_inode = sbsp->smk_default;
37+ } else if (strcmp(name, XATTR_NAME_SMACKEXEC) == 0)
38 isp->smk_task = NULL;
39 else if (strcmp(name, XATTR_NAME_SMACKMMAP) == 0)
40 isp->smk_mmap = NULL;
41--
422.7.4
43
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0003-Smack-ignore-null-signal-in-smack_task_kill.patch b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0003-Smack-ignore-null-signal-in-smack_task_kill.patch
deleted file mode 100644
index c9180bb..0000000
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0003-Smack-ignore-null-signal-in-smack_task_kill.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From ec4eb03af07b0fbc330aecca6ac4ebd6accd8825 Mon Sep 17 00:00:00 2001
2From: Rafal Krypa <r.krypa@samsung.com>
3Date: Mon, 4 Apr 2016 11:14:53 +0200
4Subject: [PATCH 3/4] Smack: ignore null signal in smack_task_kill
5
6Kill with signal number 0 is commonly used for checking PID existence.
7Smack treated such cases like any other kills, although no signal is
8actually delivered when sig == 0.
9
10Checking permissions when sig == 0 didn't prevent an unprivileged caller
11from learning whether PID exists or not. When it existed, kernel returned
12EPERM, when it didn't - ESRCH. The only effect of policy check in such
13case is noise in audit logs.
14
15This change lets Smack silently ignore kill() invocations with sig == 0.
16
17Signed-off-by: Rafal Krypa <r.krypa@samsung.com>
18Acked-by: Casey Schaufler <casey@schaufler-ca.com>
19---
20 security/smack/smack_lsm.c | 3 +++
21 1 file changed, 3 insertions(+)
22
23diff --git a/security/smack/smack_lsm.c b/security/smack/smack_lsm.c
24index b2bcb14..cf8a93f 100644
25--- a/security/smack/smack_lsm.c
26+++ b/security/smack/smack_lsm.c
27@@ -2239,6 +2239,9 @@ static int smack_task_kill(struct task_struct *p, struct siginfo *info,
28 struct smack_known *tkp = smk_of_task_struct(p);
29 int rc;
30
31+ if (!sig)
32+ return 0; /* null signal; existence test */
33+
34 smk_ad_init(&ad, __func__, LSM_AUDIT_DATA_TASK);
35 smk_ad_setfield_u_tsk(&ad, p);
36 /*
37--
382.7.4
39
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch
deleted file mode 100644
index a1eeac3..0000000
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From c8bbb0f916de54610513e376070aea531af19dd6 Mon Sep 17 00:00:00 2001
2From: jooseong lee <jooseong.lee@samsung.com>
3Date: Thu, 3 Nov 2016 10:55:43 +0100
4Subject: [PATCH 4/4] Smack: Assign smack_known_web label for kernel thread's
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Assign smack_known_web label for kernel thread's socket in the sk_alloc_security hook
10
11Creating struct sock by sk_alloc function in various kernel subsystems
12like bluetooth dosen't call smack_socket_post_create(). In such case,
13received sock label is the floor('_') label and makes access deny.
14
15Refers-to: https://review.tizen.org/gerrit/#/c/80717/4
16
17Change-Id: I2e5c9359bfede84a988fd4d4d74cdb9dfdfc52d8
18Signed-off-by: jooseong lee <jooseong.lee@samsung.com>
19Signed-off-by: José Bollo <jose.bollo@iot.bzh>
20---
21 security/smack/smack_lsm.c | 12 ++++++++++--
22 1 file changed, 10 insertions(+), 2 deletions(-)
23
24diff --git a/security/smack/smack_lsm.c b/security/smack/smack_lsm.c
25index cf8a93f..21651bc 100644
26--- a/security/smack/smack_lsm.c
27+++ b/security/smack/smack_lsm.c
28@@ -2321,8 +2321,16 @@ static int smack_sk_alloc_security(struct sock *sk, int family, gfp_t gfp_flags)
29 if (ssp == NULL)
30 return -ENOMEM;
31
32- ssp->smk_in = skp;
33- ssp->smk_out = skp;
34+ /*
35+ * Sockets created by kernel threads receive web label.
36+ */
37+ if (unlikely(current->flags & PF_KTHREAD)) {
38+ ssp->smk_in = &smack_known_web;
39+ ssp->smk_out = &smack_known_web;
40+ } else {
41+ ssp->smk_in = skp;
42+ ssp->smk_out = skp;
43+ }
44 ssp->smk_packet = NULL;
45
46 sk->sk_security = ssp;
47--
482.7.4
49
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index 451aa94..e2e7e60 100644
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -1,72 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2 2
3SRC_URI_append = "\
4 ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
5"
6
7do_configure_append_smack() {
8 # SMACK and Co
9 kernel_configure_variable IP_NF_SECURITY m
10 kernel_configure_variable IP6_NF_SECURITY m
11 kernel_configure_variable EXT2_FS_SECURITY y
12 kernel_configure_variable EXT3_FS_SECURITY y
13 kernel_configure_variable EXT4_FS_SECURITY y
14 kernel_configure_variable SECURITY y
15 kernel_configure_variable SECURITY_SMACK y
16 kernel_configure_variable TMPFS_XATTR y
17 kernel_configure_variable DEFAULT_SECURITY "smack"
18 kernel_configure_variable DEFAULT_SECURITY_SMACK y
19 kernel_configure_variable FANOTIFY_ACCESS_PERMISSIONS y
20}
21
22do_configure_append_netboot() {
23 # NBD for netboot
24 kernel_configure_variable BLK_DEV_NBD y
25 # ramblk for inird
26 kernel_configure_variable BLK_DEV_RAM y
27}
28
29do_configure_append_sota() { 3do_configure_append_sota() {
30 # ramblk for inird 4 # ramblk for inird
31 kernel_configure_variable BLK_DEV_RAM y 5 kernel_configure_variable BLK_DEV_RAM y
32} 6}
33 7
34do_configure_append() {
35
36 # VC4 Wayland/Weston
37 kernel_configure_variable I2C_BCM2835 y
38 kernel_configure_variable DRM y
39 kernel_configure_variable DRM_PANEL_RASPBERRYPI_TOUCHSCREEN y
40 kernel_configure_variable DRM_VC4 y
41 kernel_configure_variable FB_BCM2708 n
42
43 # Enable support for TP-Link TL-W722N USB Wifi adapter
44 kernel_configure_variable CONFIG_ATH_CARDS m
45 kernel_configure_variable CONFIG_ATH9K_HTC m
46
47 # Enable support for RTLSDR
48 kernel_configure_variable CONFIG_MEDIA_USB_SUPPORT y
49 kernel_configure_variable CONFIG_MEDIA_DIGITAL_TV_SUPPORT y
50 kernel_configure_variable CONFIG_DVB_USB_V2 m
51 kernel_configure_variable CONFIG_DVB_USB_RTL28XXU m
52
53 # KEEP until fixed upstream:
54 # Keep this the last line
55 # Remove all modified configs and add the rest to .config
56 sed -e "${CONF_SED_SCRIPT}" < '${WORKDIR}/defconfig' >> '${B}/.config'
57
58 yes '' | oe_runmake oldconfig
59 kernel_do_configure
60}
61
62CMDLINE_DEBUG = ""
63CMDLINE_append = " usbhid.mousepoll=0"
64
65# Add options to allow CMA to operate
66CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
67
68KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
69KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
70
71RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
72PACKAGES += "kernel-module-snd-bcm2835"
diff --git a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend b/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
deleted file mode 100644
index 206a8d0..0000000
--- a/meta-sota-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
1#-------------------------------------------------------------------------
2# smack patches for handling bluetooth
3
4SRC_URI_append_smack = "\
5 file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
6"
diff --git a/meta-sota-raspberrypi/scripts/flash-image.sh b/meta-sota-raspberrypi/scripts/flash-image.sh
index 74707bc..9692137 100755
--- a/meta-sota-raspberrypi/scripts/flash-image.sh
+++ b/meta-sota-raspberrypi/scripts/flash-image.sh
@@ -55,7 +55,7 @@ if [ -z "$1" ]; then
55 echo " Example: sdb" 55 echo " Example: sdb"
56 echo "" 56 echo ""
57 echo " imagefile : An image file generated by bitbake (optional)." 57 echo " imagefile : An image file generated by bitbake (optional)."
58 echo " Default: ./tmp/deploy/images/raspberrypi3/rpi-basic-image-raspberrypi3.rpi-sdimg-ota" 58 echo " Default: ./tmp/deploy/images/raspberrypi3/rpi-basic-image-raspberrypi3.wic"
59 echo "" 59 echo ""
60 echo " The following utilities are prerequisites:" 60 echo " The following utilities are prerequisites:"
61 echo "" 61 echo ""
@@ -71,7 +71,7 @@ fi
71set -euo pipefail 71set -euo pipefail
72 72
73DEVICE_TO_FLASH=$1 73DEVICE_TO_FLASH=$1
74IMAGE_TO_FLASH="${2-tmp/deploy/images/raspberrypi3/rpi-basic-image-raspberrypi3.rpi-sdimg-ota}" 74IMAGE_TO_FLASH="${2-tmp/deploy/images/raspberrypi3/rpi-basic-image-raspberrypi3.wic}"
75DEVICE_IS_REMOVABLE=$(cat /sys/block/$DEVICE_TO_FLASH/removable) 75DEVICE_IS_REMOVABLE=$(cat /sys/block/$DEVICE_TO_FLASH/removable)
76 76
77if [[ $DEVICE_IS_REMOVABLE != "1" ]]; then 77if [[ $DEVICE_IS_REMOVABLE != "1" ]]; then