summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2018-02-21 16:49:01 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2018-02-21 16:49:01 +0100
commit3c25c32e7aa2913539406ed0ff8a32d405fc615c (patch)
tree25cd8a8190cd848a53b58d92dacb4c29b329148a
parent27d143ed7d3dc5dd0dfb99ef9d2005e0b84ccdc1 (diff)
downloadmeta-updater-3c25c32e7aa2913539406ed0ff8a32d405fc615c.tar.gz
Add support to FIT images and don't use DTB provided by the bootloader
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend6
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt4
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch23
-rw-r--r--meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend3
4 files changed, 28 insertions, 8 deletions
diff --git a/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 9222fd5..5073560 100644
--- a/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-sota-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -11,13 +11,7 @@ do_deploy_append() {
11 11
12 echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 12 echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
13 echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 13 echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
14 echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
15 echo "dtoverlay=rpi-ft5406-overlay" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
16 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 14 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
17} 15}
18 16
19do_deploy_append_sota() {
20 echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
21}
22
23ENABLE_UART_raspberrypi3 = "1" 17ENABLE_UART_raspberrypi3 = "1"
diff --git a/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt b/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
index f6c0570..ede4234 100644
--- a/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
+++ b/meta-sota-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
@@ -3,5 +3,5 @@ bootcmd_dtb=fdt addr $fdt_addr_r; fdt get value bootargs_fdt /chosen bootargs
3bootcmd_otenv=ext2load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize 3bootcmd_otenv=ext2load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
4bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192" 4bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192"
5bootcmd_load=ext2load mmc 0:2 $kernel_addr_r "/boot"$kernel_image; ext2load mmc 0:2 $ramdisk_addr_r "/boot"$ramdisk_image 5bootcmd_load=ext2load mmc 0:2 $kernel_addr_r "/boot"$kernel_image; ext2load mmc 0:2 $ramdisk_addr_r "/boot"$ramdisk_image
6bootcmd_run=bootm $kernel_addr_r $ramdisk_addr_r $fdt_addr_r 6bootcmd_run=bootm $kernel_addr_r $ramdisk_addr_r
7bootcmd=run bootcmd_dtb; run bootcmd_otenv; run bootcmd_args; run bootcmd_load; run bootcmd_run 7bootcmd=run bootcmd_otenv; run bootcmd_args; run bootcmd_load; run bootcmd_run
diff --git a/meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch b/meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch
new file mode 100644
index 0000000..fb8fa09
--- /dev/null
+++ b/meta-sota-raspberrypi/recipes-bsp/u-boot/files/0001-Enable-FIT.patch
@@ -0,0 +1,23 @@
1From d6323c4aacff2922051cf801eb7c2661b437baf6 Mon Sep 17 00:00:00 2001
2From: Anton Gerasimov <anton@advancedtelematic.com>
3Date: Tue, 13 Feb 2018 15:16:00 +0100
4Subject: [PATCH] Enable FIT
5
6---
7 configs/rpi_3_32b_defconfig | 3 +++
8 1 file changed, 3 insertions(+)
9
10diff --git a/configs/rpi_3_32b_defconfig b/configs/rpi_3_32b_defconfig
11index bb56a9e4e1..b366a3a061 100644
12--- a/configs/rpi_3_32b_defconfig
13+++ b/configs/rpi_3_32b_defconfig
14@@ -36,3 +36,6 @@ CONFIG_SYS_WHITE_ON_BLACK=y
15 CONFIG_CONSOLE_SCROLL_LINES=10
16 CONFIG_PHYS_TO_BUS=y
17 CONFIG_OF_LIBFDT_OVERLAY=y
18+
19+CONFIG_FIT=y
20+CONFIG_FIT_VERBOSE=y
21--
222.15.1
23
diff --git a/meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..b99397b
--- /dev/null
+++ b/meta-sota-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append = " file://0001-Enable-FIT.patch "