summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2018-05-18 14:28:57 +0200
committerLaurent Bonnans <laurent.bonnans@here.com>2018-05-18 14:28:57 +0200
commit386dd637903de2f747512477dabf7a5278ebba41 (patch)
treee0f312896f712d8a2fa9a982ef2923b6033e51a3
parent07151ad0bbc84b83333b6535c85d2f74e52dc86b (diff)
downloadmeta-updater-386dd637903de2f747512477dabf7a5278ebba41.tar.gz
Remove u-boot support for minnowboard
Was already broken
-rw-r--r--meta-sota-minnowboard/recipes-bsp/bootfiles/files/uEnv-ota.txt17
-rw-r--r--meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb25
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0001-Load-environment-from-the-boot-partition.patch24
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch142
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb36
5 files changed, 0 insertions, 244 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/bootfiles/files/uEnv-ota.txt b/meta-sota-minnowboard/recipes-bsp/bootfiles/files/uEnv-ota.txt
deleted file mode 100644
index 2b0f293..0000000
--- a/meta-sota-minnowboard/recipes-bsp/bootfiles/files/uEnv-ota.txt
+++ /dev/null
@@ -1,17 +0,0 @@
1bootkaddr=0x01000000
2bootiaddr=0x04000000
3
4bootargs_console=console=ttyS0,115200
5bootargs_extra=rw rootfstype=ext4 rootwait rootdelay=2
6
7bootargs_root=ostree_root=/dev/mmcblk0p2 root=/dev/ram0 ramdisk_size=16384
8
9bootmmc=1:2
10
11booteload_sd=ext4load mmc ${bootmmc} ${bootkaddr} boot/loader/uEnv.txt; env import -t ${bootkaddr} ${filesize}
12
13bootkload_sd=ext4load mmc ${bootmmc} ${bootkaddr} boot/${kernel_image}
14bootiload_sd=ext4load mmc ${bootmmc} ${bootiaddr} boot/${ramdisk_image}
15
16bootcmd=run booteload_sd; setenv bootargs ${bootargs} ${bootargs_console} ${bootargs_root} ${bootargs_extra}; run bootkload_sd; run bootiload_sd; zboot ${bootkaddr} - ${bootiaddr} ${filesize}
17
diff --git a/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb
deleted file mode 100644
index 74d1f18..0000000
--- a/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "Boot files (bootscripts etc.) for Minnowboard Max/Turbot"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5inherit deploy
6
7COMPATIBLE_MACHINE = "intel-corei7-64"
8
9S = "${WORKDIR}"
10
11SRC_URI_append_sota = "file://uEnv-ota.txt"
12
13do_deploy() {
14 install -d ${DEPLOYDIR}/${PN}
15}
16
17do_deploy_append_sota() {
18 install -m 0755 ${WORKDIR}/uEnv-ota.txt ${DEPLOYDIR}/${PN}/uEnv.txt
19}
20
21addtask deploy before do_package after do_install
22do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0001-Load-environment-from-the-boot-partition.patch b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0001-Load-environment-from-the-boot-partition.patch
deleted file mode 100644
index 02d0e4c..0000000
--- a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0001-Load-environment-from-the-boot-partition.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From 0161adf28590d95eaf234acc97156bc7dd989c8c Mon Sep 17 00:00:00 2001
2From: Anton Gerasimov <anton@advancedtelematic.com>
3Date: Wed, 28 Dec 2016 16:53:35 +0100
4Subject: [PATCH] Load environment from the boot partition
5
6---
7 include/configs/minnowmax.h | 3 +++
8 1 file changed, 3 insertions(+)
9
10diff --git a/include/configs/minnowmax.h b/include/configs/minnowmax.h
11index 3aa22d2..02f6980 100644
12--- a/include/configs/minnowmax.h
13+++ b/include/configs/minnowmax.h
14@@ -41,4 +41,7 @@
15 #define CONFIG_ENV_SECT_SIZE 0x1000
16 #define CONFIG_ENV_OFFSET 0x006ef000
17
18+#undef CONFIG_BOOTCOMMAND
19+#define CONFIG_BOOTCOMMAND "fatload mmc 1:1 0x01000000 uEnv.txt; env import -t 0x01000000 ${filesize}; run bootcmd"
20+
21 #endif /* __CONFIG_H */
22--
232.9.3
24
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
deleted file mode 100644
index f1fcd06..0000000
--- a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
+++ /dev/null
@@ -1,142 +0,0 @@
1From ab0d7e270d89f6eb99582197d2d58bf60c9c3d26 Mon Sep 17 00:00:00 2001
2From: Anton Gerasimov <anton@advancedtelematic.com>
3Date: Thu, 15 Sep 2016 16:49:32 +0200
4Subject: [PATCH 2/2] Replace wraps with built-in code to remove dependency on
5 multilib
6
7---
8 arch/x86/config.mk | 3 ---
9 arch/x86/lib/gcc.c | 104 ++++++++++++++++++++++++++++++++++++++++++++---------
10 2 files changed, 87 insertions(+), 20 deletions(-)
11
12diff --git a/arch/x86/config.mk b/arch/x86/config.mk
13index d7addd8..892e0fc 100644
14--- a/arch/x86/config.mk
15+++ b/arch/x86/config.mk
16@@ -21,9 +21,6 @@ PLATFORM_RELFLAGS += -ffunction-sections -fvisibility=hidden
17
18 PLATFORM_LDFLAGS += -Bsymbolic -Bsymbolic-functions -m elf_i386
19
20-LDFLAGS_FINAL += --wrap=__divdi3 --wrap=__udivdi3
21-LDFLAGS_FINAL += --wrap=__moddi3 --wrap=__umoddi3
22-
23 # This is used in the top-level Makefile which does not include
24 # PLATFORM_LDFLAGS
25 LDFLAGS_EFI_PAYLOAD := -Bsymbolic -Bsymbolic-functions -shared --no-undefined
26diff --git a/arch/x86/lib/gcc.c b/arch/x86/lib/gcc.c
27index 497ad75..c321b11 100644
28--- a/arch/x86/lib/gcc.c
29+++ b/arch/x86/lib/gcc.c
30@@ -19,22 +19,92 @@
31
32 #ifdef __GNUC__
33
34-/*
35- * GCC's libgcc handling is quite broken. While the libgcc functions
36- * are always regparm(0) the code that calls them uses whatever the
37- * compiler call specifies. Therefore we need a wrapper around those
38- * functions. See gcc bug PR41055 for more information.
39- */
40-#define WRAP_LIBGCC_CALL(type, name) \
41- type __normal_##name(type a, type b) __attribute__((regparm(0))); \
42- type __wrap_##name(type a, type b); \
43- type __attribute__((no_instrument_function)) \
44- __wrap_##name(type a, type b) \
45- { return __normal_##name(a, b); }
46-
47-WRAP_LIBGCC_CALL(long long, __divdi3)
48-WRAP_LIBGCC_CALL(unsigned long long, __udivdi3)
49-WRAP_LIBGCC_CALL(long long, __moddi3)
50-WRAP_LIBGCC_CALL(unsigned long long, __umoddi3)
51+#include <stdint.h>
52+#include <stddef.h>
53+
54+uint64_t __udivmoddi4 ( uint64_t num,
55+ uint64_t den,
56+ uint64_t *rem_p )
57+{
58+ uint64_t quot = 0, qbit = 1;
59+
60+ if ( den == 0 ) {
61+ return 1/((unsigned)den); /* Intentional divide by zero, without
62+ triggering a compiler warning which
63+ would abort the build */
64+ }
65+
66+ /* Left-justify denominator and count shift */
67+ while ( (int64_t)den >= 0 ) {
68+ den <<= 1;
69+ qbit <<= 1;
70+ }
71+
72+ while ( qbit ) {
73+ if ( den <= num ) {
74+ num -= den;
75+ quot += qbit;
76+ }
77+ den >>= 1;
78+ qbit >>= 1;
79+ }
80+
81+ if ( rem_p )
82+ *rem_p = num;
83+
84+ return quot;
85+}
86+uint64_t __udivdi3( uint64_t num, uint64_t den )
87+{
88+ return __udivmoddi4(num, den, NULL);
89+}
90+
91+uint64_t __umoddi3 ( uint64_t num, uint64_t den )
92+{
93+ uint64_t v;
94+
95+ (void) __udivmoddi4(num, den, &v);
96+ return v;
97+}
98+
99+int64_t __divmoddi4 ( int64_t num,
100+ int64_t den,
101+ int64_t* rem_p )
102+{
103+ int minus = 0;
104+ int64_t v;
105+
106+ if ( num < 0 ) {
107+ num = -num;
108+ minus = 1;
109+ }
110+ if ( den < 0 ) {
111+ den = -den;
112+ minus ^= 1;
113+ }
114+
115+ v = __udivmoddi4(num, den, (uint64_t *)rem_p);
116+ if ( minus ) {
117+ v = -v;
118+ if ( rem_p )
119+ *rem_p = -(*rem_p);
120+ }
121+
122+ return v;
123+}
124+
125+
126+int64_t __moddi3 (int64_t num, int64_t den)
127+{
128+ int64_t v;
129+
130+ (void) __divmoddi4(num, den, &v);
131+ return v;
132+}
133+
134+int64_t __divdi3(int64_t num, int64_t den)
135+{
136+ return __divmoddi4(num, den, NULL);
137+}
138
139 #endif
140--
1412.9.3
142
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
deleted file mode 100644
index c0603f0..0000000
--- a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1include recipes-bsp/u-boot/u-boot.inc
2DEPENDS += "dtc-native intel-fsp-native iasl-native"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
6
7# This revision corresponds to the tag "v2016.11"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
11
12SRC_URI += "file://0001-Load-environment-from-the-boot-partition.patch \
13 file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \
14 http://firmware.intel.com/sites/default/files/MinnowBoard.MAX_.X64.92.R01.zip \
15 "
16
17# Hashes for MinnowBoard.MAX_.X64.92.R01.zip
18SRC_URI[md5sum] = "236070e3d0fb193e03a102939822cf59"
19SRC_URI[sha256sum] = "708f00d835cc9c49df4e937ef59852ccb6b95026291ac9779b5411dd09baed1f"
20
21PV = "v2016.11+git${SRCPV}"
22
23EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
24
25UBOOT_SUFFIX = "rom"
26
27do_configure_prepend() {
28 make ${UBOOT_MACHINE}
29 make tools
30 ./tools/ifdtool -x ${WORKDIR}/MNW2MAX1.X64.0092.R01.1605221712.bin
31 cp flashregion_0_flashdescriptor.bin ./board/intel/minnowmax/descriptor.bin
32 cp flashregion_2_intel_me.bin ./board/intel/minnowmax/me.bin
33 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/BayTrailFSP.fd ./board/intel/minnowmax/fsp.bin
34 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/Vga.dat ./board/intel/minnowmax/vga.bin
35}
36