summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton.gerasimov@openmailbox.org>2018-01-16 18:47:15 +0100
committerAnton Gerasimov <anton.gerasimov@openmailbox.org>2018-01-16 18:47:15 +0100
commit18c67dcead8bb7eb0cfa9bb63196bb3159b8607a (patch)
tree7c532ed3e631da768db49d678d8cc416e95d82d5
parent1b75e3e9262cbeca0acb06ef075c635e1dc0b650 (diff)
downloadmeta-updater-18c67dcead8bb7eb0cfa9bb63196bb3159b8607a.tar.gz
Deploy EFI startup.nsh for Minnowboard Max
-rw-r--r--meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb
new file mode 100644
index 0000000..0ad740b
--- /dev/null
+++ b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb
@@ -0,0 +1,11 @@
1DESCRIPTION = "startup.nsh for minnowboard using grub"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5COMPATIBLE_MACHINE = "intel-corei7-64"
6ALLOW_EMPTY_${PN} = "1"
7
8do_install() {
9 echo "fs0:\EFI\BOOT\bootx64.efi" > ${DEPLOY_DIR_IMAGE}/startup.nsh
10}
11