summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2019-07-02 14:00:23 -0300
committerRicardo Salveti <ricardo@foundries.io>2019-07-03 21:55:10 -0300
commit30d347574cdef5498ec6f090f471e83e149a431c (patch)
tree6790ecb65392f660882ea1b39ead10e5b12419d4
parent37201eba4e17aea092a242b793424135cba3c8b8 (diff)
downloadmeta-updater-30d347574cdef5498ec6f090f471e83e149a431c.tar.gz
libp11: remove recipe, prefer recipe from meta-oe
meta-oe now ships with libp11 0.4.10, which is newer than the revision used by this recipe. Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
-rw-r--r--recipes-support/libp11/libp11_git.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/recipes-support/libp11/libp11_git.bb b/recipes-support/libp11/libp11_git.bb
deleted file mode 100644
index bedcdc8..0000000
--- a/recipes-support/libp11/libp11_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10RDEPENDS_${PN} += " opensc"
11
12SRC_URI = "git://github.com/OpenSC/libp11.git"
13SRCREV = "57ca68ff67efa08e3be1f26dec6d23bf5bb977f2"
14
15PV = "0.4.9+git${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21# Currently, Makefile dependencies are incorrectly defined which causes build errors
22# if the number of jobs is high
23# See https://github.com/OpenSC/libp11/issues/94
24PARALLEL_MAKE = ""
25EXTRA_OECONF = "--disable-static"
26
27do_install_append () {
28 rm -rf ${D}${libdir}/*.la
29 rm -rf ${D}${docdir}/${BPN}
30}
31
32FILES_${PN} = "${libdir}/engines*/pkcs11.so \
33 ${libdir}/engines*/libpkcs11${SOLIBS} \
34 ${libdir}/libp11${SOLIBS}"
35
36FILES_${PN}-dev = " \
37 ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
38 ${libdir}/libp11${SOLIBSDEV} \
39 ${libdir}/pkgconfig/libp11.pc \
40 /usr/include"