summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-07-11 14:12:49 +0200
committerGitHub <noreply@github.com>2019-07-11 14:12:49 +0200
commitf68e1d59f0a0ed4341dad3b16d4979b1b63336d7 (patch)
treeca09b8b8fcd5dcef30a49fe45368d655a89afc9e
parent6a11a18f290707975f1cbc43f247aa52fa5cf050 (diff)
parentc1de33deb2a5d2d928830329ee08d0e48606b1a5 (diff)
downloadmeta-updater-f68e1d59f0a0ed4341dad3b16d4979b1b63336d7.tar.gz
Merge pull request #536 from ricardosalveti/master
Use libp11 from meta-oe upstream
-rw-r--r--recipes-support/libp11/libp11_git.bb40
-rw-r--r--recipes-support/softhsm-testtoken/softhsm-testtoken.bb2
2 files changed, 1 insertions, 41 deletions
diff --git a/recipes-support/libp11/libp11_git.bb b/recipes-support/libp11/libp11_git.bb
deleted file mode 100644
index bedcdc8..0000000
--- a/recipes-support/libp11/libp11_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10RDEPENDS_${PN} += " opensc"
11
12SRC_URI = "git://github.com/OpenSC/libp11.git"
13SRCREV = "57ca68ff67efa08e3be1f26dec6d23bf5bb977f2"
14
15PV = "0.4.9+git${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21# Currently, Makefile dependencies are incorrectly defined which causes build errors
22# if the number of jobs is high
23# See https://github.com/OpenSC/libp11/issues/94
24PARALLEL_MAKE = ""
25EXTRA_OECONF = "--disable-static"
26
27do_install_append () {
28 rm -rf ${D}${libdir}/*.la
29 rm -rf ${D}${docdir}/${BPN}
30}
31
32FILES_${PN} = "${libdir}/engines*/pkcs11.so \
33 ${libdir}/engines*/libpkcs11${SOLIBS} \
34 ${libdir}/libp11${SOLIBS}"
35
36FILES_${PN}-dev = " \
37 ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
38 ${libdir}/libp11${SOLIBSDEV} \
39 ${libdir}/pkgconfig/libp11.pc \
40 /usr/include"
diff --git a/recipes-support/softhsm-testtoken/softhsm-testtoken.bb b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
index 58b521c..68514b2 100644
--- a/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
+++ b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit systemd 5inherit systemd
6 6
7RDEPENDS_${PN} = "softhsm libp11 openssl-bin" 7RDEPENDS_${PN} = "softhsm libp11 opensc openssl-bin"
8DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 8DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
9 9
10 10