summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-02-09 00:54:15 -0200
committerLaurent Bonnans <laurent.bonnans@here.com>2018-05-15 10:54:51 +0200
commit6ce668bc1ca33ae88ba6b51dee1e680212247539 (patch)
tree6eeeb7ada757b51a3dc8225aba2f0b1e942270f1
parent3af1b32743b245be8c4e199c6a3785bc92e93ab1 (diff)
downloadmeta-updater-6ce668bc1ca33ae88ba6b51dee1e680212247539.tar.gz
ostree: fix systemd service files permission
Fix the following boot warning: systemd[1]: Configuration file /usr/lib/systemd/system/ostree-remount.service is marked executable. Please remove executable permission bits. Proceeding anyway. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r--recipes-sota/ostree/ostree_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index ad85775..2db96e4 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -63,8 +63,8 @@ export SYSTEMD_REQUIRED
63 63
64do_install_append() { 64do_install_append() {
65 if [ -n ${SYSTEMD_REQUIRED} ]; then 65 if [ -n ${SYSTEMD_REQUIRED} ]; then
66 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service 66 install -m 0644 -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
67 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service 67 install -m 0644 -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
68 fi 68 fi
69} 69}
70 70