summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2020-10-15 12:27:10 -0300
committerRicardo Salveti <ricardo@foundries.io>2020-10-15 14:21:11 -0300
commitf9e462ef42bcf79beb2b354b5a1c069c8e47d65d (patch)
tree2825eb1c431cbee4e77d7a0ec087aa5555fbe0b3
parent67ab5b0333cf2c63a6099bab655b836d1b62db78 (diff)
downloadmeta-updater-f9e462ef42bcf79beb2b354b5a1c069c8e47d65d.tar.gz
ostree-kernel-initramfs: add back initramfs fit workaround
Previous initramfs fit specific workaround was removed as part of commit 6eecf1593d, causing ostree to provide an init argument as part of the kernel command line arguments when it is not really needed. Bring back the workaround by simply generating an empty file in case kernel image type is fit and initramfs is also used by the target. Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
-rw-r--r--classes/sota.bbclass3
-rw-r--r--recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb8
2 files changed, 8 insertions, 3 deletions
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index e6a0f8b..8f3f5d7 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -6,8 +6,7 @@ SOTA_HARDWARE_ID ??= "${MACHINE}"
6 6
7IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" 7IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest"
8IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \ 8IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \
9 ostree os-release ostree-kernel \ 9 ostree os-release ostree-kernel ostree-initramfs \
10 ${@'ostree-initramfs' if d.getVar('KERNEL_IMAGETYPE') != 'fitImage' else ''} \
11 ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" 10 ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}"
12 11
13IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}" 12IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}"
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
index 9ac90b9..9a229ba 100644
--- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
+++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
@@ -36,7 +36,13 @@ do_install() {
36 36
37 cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz 37 cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz
38 38
39 if [ "${KERNEL_IMAGETYPE}" != "fitImage" ]; then 39 if [ "${KERNEL_IMAGETYPE}" = "fitImage" ]; then
40 if [ -n "${INITRAMFS_IMAGE}" ]; then
41 # this is a hack for ostree not to override init= in kernel cmdline -
42 # make it think that the initramfs is present (while it is in FIT image)
43 touch $kerneldir/initramfs.img
44 fi
45 else
40 if [ -n "${INITRAMFS_IMAGE}" ]; then 46 if [ -n "${INITRAMFS_IMAGE}" ]; then
41 cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img 47 cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img
42 fi 48 fi