summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-08-03 08:58:53 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2020-08-03 13:47:30 +0200
commit628c4e317618d1b03da41e43cf0ede69c1fa4695 (patch)
treeb389457e32963338ce779431ed8cebb5d11ed23e
parent5f7f0d139b3c81e163ad46d366cf1d843c3cb793 (diff)
downloadmeta-updater-628c4e317618d1b03da41e43cf0ede69c1fa4695.tar.gz
Inherit python3native instead of using HOSTTOOLS.fix/pythonnative
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--classes/image_repo_manifest.bbclass2
-rw-r--r--conf/distro/sota.conf.inc2
-rw-r--r--recipes-test/big-update/big-update_1.0.bb2
-rw-r--r--recipes-test/big-update/big-update_2.0.bb2
4 files changed, 7 insertions, 1 deletions
diff --git a/classes/image_repo_manifest.bbclass b/classes/image_repo_manifest.bbclass
index 72dc28f..47692df 100644
--- a/classes/image_repo_manifest.bbclass
+++ b/classes/image_repo_manifest.bbclass
@@ -9,6 +9,8 @@
9# For more information, see: 9# For more information, see:
10# https://web.archive.org/web/20161224194009/https://wiki.cyanogenmod.org/w/Doc:_Using_manifests 10# https://web.archive.org/web/20161224194009/https://wiki.cyanogenmod.org/w/Doc:_Using_manifests
11 11
12inherit python3native
13
12# Write build information to target filesystem 14# Write build information to target filesystem
13buildinfo_manifest () { 15buildinfo_manifest () {
14 if [ $(which repo) ]; then 16 if [ $(which repo) ]; then
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index 9804694..99035de 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -18,4 +18,4 @@ export SOURCE_DATE_EPOCH = "0"
18REPRODUCIBLE_TIMESTAMP_ROOTFS = "0" 18REPRODUCIBLE_TIMESTAMP_ROOTFS = "0"
19 19
20HOSTTOOLS += "git sync sha256sum" 20HOSTTOOLS += "git sync sha256sum"
21HOSTTOOLS_NONFATAL += "java repo python" 21HOSTTOOLS_NONFATAL += "java repo"
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb
index 3b1d652..dfb3a96 100644
--- a/recipes-test/big-update/big-update_1.0.bb
+++ b/recipes-test/big-update/big-update_1.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M)
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 7cb6e94..6fffbc1 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M)