summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-03-09 09:13:00 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2019-04-29 09:12:02 +0200
commitf5c5ac3e444b765bfcd48b1a6d2b63ef7aec54aa (patch)
tree8c982fc3e486b74d03928c9bb2fd6e0bbaedf085
parentb78e63f136aaa20f749bd1f81e776808a72af6bb (diff)
downloadmeta-updater-f5c5ac3e444b765bfcd48b1a6d2b63ef7aec54aa.tar.gz
aktualizr: use echo -e when using escape sequences
Some shell require the -e argument when using escape sequences in echo. This has been observed when building images on a Fedora machine, where the configuration files ended up including "\n" sequences instead of newlines. Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 9a51681..3c029d6 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -69,14 +69,14 @@ do_install_append () {
69 install -m 0700 -d ${D}${sysconfdir}/sota/conf.d 69 install -m 0700 -d ${D}${sysconfdir}/sota/conf.d
70 70
71 if [ -n "${SOTA_HARDWARE_ID}" ]; then 71 if [ -n "${SOTA_HARDWARE_ID}" ]; then
72 echo "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml 72 echo -e "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml
73 fi 73 fi
74 74
75 if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then 75 if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then
76 if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then 76 if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then
77 install -m 0700 -d ${D}${sysconfdir}/sota/ecus 77 install -m 0700 -d ${D}${sysconfdir}/sota/ecus
78 install -m 0644 "${SOTA_SECONDARY_CONFIG_DIR}"/* ${D}${sysconfdir}/sota/ecus/ 78 install -m 0644 "${SOTA_SECONDARY_CONFIG_DIR}"/* ${D}${sysconfdir}/sota/ecus/
79 echo "[uptane]\nsecondary_configs_dir = /etc/sota/ecus/\n" > ${D}${libdir}/sota/conf.d/30-secondary-configs-dir.toml 79 echo -e "[uptane]\nsecondary_configs_dir = /etc/sota/ecus/\n" > ${D}${libdir}/sota/conf.d/30-secondary-configs-dir.toml
80 else 80 else
81 bbwarn "SOTA_SECONDARY_CONFIG_DIR is set to an invalid directory (${SOTA_SECONDARY_CONFIG_DIR})" 81 bbwarn "SOTA_SECONDARY_CONFIG_DIR is set to an invalid directory (${SOTA_SECONDARY_CONFIG_DIR})"
82 fi 82 fi