summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-03-05 18:02:10 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2019-04-26 15:57:52 +0200
commit26d2a79bc74deacdc7d92206245538998caa1fa5 (patch)
treecfc1429ed90253b03808cabe96b489e75502ff6d
parentc4855e5d6ed4778227444dcae1c03f0abb71c399 (diff)
downloadmeta-updater-26d2a79bc74deacdc7d92206245538998caa1fa5.tar.gz
Replace connman with systemd-networkd on qemux86-64
Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rw-r--r--classes/sota_qemux86-64.bbclass2
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network5
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb23
-rw-r--r--recipes-test/images/secondary-image.bb1
4 files changed, 30 insertions, 1 deletions
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass
index 5d82bde..6b1ed94 100644
--- a/classes/sota_qemux86-64.bbclass
+++ b/classes/sota_qemux86-64.bbclass
@@ -13,4 +13,4 @@ IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '655
13# fix for u-boot/swig build issue 13# fix for u-boot/swig build issue
14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc" 14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc"
15 15
16IMAGE_INSTALL_append_sota = " connman connman-client" 16IMAGE_INSTALL_append_sota = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'networkd-dhcp-conf', '', d)} "
diff --git a/recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network b/recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network
new file mode 100644
index 0000000..aec1849
--- /dev/null
+++ b/recipes-connectivity/networkd-dhcp-conf/files/20-wired-dhcp.network
@@ -0,0 +1,5 @@
1[Match]
2Name=en*
3
4[Network]
5DHCP=yes
diff --git a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
new file mode 100644
index 0000000..60eae44
--- /dev/null
+++ b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
@@ -0,0 +1,23 @@
1SUMMARY = "systemd-networkd config to setup wired interface with dhcp"
2DESCRIPTION = "Provides automatic dhcp network configuration for wired \
3interfaces through systemd-networkd"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
6
7inherit systemd
8
9SRC_URI_append = " file://20-wired-dhcp.network"
10PR = "r1"
11
12RDEPENDS_${PN} = "systemd"
13
14S = "${WORKDIR}"
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18FILES_${PN} = "${systemd_unitdir}/network/*"
19
20do_install() {
21 install -d ${D}/${systemd_unitdir}/network
22 install -m 0644 ${WORKDIR}/20-wired-dhcp.network ${D}/${systemd_unitdir}/network
23}
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb
index 1a41169..371d517 100644
--- a/recipes-test/images/secondary-image.bb
+++ b/recipes-test/images/secondary-image.bb
@@ -17,6 +17,7 @@ IMAGE_INSTALL_remove = " \
17 aktualizr-uboot-env-rollback \ 17 aktualizr-uboot-env-rollback \
18 connman \ 18 connman \
19 connman-client \ 19 connman-client \
20 networkd-dhcp-conf \
20 " 21 "
21 22
22IMAGE_INSTALL_append = " \ 23IMAGE_INSTALL_append = " \