summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-11-14 13:53:04 +0100
committerGitHub <noreply@github.com>2019-11-14 13:53:04 +0100
commit004456ed74f5af940d77aa46f8ca7d7c9bbb4d85 (patch)
tree0017cb1186b7e718596044ef4150f9a24b243c18
parent4fd7d8023d8e447cd3d2289a837b82f006be4041 (diff)
parentfa24b716dd21b874975ae8e1a0978a3356c94dc6 (diff)
downloadmeta-updater-004456ed74f5af940d77aa46f8ca7d7c9bbb4d85.tar.gz
Merge pull request #629 from advancedtelematic/fix/rpi3-uart
Fix uart output on recent raspberrypi3
-rw-r--r--classes/sota_raspberrypi.bbclass6
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/classes/sota_raspberrypi.bbclass b/classes/sota_raspberrypi.bbclass
index c901a70..d5d89a9 100644
--- a/classes/sota_raspberrypi.bbclass
+++ b/classes/sota_raspberrypi.bbclass
@@ -44,9 +44,9 @@ IMAGE_BOOT_FILES_sota = "bcm2835-bootfiles/* \
44 " 44 "
45 45
46# OSTree puts its own boot.scr to bcm2835-bootfiles 46# OSTree puts its own boot.scr to bcm2835-bootfiles
47# raspberrypi4 needs dtb in /boot partition so that they can be read by the 47# rpi4 and recent rpi3 firmwares needs dtb in /boot partition
48# firmware 48# so that they can be read by the firmware
49IMAGE_BOOT_FILES_append_sota_raspberrypi4 = "${@make_dtb_boot_files(d)}" 49IMAGE_BOOT_FILES_append_sota = "${@make_dtb_boot_files(d)}"
50 50
51# Just the overlays that will be used should be listed 51# Just the overlays that will be used should be listed
52KERNEL_DEVICETREE_raspberrypi2_sota ?= " bcm2709-rpi-2-b.dtb " 52KERNEL_DEVICETREE_raspberrypi2_sota ?= " bcm2709-rpi-2-b.dtb "
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 8e129e1..cef66ab 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -30,7 +30,7 @@ SRC_URI = " \
30SRC_URI[garagesign.md5sum] = "de0877ecb693fd48ec11052e51b0ff1a" 30SRC_URI[garagesign.md5sum] = "de0877ecb693fd48ec11052e51b0ff1a"
31SRC_URI[garagesign.sha256sum] = "cf25759574c9c1206835daeaf6fc345f6db7b5ccdb95fb828c86d7451f78f0aa" 31SRC_URI[garagesign.sha256sum] = "cf25759574c9c1206835daeaf6fc345f6db7b5ccdb95fb828c86d7451f78f0aa"
32 32
33SRCREV = "9677f025abbb958ad36d4b58cae1dd4fe5750cf0" 33SRCREV = "1c2f495e47a41cc7c9ad969ff42496208ad6b23a"
34BRANCH ?= "master" 34BRANCH ?= "master"
35 35
36S = "${WORKDIR}/git" 36S = "${WORKDIR}/git"