summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-03-12 15:41:44 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2019-04-29 09:23:15 +0200
commit39ca95ca10fb27e87578b4051f1ae31298229c64 (patch)
treec7dbb79ae7a560d6aebcc11493bf12dba4e4db42
parent6c73fd1caaea849c24ffb697a8f1d92e501551bf (diff)
downloadmeta-updater-39ca95ca10fb27e87578b4051f1ae31298229c64.tar.gz
Save space in deployed aktualizr ptest
* remove whole RIOT repo * remove intermediary static libraries, only useful during build Should be around 500MB saving in total Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 401042f..ca9d47b 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -71,8 +71,11 @@ do_install_ptest() {
71 cp -r ${B}/ ${D}/${PTEST_PATH}/build 71 cp -r ${B}/ ${D}/${PTEST_PATH}/build
72 cp -r ${S}/ ${D}/${PTEST_PATH}/src 72 cp -r ${S}/ ${D}/${PTEST_PATH}/src
73 73
74 # remove bogus elf file 74 # remove huge external unused repository
75 rm ${D}/${PTEST_PATH}/src/partial/extern/RIOT/cpu/esp32/bin/bootloader.elf 75 rm -rf ${D}/${PTEST_PATH}/src/partial/extern/RIOT
76
77 # remove huge build artifacts
78 find ${D}/${PTEST_PATH}/build/src -name "*.a" -delete
76 79
77 # fix the absolute paths 80 # fix the absolute paths
78 find ${D}/${PTEST_PATH}/build -name "CMakeFiles" | xargs rm -rf 81 find ${D}/${PTEST_PATH}/build -name "CMakeFiles" | xargs rm -rf