summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-04-29 14:44:37 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-05-07 16:25:01 +0200
commit04eb26b60435a65cbd2918defcd861aa45bc7f74 (patch)
treeb43a35902b180b8f5f9c64ca84bf40361b4dab55
parent0ac9924bf8b7e9ea4bcc054c1d0491149a0bb467 (diff)
downloadmeta-updater-04eb26b60435a65cbd2918defcd861aa45bc7f74.tar.gz
aktualizr: fix cmake compilation for ptest.
The cmake recipe in rocko doesn't support the build function that later release branches use, and by default it just compiles the default target (instead of 'all'). This fix will compile everything the same way as is done in the later release branches, but we have to be much more explicit about it. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index e85a8cd..6cdb27b 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -72,7 +72,8 @@ RESOURCE_MEMORY_HIGH = "100M"
72RESOURCE_MEMORY_MAX = "80%" 72RESOURCE_MEMORY_MAX = "80%"
73 73
74do_compile_ptest() { 74do_compile_ptest() {
75 cmake_runcmake_build --target build_tests "${PARALLEL_MAKE}" 75 bbnote VERBOSE=1 cmake --build '${B}' --target build_tests -- ${EXTRA_OECMAKE_BUILD} ${PARALLEL_MAKE}
76 VERBOSE=1 cmake --build '${B}' --target build_tests -- ${EXTRA_OECMAKE_BUILD} ${PARALLEL_MAKE}
76} 77}
77 78
78do_install_ptest() { 79do_install_ptest() {