summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-10-11 15:21:00 +0200
committerGitHub <noreply@github.com>2019-10-11 15:21:00 +0200
commita1f2ccf986e844e130ecc6ae61d2b6fc3632e2f8 (patch)
treed1b0f02b5a573b6e89bf80da83a818b5469310f4
parent7cad55821f0cc9f379b689afc6325bdb0cb1eff3 (diff)
parentf87628186bd3b548c1f449adce3116d38557df5c (diff)
downloadmeta-updater-a1f2ccf986e844e130ecc6ae61d2b6fc3632e2f8.tar.gz
Merge pull request #611 from advancedtelematic/feat/example-virtual-sec
Example config for a virtual secondary.
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb2
-rw-r--r--recipes-sota/config/aktualizr-virtualsec.bb27
-rw-r--r--recipes-sota/config/files/30-virtualsec.toml3
-rw-r--r--recipes-sota/config/files/virtualsec.json14
-rwxr-xr-xscripts/ci/checkout-oe.sh4
5 files changed, 48 insertions, 2 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 694e849..e4c9be8 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -31,7 +31,7 @@ SRC_URI = " \
31SRC_URI[md5sum] = "66ffe8dcd61d4c15646e1c4b7dde7401" 31SRC_URI[md5sum] = "66ffe8dcd61d4c15646e1c4b7dde7401"
32SRC_URI[sha256sum] = "7a7193ddf7e1a33ea60fbb20f98318a8bd78c325dab391d8c4ebd644a738abdc" 32SRC_URI[sha256sum] = "7a7193ddf7e1a33ea60fbb20f98318a8bd78c325dab391d8c4ebd644a738abdc"
33 33
34SRCREV = "5443f810d63eedc92ff917e49ca20e2e7551ba43" 34SRCREV = "d13ff1ceeca2694b982287740aca8f58edad514d"
35BRANCH ?= "master" 35BRANCH ?= "master"
36 36
37S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
diff --git a/recipes-sota/config/aktualizr-virtualsec.bb b/recipes-sota/config/aktualizr-virtualsec.bb
new file mode 100644
index 0000000..b7d55aa
--- /dev/null
+++ b/recipes-sota/config/aktualizr-virtualsec.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Example virtual secondary in aktualizr"
2DESCRIPTION = "Creates an example virtual secondary to be used to update an arbitrary file on the primary"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base"
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
7
8inherit allarch
9
10SRC_URI = " \
11 file://30-virtualsec.toml \
12 file://virtualsec.json \
13 "
14
15do_install_append () {
16 install -m 0700 -d ${D}${libdir}/sota/conf.d
17 install -m 0644 ${WORKDIR}/30-virtualsec.toml ${D}${libdir}/sota/conf.d/30-virtualsec.toml
18 install -m 0644 ${WORKDIR}/virtualsec.json ${D}${libdir}/sota/virtualsec.json
19}
20
21FILES_${PN} = " \
22 ${libdir}/sota/conf.d/30-virtualsec.toml \
23 ${libdir}/sota/virtualsec.json \
24 "
25
26# vim:set ts=4 sw=4 sts=4 expandtab:
27
diff --git a/recipes-sota/config/files/30-virtualsec.toml b/recipes-sota/config/files/30-virtualsec.toml
new file mode 100644
index 0000000..987f692
--- /dev/null
+++ b/recipes-sota/config/files/30-virtualsec.toml
@@ -0,0 +1,3 @@
1[uptane]
2secondary_config_file = "/usr/lib/sota/virtualsec.json"
3
diff --git a/recipes-sota/config/files/virtualsec.json b/recipes-sota/config/files/virtualsec.json
new file mode 100644
index 0000000..dcdcdba
--- /dev/null
+++ b/recipes-sota/config/files/virtualsec.json
@@ -0,0 +1,14 @@
1{
2 "virtual": [
3 {
4 "partial_verifying": "false",
5 "ecu_hardware_id": "external-config",
6 "full_client_dir": "/var/sota/external-config",
7 "ecu_private_key": "sec.private",
8 "ecu_public_key": "sec.public",
9 "firmware_path": "/var/sota/external-config/config.txt",
10 "target_name_path": "/var/sota/external-config/target_name",
11 "metadata_path": "/var/sota/external-config/metadata"
12 }
13 ]
14}
diff --git a/scripts/ci/checkout-oe.sh b/scripts/ci/checkout-oe.sh
index fdc0e48..e8a2473 100755
--- a/scripts/ci/checkout-oe.sh
+++ b/scripts/ci/checkout-oe.sh
@@ -64,7 +64,9 @@ fi
64 64
65repo manifest 65repo manifest
66 66
67repo forall -c 'git reset --hard ; git clean -fdx' 67# Try to clean up the repos in case they are messed up, but this returns an
68# error code if the repos don't exist, which the subsequent repo sync will fix.
69repo forall -c 'git reset --hard ; git clean -fdx' || true
68 70
69repo sync -d --force-sync 71repo sync -d --force-sync
70 72