diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2018-01-22 19:15:40 +0200 |
---|---|---|
committer | Leon Anavi <leon.anavi@konsulko.com> | 2018-01-22 19:15:40 +0200 |
commit | 62b32e9cc348758e8569040f4d5f4d337234d3ad (patch) | |
tree | 76a16234afd12405587803423b4be168b5dbcc6a | |
parent | 99e49cc2e6fe29f9b58d1f38c25b7e02c72964e2 (diff) | |
download | meta-updater-62b32e9cc348758e8569040f4d5f4d337234d3ad.tar.gz |
Drop rvi-sota-client and remove meta-rust dependency
Remove the old RVI SOTA Client and the dependecy
from Yocto/OE layer meta-rust.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
9 files changed, 0 insertions, 328 deletions
diff --git a/conf/include/bblayers/sota.inc b/conf/include/bblayers/sota.inc index b1fd28a..26eea22 100644 --- a/conf/include/bblayers/sota.inc +++ b/conf/include/bblayers/sota.inc | |||
@@ -1,4 +1,3 @@ | |||
1 | BBLAYERS += "${METADIR}/meta-updater" | 1 | BBLAYERS += "${METADIR}/meta-updater" |
2 | BBLAYERS += "${METADIR}/meta-openembedded/meta-filesystems" | 2 | BBLAYERS += "${METADIR}/meta-openembedded/meta-filesystems" |
3 | BBLAYERS += "${METADIR}/meta-openembedded/meta-oe" | 3 | BBLAYERS += "${METADIR}/meta-openembedded/meta-oe" |
4 | BBLAYERS += "${METADIR}/meta-rust" | ||
diff --git a/recipes-sota/rvi-sota-client/files/sota-client-autoprovision.service b/recipes-sota/rvi-sota-client/files/sota-client-autoprovision.service deleted file mode 100644 index 11b1354..0000000 --- a/recipes-sota/rvi-sota-client/files/sota-client-autoprovision.service +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=SOTA Client Autoprovisioning | ||
3 | Requires=network-online.target | ||
4 | After=network-online.target | ||
5 | |||
6 | [Service] | ||
7 | Type=oneshot | ||
8 | WorkingDirectory=/var/sota | ||
9 | Environment=SOTA_CERT_DIR=/var/sota | ||
10 | ExecStart=/usr/bin/sota_provision.sh sota_provisioning_credentials | ||
11 | RemainAfterExit=true | ||
12 | StandardOutput=journal | ||
13 | |||
14 | [Install] | ||
15 | WantedBy=multi-user.target | ||
diff --git a/recipes-sota/rvi-sota-client/files/sota-client-ostree.service b/recipes-sota/rvi-sota-client/files/sota-client-ostree.service deleted file mode 100644 index 093a994..0000000 --- a/recipes-sota/rvi-sota-client/files/sota-client-ostree.service +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=SOTA Client | ||
3 | Requires=network-online.target | ||
4 | After=network.target network-online.target | ||
5 | |||
6 | [Service] | ||
7 | RestartSec=5 | ||
8 | Restart=on-failure | ||
9 | Environment="RUST_LOG=debug" | ||
10 | ExecStart=/usr/bin/sota_client --config /sysroot/boot/sota.toml --device-package-manager ostree | ||
11 | |||
12 | [Install] | ||
13 | WantedBy=multi-user.target | ||
diff --git a/recipes-sota/rvi-sota-client/files/sota-client-uptane.service b/recipes-sota/rvi-sota-client/files/sota-client-uptane.service deleted file mode 100644 index a2d80ce..0000000 --- a/recipes-sota/rvi-sota-client/files/sota-client-uptane.service +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=SOTA Client | ||
3 | Requires=network-online.target | ||
4 | After=network.target network-online.target | ||
5 | Requires=sota-client-autoprovision | ||
6 | After=sota-client-autoprovision | ||
7 | |||
8 | [Service] | ||
9 | RestartSec=5 | ||
10 | Restart=on-failure | ||
11 | Environment="RUST_LOG=debug" | ||
12 | ExecStart=/usr/bin/sota_client --config /var/sota/sota.toml --device-package-manager uptane | ||
13 | |||
14 | [Install] | ||
15 | WantedBy=multi-user.target | ||
diff --git a/recipes-sota/rvi-sota-client/files/sota-installer.service b/recipes-sota/rvi-sota-client/files/sota-installer.service deleted file mode 100644 index a4fd99e..0000000 --- a/recipes-sota/rvi-sota-client/files/sota-installer.service +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=SOTA Secondary ECU Installer | ||
3 | Requires=network-online.target | ||
4 | After=network-online.target | ||
5 | |||
6 | [Service] | ||
7 | RestartSec=10 | ||
8 | Restart=always | ||
9 | ExecStart=/usr/bin/sota-installer --level debug --oneshot --config /var/sota/installer.toml | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client.inc b/recipes-sota/rvi-sota-client/rvi-sota-client.inc deleted file mode 100644 index 712b9b3..0000000 --- a/recipes-sota/rvi-sota-client/rvi-sota-client.inc +++ /dev/null | |||
@@ -1,173 +0,0 @@ | |||
1 | inherit cargo systemd | ||
2 | |||
3 | DESCRIPTION = "rvi-sota-client recipe" | ||
4 | HOMEPAGE = "https://github.com/advancedtelematic/rvi_sota_client" | ||
5 | LICENSE = "MPL-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea" | ||
7 | |||
8 | BBCLASSEXTEND = "native" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | SRC_URI[index.md5sum] = "6a635e8a081b4d4ba4cebffd721c2d7d" | ||
13 | SRC_URI[index.sha256sum] = "1913c41d4b8de89a931b6f9e418f83e70a083e12e6c247e8510ee932571ebae2" | ||
14 | |||
15 | # also update PV and SRC_URI crates when updating SRCREV | ||
16 | SRCREV = "be8ec83af2051a2b2499ce8878242771c65f0f1c" | ||
17 | |||
18 | PR = "1" | ||
19 | |||
20 | # generate with: `make package-version` | ||
21 | PV = "0.2.34-8-gbe8ec83" | ||
22 | |||
23 | # generate with: `make yocto-version` | ||
24 | SRC_URI = " \ | ||
25 | git://github.com/advancedtelematic/rvi_sota_client \ | ||
26 | file://sota-client-autoprovision.service \ | ||
27 | file://sota-client-ostree.service \ | ||
28 | file://sota-client-uptane.service \ | ||
29 | file://sota-installer.service \ | ||
30 | crate://crates.io/adler32/1.0.2 \ | ||
31 | crate://crates.io/advapi32-sys/0.2.0 \ | ||
32 | crate://crates.io/aho-corasick/0.6.3 \ | ||
33 | crate://crates.io/ansi_term/0.9.0 \ | ||
34 | crate://crates.io/antidote/1.0.0 \ | ||
35 | crate://crates.io/atty/0.2.3 \ | ||
36 | crate://crates.io/backtrace/0.3.3 \ | ||
37 | crate://crates.io/backtrace-sys/0.1.15 \ | ||
38 | crate://crates.io/base64/0.6.0 \ | ||
39 | crate://crates.io/bincode/0.9.0 \ | ||
40 | crate://crates.io/bit-set/0.4.0 \ | ||
41 | crate://crates.io/bit-vec/0.4.4 \ | ||
42 | crate://crates.io/bitflags/0.7.0 \ | ||
43 | crate://crates.io/bitflags/0.9.1 \ | ||
44 | crate://crates.io/block-buffer/0.2.0 \ | ||
45 | crate://crates.io/byte-tools/0.2.0 \ | ||
46 | crate://crates.io/byteorder/1.1.0 \ | ||
47 | crate://crates.io/bytes/0.4.5 \ | ||
48 | crate://crates.io/cc/1.0.1 \ | ||
49 | crate://crates.io/cfg-if/0.1.2 \ | ||
50 | crate://crates.io/chan/0.1.19 \ | ||
51 | crate://crates.io/chan-signal/0.3.1 \ | ||
52 | crate://crates.io/chrono/0.4.0 \ | ||
53 | crate://crates.io/clap/2.26.2 \ | ||
54 | crate://crates.io/coco/0.1.1 \ | ||
55 | crate://crates.io/constant_time_eq/0.1.3 \ | ||
56 | crate://crates.io/core-foundation/0.2.3 \ | ||
57 | crate://crates.io/core-foundation-sys/0.2.3 \ | ||
58 | crate://crates.io/crossbeam/0.3.0 \ | ||
59 | crate://crates.io/crypt32-sys/0.2.0 \ | ||
60 | crate://crates.io/crypto-mac/0.4.0 \ | ||
61 | crate://crates.io/dbghelp-sys/0.2.0 \ | ||
62 | crate://crates.io/dbus/0.5.4 \ | ||
63 | crate://crates.io/digest/0.6.2 \ | ||
64 | crate://crates.io/dtoa/0.4.2 \ | ||
65 | crate://crates.io/either/1.2.0 \ | ||
66 | crate://crates.io/env_logger/0.4.3 \ | ||
67 | crate://crates.io/error-chain/0.10.0 \ | ||
68 | crate://crates.io/fake-simd/0.1.2 \ | ||
69 | crate://crates.io/filetime/0.1.14 \ | ||
70 | crate://crates.io/foreign-types/0.2.0 \ | ||
71 | crate://crates.io/fuchsia-zircon/0.2.1 \ | ||
72 | crate://crates.io/fuchsia-zircon-sys/0.2.0 \ | ||
73 | crate://crates.io/futures/0.1.16 \ | ||
74 | crate://crates.io/gcc/0.3.54 \ | ||
75 | crate://crates.io/generic-array/0.8.3 \ | ||
76 | crate://crates.io/getopts/0.2.15 \ | ||
77 | crate://crates.io/hex/0.2.0 \ | ||
78 | crate://crates.io/hmac/0.4.2 \ | ||
79 | crate://crates.io/httparse/1.2.3 \ | ||
80 | crate://crates.io/hyper/0.10.13 \ | ||
81 | crate://crates.io/hyper-native-tls/0.2.4 \ | ||
82 | crate://crates.io/idna/0.1.4 \ | ||
83 | crate://crates.io/iovec/0.1.1 \ | ||
84 | crate://crates.io/itoa/0.3.4 \ | ||
85 | crate://crates.io/kernel32-sys/0.2.2 \ | ||
86 | crate://crates.io/language-tags/0.2.2 \ | ||
87 | crate://crates.io/lazy_static/0.2.9 \ | ||
88 | crate://crates.io/libc/0.2.32 \ | ||
89 | crate://crates.io/libdbus-sys/0.1.1 \ | ||
90 | crate://crates.io/libflate/0.1.11 \ | ||
91 | crate://crates.io/log/0.3.8 \ | ||
92 | crate://crates.io/maplit/0.1.5 \ | ||
93 | crate://crates.io/matches/0.1.6 \ | ||
94 | crate://crates.io/memchr/1.0.1 \ | ||
95 | crate://crates.io/metadeps/1.1.2 \ | ||
96 | crate://crates.io/mime/0.2.6 \ | ||
97 | crate://crates.io/native-tls/0.1.4 \ | ||
98 | crate://crates.io/net2/0.2.31 \ | ||
99 | crate://crates.io/nodrop/0.1.9 \ | ||
100 | crate://crates.io/num/0.1.40 \ | ||
101 | crate://crates.io/num-integer/0.1.35 \ | ||
102 | crate://crates.io/num-iter/0.1.34 \ | ||
103 | crate://crates.io/num-traits/0.1.40 \ | ||
104 | crate://crates.io/num_cpus/1.7.0 \ | ||
105 | crate://crates.io/odds/0.2.25 \ | ||
106 | crate://crates.io/openssl/0.9.19 \ | ||
107 | crate://crates.io/openssl-sys/0.9.19 \ | ||
108 | crate://crates.io/pem/0.4.1 \ | ||
109 | crate://crates.io/percent-encoding/1.0.0 \ | ||
110 | crate://crates.io/pkg-config/0.3.9 \ | ||
111 | crate://crates.io/quote/0.3.15 \ | ||
112 | crate://crates.io/rand/0.3.17 \ | ||
113 | crate://crates.io/rayon/0.8.2 \ | ||
114 | crate://crates.io/rayon-core/1.2.1 \ | ||
115 | crate://crates.io/redox_syscall/0.1.31 \ | ||
116 | crate://crates.io/redox_termios/0.1.1 \ | ||
117 | crate://crates.io/regex/0.2.2 \ | ||
118 | crate://crates.io/regex-syntax/0.4.1 \ | ||
119 | crate://crates.io/reqwest/0.6.2 \ | ||
120 | crate://crates.io/ring/0.12.1 \ | ||
121 | crate://crates.io/rust-crypto/0.2.36 \ | ||
122 | crate://crates.io/rustc-demangle/0.1.5 \ | ||
123 | crate://crates.io/rustc-serialize/0.3.24 \ | ||
124 | crate://crates.io/safemem/0.2.0 \ | ||
125 | crate://crates.io/schannel/0.1.8 \ | ||
126 | crate://crates.io/scopeguard/0.3.2 \ | ||
127 | crate://crates.io/secur32-sys/0.2.0 \ | ||
128 | crate://crates.io/security-framework/0.1.16 \ | ||
129 | crate://crates.io/security-framework-sys/0.1.16 \ | ||
130 | crate://crates.io/serde/1.0.15 \ | ||
131 | crate://crates.io/serde_derive/1.0.15 \ | ||
132 | crate://crates.io/serde_derive_internals/0.16.0 \ | ||
133 | crate://crates.io/serde_json/1.0.3 \ | ||
134 | crate://crates.io/serde_urlencoded/0.5.1 \ | ||
135 | crate://crates.io/sha1/0.2.0 \ | ||
136 | crate://crates.io/sha2/0.6.0 \ | ||
137 | crate://crates.io/strsim/0.6.0 \ | ||
138 | crate://crates.io/syn/0.11.11 \ | ||
139 | crate://crates.io/synom/0.11.3 \ | ||
140 | crate://crates.io/tar/0.4.13 \ | ||
141 | crate://crates.io/tempdir/0.3.5 \ | ||
142 | crate://crates.io/term_size/0.3.0 \ | ||
143 | crate://crates.io/termion/1.5.1 \ | ||
144 | crate://crates.io/textwrap/0.8.0 \ | ||
145 | crate://crates.io/thread_local/0.3.4 \ | ||
146 | crate://crates.io/time/0.1.38 \ | ||
147 | crate://crates.io/toml/0.2.1 \ | ||
148 | crate://crates.io/toml/0.4.5 \ | ||
149 | crate://crates.io/traitobject/0.1.0 \ | ||
150 | crate://crates.io/tungstenite/0.5.0 \ | ||
151 | crate://crates.io/typeable/0.1.2 \ | ||
152 | crate://crates.io/typenum/1.9.0 \ | ||
153 | crate://crates.io/unicase/1.4.2 \ | ||
154 | crate://crates.io/unicode-bidi/0.3.4 \ | ||
155 | crate://crates.io/unicode-normalization/0.1.5 \ | ||
156 | crate://crates.io/unicode-width/0.1.4 \ | ||
157 | crate://crates.io/unicode-xid/0.0.4 \ | ||
158 | crate://crates.io/unix_socket/0.5.0 \ | ||
159 | crate://crates.io/unreachable/1.0.0 \ | ||
160 | crate://crates.io/untrusted/0.5.1 \ | ||
161 | crate://crates.io/url/1.5.1 \ | ||
162 | crate://crates.io/utf-8/0.7.1 \ | ||
163 | crate://crates.io/utf8-ranges/1.0.0 \ | ||
164 | crate://crates.io/uuid/0.5.1 \ | ||
165 | crate://crates.io/vcpkg/0.2.2 \ | ||
166 | crate://crates.io/vec_map/0.8.0 \ | ||
167 | crate://crates.io/version_check/0.1.3 \ | ||
168 | crate://crates.io/void/1.0.2 \ | ||
169 | crate://crates.io/winapi/0.2.8 \ | ||
170 | crate://crates.io/winapi-build/0.1.1 \ | ||
171 | crate://crates.io/ws2_32-sys/0.2.1 \ | ||
172 | crate://crates.io/xattr/0.1.11 \ | ||
173 | " | ||
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb deleted file mode 100644 index e286598..0000000 --- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb +++ /dev/null | |||
@@ -1,59 +0,0 @@ | |||
1 | require rvi-sota-client.inc | ||
2 | |||
3 | |||
4 | SYSTEMD_SERVICE_${PN} = "sota-client.service sota-client-autoprovision.service" | ||
5 | |||
6 | FILES_${PN} = " \ | ||
7 | /lib64 \ | ||
8 | ${bindir}/sota_client \ | ||
9 | ${bindir}/sota_sysinfo.sh \ | ||
10 | ${bindir}/sota_provision.sh \ | ||
11 | ${sysconfdir}/sota_client.version \ | ||
12 | ${sysconfdir}/sota_certificates \ | ||
13 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota-client.service', '', d)} \ | ||
14 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota-client-autoprovision.service', '', d)} \ | ||
15 | " | ||
16 | |||
17 | DEPENDS += " openssl openssl-native dbus " | ||
18 | RDEPENDS_${PN} = " \ | ||
19 | bash \ | ||
20 | curl \ | ||
21 | libcrypto \ | ||
22 | libssl \ | ||
23 | lshw \ | ||
24 | jq \ | ||
25 | python-petname \ | ||
26 | sota-launcher \ | ||
27 | zip \ | ||
28 | " | ||
29 | |||
30 | export SOTA_PACKED_CREDENTIALS | ||
31 | |||
32 | do_compile_prepend() { | ||
33 | export SOTA_VERSION=$(make sota-version) | ||
34 | cd sota-client | ||
35 | } | ||
36 | |||
37 | do_install() { | ||
38 | ln -fs /lib ${D}/lib64 | ||
39 | |||
40 | install -d ${D}${bindir} | ||
41 | install -d ${D}${sysconfdir} | ||
42 | |||
43 | echo `git log -1 --pretty=format:%H` > ${D}${sysconfdir}/sota_client.version | ||
44 | install -c ${S}/sota-client/docker/sota_certificates ${D}${sysconfdir} | ||
45 | |||
46 | install -m 0755 target/${TARGET_SYS}/release/sota_client ${D}${bindir} | ||
47 | install -m 0755 ${S}/sota-client/docker/sota_provision.sh ${D}${bindir} | ||
48 | install -m 0755 ${S}/sota-client/docker/sota_sysinfo.sh ${D}${bindir} | ||
49 | |||
50 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
51 | install -d ${D}/${systemd_unitdir}/system | ||
52 | if [ -n "$SOTA_PACKED_CREDENTIALS" ]; then | ||
53 | install -m 0644 ${WORKDIR}/sota-client-uptane.service ${D}/${systemd_unitdir}/system/sota-client.service | ||
54 | else | ||
55 | install -m 0644 ${WORKDIR}/sota-client-ostree.service ${D}/${systemd_unitdir}/system/sota-client.service | ||
56 | fi | ||
57 | install -m 0644 ${WORKDIR}/sota-client-autoprovision.service ${D}/${systemd_unitdir}/system/sota-client-autoprovision.service | ||
58 | fi | ||
59 | } | ||
diff --git a/recipes-sota/rvi-sota-client/sota-installer_git.bb b/recipes-sota/rvi-sota-client/sota-installer_git.bb deleted file mode 100644 index 09f6e5d..0000000 --- a/recipes-sota/rvi-sota-client/sota-installer_git.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | require rvi-sota-client.inc | ||
2 | |||
3 | |||
4 | SYSTEMD_SERVICE_${PN} = "sota-installer.service" | ||
5 | |||
6 | DEPENDS += " rvi-sota-client " | ||
7 | |||
8 | FILES_${PN} = " \ | ||
9 | ${bindir}/sota-installer \ | ||
10 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota-installer.service', '', d)} \ | ||
11 | " | ||
12 | |||
13 | do_compile_prepend() { | ||
14 | cd sota-installer | ||
15 | } | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${bindir} | ||
19 | install -m 0755 target/${TARGET_SYS}/release/sota-installer ${D}${bindir} | ||
20 | |||
21 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
22 | install -d ${D}/${systemd_unitdir}/system | ||
23 | install -m 0644 ${WORKDIR}/sota-installer.service ${D}/${systemd_unitdir}/system/sota-installer.service | ||
24 | fi | ||
25 | } | ||
diff --git a/recipes-sota/rvi-sota-client/sota-launcher_git.bb b/recipes-sota/rvi-sota-client/sota-launcher_git.bb deleted file mode 100644 index e9874e7..0000000 --- a/recipes-sota/rvi-sota-client/sota-launcher_git.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | require rvi-sota-client.inc | ||
2 | |||
3 | |||
4 | DEPENDS += " rvi-sota-client " | ||
5 | FILES_${PN} = "${bindir}/sota-launcher" | ||
6 | |||
7 | |||
8 | do_compile_prepend() { | ||
9 | cd sota-launcher | ||
10 | } | ||
11 | |||
12 | do_install() { | ||
13 | install -d ${D}${bindir} | ||
14 | install -m 0755 target/${TARGET_SYS}/release/sota-launcher ${D}${bindir} | ||
15 | } | ||