diff options
author | lbonn <lbonn@users.noreply.github.com> | 2018-03-26 14:12:27 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2018-03-26 14:12:27 +0200 |
commit | 7ce65035d63107605e07ecb1d923be63ecaa1ec9 (patch) | |
tree | 52271f7c10f5b306cdb3b484b3625a0b3882f90d | |
parent | 156074d9533acf88f102a07701591a4532d007db (diff) | |
parent | 313278d88fddcc9441f7eacf2e5578d3a19cf8ff (diff) | |
download | meta-updater-7ce65035d63107605e07ecb1d923be63ecaa1ec9.tar.gz |
Merge pull request #278 from advancedtelematic/feat/udp-socket-activation
UDP Socket activation for discovery service
-rw-r--r-- | lib/oeqa/selftest/cases/updater.py | 4 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/files/aktualizr-secondary.socket | 1 |
3 files changed, 4 insertions, 3 deletions
diff --git a/lib/oeqa/selftest/cases/updater.py b/lib/oeqa/selftest/cases/updater.py index 0e7c11b..06884e5 100644 --- a/lib/oeqa/selftest/cases/updater.py +++ b/lib/oeqa/selftest/cases/updater.py | |||
@@ -544,7 +544,7 @@ class SecondaryTests(OESelftestTestCase): | |||
544 | self.assertEqual(stderr, b'', 'Error: ' + stderr.decode()) | 544 | self.assertEqual(stderr, b'', 'Error: ' + stderr.decode()) |
545 | 545 | ||
546 | def test_secondary_listening(self): | 546 | def test_secondary_listening(self): |
547 | print('Checking aktualizr-secondary is present') | 547 | print('Checking aktualizr-secondary service is listening') |
548 | stdout, stderr, retcode = self.qemu_command('echo test | nc localhost 9030') | 548 | stdout, stderr, retcode = self.qemu_command('echo test | nc localhost 9030') |
549 | self.assertEqual(retcode, 0, "Unable to connect to secondary") | 549 | self.assertEqual(retcode, 0, "Unable to connect to secondary") |
550 | 550 | ||
@@ -591,7 +591,7 @@ def qemu_send_command(port, command): | |||
591 | command = ['ssh -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no root@localhost -p ' + | 591 | command = ['ssh -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no root@localhost -p ' + |
592 | str(port) + ' "' + command + '"'] | 592 | str(port) + ' "' + command + '"'] |
593 | s2 = subprocess.Popen(command, shell=True, stdout=subprocess.PIPE, stderr=subprocess.PIPE) | 593 | s2 = subprocess.Popen(command, shell=True, stdout=subprocess.PIPE, stderr=subprocess.PIPE) |
594 | stdout, stderr = s2.communicate() | 594 | stdout, stderr = s2.communicate(timeout=60) |
595 | return stdout, stderr, s2.returncode | 595 | return stdout, stderr, s2.returncode |
596 | 596 | ||
597 | 597 | ||
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 5e683ac..79a89ef 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -22,7 +22,7 @@ SRC_URI = " \ | |||
22 | file://aktualizr-secondary.socket \ | 22 | file://aktualizr-secondary.socket \ |
23 | file://aktualizr-serialcan.service \ | 23 | file://aktualizr-serialcan.service \ |
24 | " | 24 | " |
25 | SRCREV = "fbb3404824c4eb239455c7fa1a794c26e2ea954d" | 25 | SRCREV = "7d1d71a28a9ff0b14240b98600de3d541835b278" |
26 | BRANCH ?= "master" | 26 | BRANCH ?= "master" |
27 | 27 | ||
28 | S = "${WORKDIR}/git" | 28 | S = "${WORKDIR}/git" |
diff --git a/recipes-sota/aktualizr/files/aktualizr-secondary.socket b/recipes-sota/aktualizr/files/aktualizr-secondary.socket index 1cb4269..da0ee44 100644 --- a/recipes-sota/aktualizr/files/aktualizr-secondary.socket +++ b/recipes-sota/aktualizr/files/aktualizr-secondary.socket | |||
@@ -1,5 +1,6 @@ | |||
1 | [Socket] | 1 | [Socket] |
2 | ListenStream=9030 | 2 | ListenStream=9030 |
3 | ListenDatagram=9031 | ||
3 | 4 | ||
4 | [Install] | 5 | [Install] |
5 | WantedBy=sockets.target \ No newline at end of file | 6 | WantedBy=sockets.target \ No newline at end of file |