summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Luck <ben+qa@advancedtelematic.com>2018-08-10 12:32:06 +0200
committerGitHub <noreply@github.com>2018-08-10 12:32:06 +0200
commit14cb2041f2e117bd3e352a1cb1fc046baa53c20d (patch)
tree506427dcf253e29486fea496a3391e035c878540
parent3ad1ac0634f4cff65f8ae4cfa78bbe73942e0bd5 (diff)
parent3dd8643030c7d973e08f536f9dde5b6029cf8321 (diff)
downloadmeta-updater-14cb2041f2e117bd3e352a1cb1fc046baa53c20d.tar.gz
Merge pull request #363 from advancedtelematic/feat/PRO-Tech-#1-rocko
Feat/pro tech #1 rocko
-rw-r--r--README.adoc2
-rw-r--r--lib/oeqa/selftest/cases/updater.py2
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb3
3 files changed, 4 insertions, 3 deletions
diff --git a/README.adoc b/README.adoc
index 75ee9ae..d2bd4b5 100644
--- a/README.adoc
+++ b/README.adoc
@@ -81,7 +81,7 @@ Although we have used U-Boot so far, other boot loaders can be configured work w
81* `OSTREE_INITRAMFS_IMAGE` - initramfs/initrd image that is used as a proxy while booting into OSTree deployment. Do not change this setting unless you are sure that your initramfs can serve as such a proxy. 81* `OSTREE_INITRAMFS_IMAGE` - initramfs/initrd image that is used as a proxy while booting into OSTree deployment. Do not change this setting unless you are sure that your initramfs can serve as such a proxy.
82* `SOTA_PACKED_CREDENTIALS` - when set, your ostree commit will be pushed to a remote repo as a bitbake step. This should be the path to a zipped credentials file in https://github.com/advancedtelematic/aktualizr/blob/master/docs/credentials.adoc[the format accepted by garage-push]. 82* `SOTA_PACKED_CREDENTIALS` - when set, your ostree commit will be pushed to a remote repo as a bitbake step. This should be the path to a zipped credentials file in https://github.com/advancedtelematic/aktualizr/blob/master/docs/credentials.adoc[the format accepted by garage-push].
83* `SOTA_CLIENT_PROV` - which provisioning method to use. Valid options are https://github.com/advancedtelematic/aktualizr/blob/master/docs/automatic-provisioning.adoc[`aktualizr-auto-prov`], https://github.com/advancedtelematic/aktualizr/blob/master/docs/implicit-provisioning.adoc[`aktualizr-implicit-prov`], and https://github.com/advancedtelematic/aktualizr/blob/master/docs/hsm-provisioning.adoc[`aktualizr-hsm-prov`]. The default is `aktualizr-auto-prov`. This can also be set to an empty string to avoid using a provisioning recipe. 83* `SOTA_CLIENT_PROV` - which provisioning method to use. Valid options are https://github.com/advancedtelematic/aktualizr/blob/master/docs/automatic-provisioning.adoc[`aktualizr-auto-prov`], https://github.com/advancedtelematic/aktualizr/blob/master/docs/implicit-provisioning.adoc[`aktualizr-implicit-prov`], and https://github.com/advancedtelematic/aktualizr/blob/master/docs/hsm-provisioning.adoc[`aktualizr-hsm-prov`]. The default is `aktualizr-auto-prov`. This can also be set to an empty string to avoid using a provisioning recipe.
84* `SOTA_CLIENT_FEATURES` - extensions to aktualizr. The only valid option is `hsm` (to build with HSM support) 84* `SOTA_CLIENT_FEATURES` - extensions to aktualizr. The only valid options are `hsm` (to build with HSM support) and `secondary-network` (to set up a simulated 'in-vehicle' network with support for a primary node with a DHCP server and a secondary node with a DHCP client).
85* `SOTA_SECONDARY_ECUS` - a list of paths separated by spaces of JSON configuration files for virtual secondaries on the host. These will be installed into `/var/sota/ecus` on the device. 85* `SOTA_SECONDARY_ECUS` - a list of paths separated by spaces of JSON configuration files for virtual secondaries on the host. These will be installed into `/var/sota/ecus` on the device.
86* `SOTA_VIRTUAL_SECONDARIES` - a list of paths separated by spaces of JSON configuration files for virtual secondaries installed on the device. If `SOTA_SECONDARY_ECUS` is used to install them, then you can expect them to be installed in `/var/sota/ecus`. 86* `SOTA_VIRTUAL_SECONDARIES` - a list of paths separated by spaces of JSON configuration files for virtual secondaries installed on the device. If `SOTA_SECONDARY_ECUS` is used to install them, then you can expect them to be installed in `/var/sota/ecus`.
87 87
diff --git a/lib/oeqa/selftest/cases/updater.py b/lib/oeqa/selftest/cases/updater.py
index ed4d8d7..8686033 100644
--- a/lib/oeqa/selftest/cases/updater.py
+++ b/lib/oeqa/selftest/cases/updater.py
@@ -226,7 +226,7 @@ class ManualControlTests(OESelftestTestCase):
226 Disable the systemd service then run aktualizr manually 226 Disable the systemd service then run aktualizr manually
227 """ 227 """
228 sleep(20) 228 sleep(20)
229 stdout, stderr, retcode = self.qemu_command('aktualizr-info') 229 stdout, stderr, retcode = self.qemu_command('aktualizr-info --allow-migrate')
230 self.assertIn(b'Fetched metadata: no', stdout, 230 self.assertIn(b'Fetched metadata: no', stdout,
231 'Aktualizr should not have run yet' + stderr.decode() + stdout.decode()) 231 'Aktualizr should not have run yet' + stderr.decode() + stdout.decode())
232 232
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 6096c7b..19f76b0 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -28,7 +28,7 @@ SRC_URI = " \
28 file://aktualizr-secondary.socket \ 28 file://aktualizr-secondary.socket \
29 file://aktualizr-serialcan.service \ 29 file://aktualizr-serialcan.service \
30 " 30 "
31SRCREV = "e9faff35ffa8c31cbf3c5fb1c3c6ed4f5f50e500" 31SRCREV = "a94a15e31f3b973966b1afc9081fc1b17a3b9d48"
32BRANCH ?= "master" 32BRANCH ?= "master"
33 33
34S = "${WORKDIR}/git" 34S = "${WORKDIR}/git"
@@ -103,6 +103,7 @@ FILES_${PN}-examples = " \
103 ${libdir}/sota/demo_secondary.json \ 103 ${libdir}/sota/demo_secondary.json \
104 ${bindir}/example-interface \ 104 ${bindir}/example-interface \
105 ${bindir}/isotp-test-interface \ 105 ${bindir}/isotp-test-interface \
106 ${bindir}/hmi_stub \
106 " 107 "
107 108
108FILES_${PN}-host-tools = " \ 109FILES_${PN}-host-tools = " \