summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sul <mykhaylo.sul@innoteka.com>2019-02-19 16:33:09 +0200
committerMike Sul <mykhaylo.sul@innoteka.com>2019-02-19 16:35:09 +0200
commitd806431db792dfd0eefe012edffe7274798467eb (patch)
treeb7bda14bc26cfb0fb5c999efcf15eb51239abd52
parent29c3476c8286649210ab8d731bfa063c76907f3b (diff)
downloadmeta-updater-d806431db792dfd0eefe012edffe7274798467eb.tar.gz
OTA-2135: Aktualizr's config and recipe to auto reboot just after update
Signed-off-by: Mike Sul <mykhaylo.sul@innoteka.com>
-rw-r--r--recipes-sota/config/aktualizr-auto-reboot.bb21
-rw-r--r--recipes-sota/config/files/35-enable-auto-reboot.toml2
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-sota/config/aktualizr-auto-reboot.bb b/recipes-sota/config/aktualizr-auto-reboot.bb
new file mode 100644
index 0000000..1317fd4
--- /dev/null
+++ b/recipes-sota/config/aktualizr-auto-reboot.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Enable auto reboot to apply updates"
2DESCRIPTION = "Configures aktualizr to auto reboot just after new updates installation in order to apply them"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base"
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
7
8SRC_URI = " \
9 file://35-enable-auto-reboot.toml \
10 "
11
12do_install_append () {
13 install -m 0700 -d ${D}${libdir}/sota/conf.d
14 install -m 0644 ${WORKDIR}/35-enable-auto-reboot.toml ${D}${libdir}/sota/conf.d/35-enable-auto-reboot.toml
15}
16
17FILES_${PN} = " \
18 ${libdir}/sota/conf.d/35-enable-auto-reboot.toml \
19 "
20
21# vim:set ts=4 sw=4 sts=4 expandtab:
diff --git a/recipes-sota/config/files/35-enable-auto-reboot.toml b/recipes-sota/config/files/35-enable-auto-reboot.toml
new file mode 100644
index 0000000..f83810e
--- /dev/null
+++ b/recipes-sota/config/files/35-enable-auto-reboot.toml
@@ -0,0 +1,2 @@
1[uptane]
2force_install_completion = true