summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbonn <lbonn@users.noreply.github.com>2019-02-25 11:23:41 +0100
committerGitHub <noreply@github.com>2019-02-25 11:23:41 +0100
commit63b03d7fdec13c8d14b7b5d73e3c14561ecdcded (patch)
treeecd2361e0e58e434d9a4dcb0eea031786e0db568
parent3b9b75140ea58f546829cb3cf1b234e5b650de77 (diff)
parent1bd5dd46c85345c7da7969bc7fe8ea49a1103c3e (diff)
downloadmeta-updater-63b03d7fdec13c8d14b7b5d73e3c14561ecdcded.tar.gz
Merge pull request #486 from advancedtelematic/feat/OTA-2135/auto-reboot
OTA-2135: Aktualizr's config and recipe to auto reboot just after update
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb3
-rw-r--r--recipes-sota/config/aktualizr-auto-reboot.bb21
-rw-r--r--recipes-sota/config/files/35-enable-auto-reboot.toml2
3 files changed, 25 insertions, 1 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 3b48e58..9dd90e8 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -23,7 +23,8 @@ SRC_URI = " \
23 file://aktualizr-serialcan.service \ 23 file://aktualizr-serialcan.service \
24 " 24 "
25 25
26SRCREV = "2aa9d93ccea09ec327789eecf858de561ef632da" 26
27SRCREV = "c2da7b5dfe34ebe3482042dd461543da291c43bd"
27BRANCH ?= "master" 28BRANCH ?= "master"
28 29
29S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
diff --git a/recipes-sota/config/aktualizr-auto-reboot.bb b/recipes-sota/config/aktualizr-auto-reboot.bb
new file mode 100644
index 0000000..1317fd4
--- /dev/null
+++ b/recipes-sota/config/aktualizr-auto-reboot.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Enable auto reboot to apply updates"
2DESCRIPTION = "Configures aktualizr to auto reboot just after new updates installation in order to apply them"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base"
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
7
8SRC_URI = " \
9 file://35-enable-auto-reboot.toml \
10 "
11
12do_install_append () {
13 install -m 0700 -d ${D}${libdir}/sota/conf.d
14 install -m 0644 ${WORKDIR}/35-enable-auto-reboot.toml ${D}${libdir}/sota/conf.d/35-enable-auto-reboot.toml
15}
16
17FILES_${PN} = " \
18 ${libdir}/sota/conf.d/35-enable-auto-reboot.toml \
19 "
20
21# vim:set ts=4 sw=4 sts=4 expandtab:
diff --git a/recipes-sota/config/files/35-enable-auto-reboot.toml b/recipes-sota/config/files/35-enable-auto-reboot.toml
new file mode 100644
index 0000000..f83810e
--- /dev/null
+++ b/recipes-sota/config/files/35-enable-auto-reboot.toml
@@ -0,0 +1,2 @@
1[uptane]
2force_install_completion = true