diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2019-05-13 14:33:45 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2019-05-13 14:33:45 +0200 |
commit | 550ef5c1c32be58cca91f80afbedc23d5e9b79b6 (patch) | |
tree | 62af6b6625f120919a98e8e97b5adb1d618938a0 | |
parent | 64be911c2ec371095ffa1f5f9863508d2d36e55d (diff) | |
parent | b58fd12a1ec8bada69d548730b481d907ccdccdd (diff) | |
download | meta-updater-550ef5c1c32be58cca91f80afbedc23d5e9b79b6.tar.gz |
Merge pull request #518 from advancedtelematic/test/fix-aktualizr-python-ptest
Make aktualizr-ptest depend on python3-misc
-rw-r--r-- | lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py | 2 | ||||
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py b/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py index 8783fe0..0f0f491 100644 --- a/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py +++ b/lib/oeqa/selftest/cases/updater_qemux86_64_ptest.py | |||
@@ -45,7 +45,7 @@ class PtestTests(OESelftestTestCase): | |||
45 | has_failure = re.search('^FAIL', output, flags=re.MULTILINE) is not None | 45 | has_failure = re.search('^FAIL', output, flags=re.MULTILINE) is not None |
46 | if has_failure: | 46 | if has_failure: |
47 | print("Full test suite log:") | 47 | print("Full test suite log:") |
48 | stdout, _, _ = self.qemu_command('sh -c "cat /tmp/aktualizr-ptest.log || cat /tmp/aktualizr-ptest.log.tmp"', timeout=None) | 48 | stdout, _, _ = self.qemu_command('cat /tmp/aktualizr-ptest.log || cat /tmp/aktualizr-ptest.log.tmp', timeout=None) |
49 | print(stdout.decode()) | 49 | print(stdout.decode()) |
50 | 50 | ||
51 | self.assertEqual(retcode, 0) | 51 | self.assertEqual(retcode, 0) |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index c0e275d..903f2de 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -10,7 +10,7 @@ DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native | |||
10 | RDEPENDS_${PN}_class-target = "aktualizr-configs lshw" | 10 | RDEPENDS_${PN}_class-target = "aktualizr-configs lshw" |
11 | RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-repo aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" | 11 | RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-repo aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" |
12 | 12 | ||
13 | RDEPENDS_${PN}-ptest += "bash cmake curl python3-modules openssl-bin sqlite3 valgrind" | 13 | RDEPENDS_${PN}-ptest += "bash cmake curl python3-misc python3-modules openssl-bin sqlite3 valgrind" |
14 | 14 | ||
15 | PV = "1.0+git${SRCPV}" | 15 | PV = "1.0+git${SRCPV}" |
16 | PR = "7" | 16 | PR = "7" |