summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-09-28 10:03:27 +0200
committerRicardo Salveti <ricardo@foundries.io>2020-10-30 21:15:01 -0300
commit8163b5e4b65143f496d7f76056396c90caf2929f (patch)
tree5f154245268a8a0ddb29ad30e264c2bb4439b6fe
parentba6a6d933b4798e98396ebbdbdc5103f9ad1d8ad (diff)
downloadmeta-updater-8163b5e4b65143f496d7f76056396c90caf2929f.tar.gz
lshw: remove since it's been in meta-openembedded for a long time.
And it's a newer version at that! Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--recipes-support/lshw/files/cross-compile.patch39
-rw-r--r--recipes-support/lshw/files/ldflags.patch42
-rw-r--r--recipes-support/lshw/lshw_02.17.bb36
3 files changed, 0 insertions, 117 deletions
diff --git a/recipes-support/lshw/files/cross-compile.patch b/recipes-support/lshw/files/cross-compile.patch
deleted file mode 100644
index 221b7e5..0000000
--- a/recipes-support/lshw/files/cross-compile.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1---
2 src/Makefile | 2 +-
3 src/core/Makefile | 2 +-
4 src/gui/Makefile | 4 ++--
5 3 files changed, 4 insertions(+), 4 deletions(-)
6
7--- a/src/Makefile
8+++ b/src/Makefile
9@@ -18,7 +18,7 @@ export MANDIR
10 export DATADIR
11 export SQLITE
12
13-CXX?=c++
14+CXX?=$(CROSS_COMPILE)c++
15 INCLUDES=-I./core/
16 DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
17 CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
18--- a/src/core/Makefile
19+++ b/src/core/Makefile
20@@ -1,6 +1,6 @@
21 PACKAGENAME?=lshw
22
23-CXX=c++
24+CXX?=$(CROSS_COMPILE)c++
25 INCLUDES=
26 DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
27 CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
28--- a/src/gui/Makefile
29+++ b/src/gui/Makefile
30@@ -1,7 +1,7 @@
31 PACKAGENAME?=lshw
32
33-CXX?=c++
34-CC?=cc
35+CXX?=$(CROSS_COMPILE)c++
36+CC?=$(CROSS_COMPILE)cc
37 STRIP?=strip
38 OBJCOPY?=objcopy
39
diff --git a/recipes-support/lshw/files/ldflags.patch b/recipes-support/lshw/files/ldflags.patch
deleted file mode 100644
index d95699d..0000000
--- a/recipes-support/lshw/files/ldflags.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.17/src/Makefile
2--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
3+++ lshw-B.02.17/src/Makefile 2017-02-07 16:22:45.578588072 +0100
4@@ -25,9 +25,9 @@
5 ifeq ($(SQLITE), 1)
6 CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
7 endif
8-LDFLAGS=-L./core/ -g
9+LDEXTRAS=-L./core/ -g
10 ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
11- LDFLAGS+= -Wl,--as-needed
12+ LDEXTRAS+= -Wl,--as-needed
13 endif
14 LDSTATIC=-static
15 LIBS=-llshw -lresolv
16@@ -37,7 +37,7 @@
17
18 export CXXFLAGS
19 export LIBS
20-export LDFLAGS
21+export LDEXTRAS
22
23 DATAFILES = pci.ids usb.ids oui.txt manuf.txt
24
25@@ -51,7 +51,7 @@
26 +make -C core all
27
28 $(PACKAGENAME): core $(PACKAGENAME).o
29- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
30+ $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
31
32 .PHONY: po
33 po:
34@@ -69,7 +69,7 @@
35 static: $(PACKAGENAME)-static
36
37 $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
38- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
39+ $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
40 $(STRIP) $@
41
42 .PHONY: compressed
diff --git a/recipes-support/lshw/lshw_02.17.bb b/recipes-support/lshw/lshw_02.17.bb
deleted file mode 100644
index 1ecc4c1..0000000
--- a/recipes-support/lshw/lshw_02.17.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1# From meta-linaro
2# http://git.linaro.org/openembedded/meta-linaro.git
3
4DESCRIPTION = "A small tool to provide detailed information on the hardware \
5configuration of the machine. It can report exact memory configuration, \
6firmware version, mainboard configuration, CPU version and speed, cache \
7configuration, bus speed, etc. on DMI-capable or EFI systems."
8SUMMARY = "Hardware lister"
9HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
10SECTION = "console/tools"
11LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
13DEPENDS = "pciutils \
14 usbutils"
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
18 file://cross-compile.patch \
19 file://ldflags.patch \
20 "
21
22SRC_URI[md5sum] = "a5feb796cb302850eaf5b4530888e3ed"
23SRC_URI[sha256sum] = "eb9cc053fa0f1e78685cb695596e73931bfb55d2377e3bc3b8b94aff4c5a489c"
24
25S="${WORKDIR}/lshw-B.${PV}"
26
27do_compile() {
28 # build core only - don't ship gui
29 oe_runmake -C src core
30}
31
32do_install() {
33 oe_runmake install DESTDIR=${D}
34 # data files provided by dependencies
35 rm -rf ${D}/usr/share/lshw
36}