summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-07-01 17:24:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-07-01 17:25:00 +0200
commitceeaa15ad780e330f25bcb085620a872dbeb0acb (patch)
treec9c09e37480124f85c1f5f93ffd2b86510b9edcb
parent880788be9be9d826616c32ab0159eed1fb09941d (diff)
downloadmeta-updater-ceeaa15ad780e330f25bcb085620a872dbeb0acb.tar.gz
ostree-kernel-initramfs: skip recipe when OSTREE_KERNEL is not defined
* otherwise it fails with useless error: ostree-kernel-initramfs/0.0.1-r0/temp/run.do_install.3011' failed with exit code 1: cp: -r not specified; omitting directory 'tmp-glibc/deploy/images/qemux86/' WARNING: exit code 1 from a shell command. because of cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz in do_install will try to copy whole ${DEPLOY_DIR_IMAGE}/ when ${OSTREE_KERNEL} is empty as reported in: https://github.com/advancedtelematic/meta-updater/pull/740#issuecomment-651952735 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
index 1b9c0ad..6159f00 100644
--- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
+++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb
@@ -51,3 +51,8 @@ do_install() {
51do_install[vardepsexclude] = "KERNEL_VERSION" 51do_install[vardepsexclude] = "KERNEL_VERSION"
52INITRAMFS_IMAGE ?= "" 52INITRAMFS_IMAGE ?= ""
53do_install[depends] = "virtual/kernel:do_deploy ${@['${INITRAMFS_IMAGE}:do_image_complete', ''][d.getVar('INITRAMFS_IMAGE') == '']}" 53do_install[depends] = "virtual/kernel:do_deploy ${@['${INITRAMFS_IMAGE}:do_image_complete', ''][d.getVar('INITRAMFS_IMAGE') == '']}"
54
55python() {
56 if not d.getVar('OSTREE_KERNEL'):
57 raise bb.parse.SkipRecipe('OSTREE_KERNEL is not defined, maybe your MACHINE config does not inherit sota.bbclass?')
58}