diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2020-03-26 14:03:33 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-03-26 14:03:33 +0100 |
commit | 8997893dda6c01b7435470a6304205280e078d8c (patch) | |
tree | 27e7d7159ec51e432abd5b0ef5dcb9d2a9acda38 | |
parent | bf39f0fec9ad410aa37d3001b11d9e731b39d6e7 (diff) | |
parent | 86157900804116db0a91d73e309ce354381fd8b1 (diff) | |
download | meta-updater-8997893dda6c01b7435470a6304205280e078d8c.tar.gz |
Merge pull request #700 from advancedtelematic/feat/zeus/2020.4
Feat/zeus/2020.4
-rw-r--r-- | classes/sota_m3ulcb.bbclass | 7 | ||||
-rw-r--r-- | lib/oeqa/selftest/cases/testutils.py | 4 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 13 | ||||
-rw-r--r-- | recipes-sota/aktualizr/files/aktualizr-secondary.service | 3 | ||||
-rw-r--r-- | recipes-sota/aktualizr/files/aktualizr.service | 3 | ||||
-rw-r--r-- | recipes-test/demo-config/primary-config.bb | 1 |
6 files changed, 17 insertions, 14 deletions
diff --git a/classes/sota_m3ulcb.bbclass b/classes/sota_m3ulcb.bbclass index b93cc40..e7fa9c2 100644 --- a/classes/sota_m3ulcb.bbclass +++ b/classes/sota_m3ulcb.bbclass | |||
@@ -1,11 +1,12 @@ | |||
1 | # Commit united image to OSTree, not just uImage | 1 | # Commit united image to OSTree, not just uImage |
2 | OSTREE_KERNEL = "Image" | 2 | OSTREE_KERNEL = "Image" |
3 | 3 | ||
4 | EXTRA_IMAGEDEPENDS_append_sota = " m3ulcb-ota-bootfiles" | 4 | EXTRA_IMAGEDEPENDS_append_sota = " renesas-ota-bootfiles" |
5 | IMAGE_BOOT_FILES_sota += "m3ulcb-ota-bootfiles/*" | 5 | IMAGE_BOOT_FILES_sota += "renesas-ota-bootfiles/*" |
6 | 6 | ||
7 | OSTREE_BOOTLOADER ?= "u-boot" | 7 | OSTREE_BOOTLOADER ?= "u-boot" |
8 | UBOOT_MACHINE_sota = "m3ulcb_defconfig" | 8 | |
9 | UBOOT_MACHINE_sota = "${@d.getVar('SOC_FAMILY').split(':')[1]}_ulcb_defconfig" | ||
9 | 10 | ||
10 | PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman" | 11 | PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman" |
11 | IMAGE_INSTALL_append_sota = " virtual/network-configuration " | 12 | IMAGE_INSTALL_append_sota = " virtual/network-configuration " |
diff --git a/lib/oeqa/selftest/cases/testutils.py b/lib/oeqa/selftest/cases/testutils.py index 3455fa8..3abfa5e 100644 --- a/lib/oeqa/selftest/cases/testutils.py +++ b/lib/oeqa/selftest/cases/testutils.py | |||
@@ -139,10 +139,10 @@ def verifyProvisioned(testInst, machine, hwid=''): | |||
139 | testInst.assertEqual(stderr, b'', 'aktualizr-info failed: ' + stderr.decode() + stdout.decode()) | 139 | testInst.assertEqual(stderr, b'', 'aktualizr-info failed: ' + stderr.decode() + stdout.decode()) |
140 | testInst.assertIn(b'Device ID: ', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode()) | 140 | testInst.assertIn(b'Device ID: ', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode()) |
141 | if hwid == '': | 141 | if hwid == '': |
142 | testInst.assertIn(b'Primary ecu hardware ID: ' + machine.encode(), stdout, | 142 | testInst.assertIn(b'Primary ECU hardware ID: ' + machine.encode(), stdout, |
143 | 'Provisioning failed: ' + stderr.decode() + stdout.decode()) | 143 | 'Provisioning failed: ' + stderr.decode() + stdout.decode()) |
144 | else: | 144 | else: |
145 | testInst.assertIn(b'Primary ecu hardware ID: ' + hwid.encode(), stdout, | 145 | testInst.assertIn(b'Primary ECU hardware ID: ' + hwid.encode(), stdout, |
146 | 'Provisioning failed: ' + stderr.decode() + stdout.decode()) | 146 | 'Provisioning failed: ' + stderr.decode() + stdout.decode()) |
147 | testInst.assertIn(b'Fetched metadata: yes', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode()) | 147 | testInst.assertIn(b'Fetched metadata: yes', stdout, 'Provisioning failed: ' + stderr.decode() + stdout.decode()) |
148 | p = re.compile(r'Device ID: ([a-z0-9-]*)\n') | 148 | p = re.compile(r'Device ID: ([a-z0-9-]*)\n') |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 804f2c2..a0c2713 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -12,10 +12,12 @@ RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.conta | |||
12 | 12 | ||
13 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" | 13 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" |
14 | 14 | ||
15 | PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so" | ||
16 | |||
15 | PV = "1.0+git${SRCPV}" | 17 | PV = "1.0+git${SRCPV}" |
16 | PR = "7" | 18 | PR = "7" |
17 | 19 | ||
18 | GARAGE_SIGN_PV = "0.7.0-70-g3adf982" | 20 | GARAGE_SIGN_PV = "0.7.0-87-g905dc3c" |
19 | 21 | ||
20 | SRC_URI = " \ | 22 | SRC_URI = " \ |
21 | gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ | 23 | gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ |
@@ -27,10 +29,10 @@ SRC_URI = " \ | |||
27 | ${@ d.expand("https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''} \ | 29 | ${@ d.expand("https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''} \ |
28 | " | 30 | " |
29 | 31 | ||
30 | SRC_URI[garagesign.md5sum] = "7c4cbeacefd97eae69104d29cf5ff37a" | 32 | SRC_URI[garagesign.md5sum] = "064b408c60676dcf282aa9209bff7dac" |
31 | SRC_URI[garagesign.sha256sum] = "e9a9b68eaa1ce4104eb2ab7f1f59d99742d50805e93216fb5b21d1f212aa3d82" | 33 | SRC_URI[garagesign.sha256sum] = "75c9b3cf24eb31dacb127d3b3d073359082e2b4ee4eeb27d75e792664800ba82" |
32 | 34 | ||
33 | SRCREV = "9f2cc5d7b026eb1a1404f0c77ef6cb9377245423" | 35 | SRCREV = "f90e8996e826d130976a7b7f1835947b7e631025" |
34 | BRANCH ?= "master" | 36 | BRANCH ?= "master" |
35 | 37 | ||
36 | S = "${WORKDIR}/git" | 38 | S = "${WORKDIR}/git" |
@@ -86,9 +88,6 @@ do_install_ptest() { | |||
86 | cp -r ${B}/ ${D}/${PTEST_PATH}/build | 88 | cp -r ${B}/ ${D}/${PTEST_PATH}/build |
87 | cp -r ${S}/ ${D}/${PTEST_PATH}/src | 89 | cp -r ${S}/ ${D}/${PTEST_PATH}/src |
88 | 90 | ||
89 | # remove huge external unused repository | ||
90 | rm -rf ${D}/${PTEST_PATH}/src/partial/extern/RIOT | ||
91 | |||
92 | # remove huge build artifacts | 91 | # remove huge build artifacts |
93 | find ${D}/${PTEST_PATH}/build/src -name "*.a" -delete | 92 | find ${D}/${PTEST_PATH}/build/src -name "*.a" -delete |
94 | 93 | ||
diff --git a/recipes-sota/aktualizr/files/aktualizr-secondary.service b/recipes-sota/aktualizr/files/aktualizr-secondary.service index b577ae8..fb610f9 100644 --- a/recipes-sota/aktualizr/files/aktualizr-secondary.service +++ b/recipes-sota/aktualizr/files/aktualizr-secondary.service | |||
@@ -1,6 +1,7 @@ | |||
1 | [Unit] | 1 | [Unit] |
2 | Description=Aktualizr SOTA Client (UPTANE Secondary) | 2 | Description=Aktualizr SOTA Client (UPTANE Secondary) |
3 | After=network.target | 3 | After=network-online.target |
4 | Wants=network-online.target | ||
4 | 5 | ||
5 | [Service] | 6 | [Service] |
6 | RestartSec=10 | 7 | RestartSec=10 |
diff --git a/recipes-sota/aktualizr/files/aktualizr.service b/recipes-sota/aktualizr/files/aktualizr.service index b6f0980..3d807a1 100644 --- a/recipes-sota/aktualizr/files/aktualizr.service +++ b/recipes-sota/aktualizr/files/aktualizr.service | |||
@@ -1,6 +1,7 @@ | |||
1 | [Unit] | 1 | [Unit] |
2 | Description=Aktualizr SOTA Client | 2 | Description=Aktualizr SOTA Client |
3 | After=network.target nss-lookup.target | 3 | After=network-online.target nss-lookup.target |
4 | Wants=network-online.target | ||
4 | 5 | ||
5 | [Service] | 6 | [Service] |
6 | RestartSec=10 | 7 | RestartSec=10 |
diff --git a/recipes-test/demo-config/primary-config.bb b/recipes-test/demo-config/primary-config.bb index b1964e2..5c8abb5 100644 --- a/recipes-test/demo-config/primary-config.bb +++ b/recipes-test/demo-config/primary-config.bb | |||
@@ -11,6 +11,7 @@ PRIMARY_SECONDARIES ?= "${SECONDARY_IP}:${SECONDARY_PORT}" | |||
11 | SRC_URI = "\ | 11 | SRC_URI = "\ |
12 | file://30-secondary-config.toml \ | 12 | file://30-secondary-config.toml \ |
13 | file://ip_secondary_config.json \ | 13 | file://ip_secondary_config.json \ |
14 | ${@('file://' + d.getVar('SOTA_SECONDARY_CONFIG')) if d.getVar('SOTA_SECONDARY_CONFIG') else ''} \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | def get_secondary_addrs(d): | 17 | def get_secondary_addrs(d): |