diff options
author | Ricardo Salveti <ricardo@opensourcefoundries.com> | 2018-02-08 18:47:27 -0200 |
---|---|---|
committer | Laurent Bonnans <laurent.bonnans@here.com> | 2018-05-16 10:28:12 +0200 |
commit | 340c0b07b79dce7bc3081f1212c3f82f660f6b81 (patch) | |
tree | 24354951b1e7c6f12f0e23c6f32f08eeb2f36d62 | |
parent | 6ce668bc1ca33ae88ba6b51dee1e680212247539 (diff) | |
download | meta-updater-340c0b07b79dce7bc3081f1212c3f82f660f6b81.tar.gz |
Replace INITRAMFS_FSTYPES with OSTREE_INITRAMFS_FSTYPES
User is able to customize the init script via OSTREE_INITRAMFS_IMAGE but
there is no way to set INITRAMFS_FSTYPES as it gets defined by
sota.bbclass. Create a new variable called OSTREE_INITRAMFS_IMAGE to
handle the INITRAMFS_FSTYPES update, and also allow the user to override
it.
Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r-- | classes/image_types_ostree.bbclass | 2 | ||||
-rw-r--r-- | classes/sota.bbclass | 2 | ||||
-rw-r--r-- | recipes-core/images/initramfs-ostree-image.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 349d8fb..bc44e33 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -11,7 +11,7 @@ export OSTREE_REPO | |||
11 | export OSTREE_BRANCHNAME | 11 | export OSTREE_BRANCHNAME |
12 | export GARAGE_TARGET_NAME | 12 | export GARAGE_TARGET_NAME |
13 | 13 | ||
14 | RAMDISK_EXT ?= ".${INITRAMFS_FSTYPES}" | 14 | RAMDISK_EXT ?= ".${OSTREE_INITRAMFS_FSTYPES}" |
15 | 15 | ||
16 | OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" | 16 | OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" |
17 | 17 | ||
diff --git a/classes/sota.bbclass b/classes/sota.bbclass index 7ff4bf1..621db24 100644 --- a/classes/sota.bbclass +++ b/classes/sota.bbclass | |||
@@ -20,7 +20,7 @@ WKS_FILE_sota ?= "sdimage-sota.wks" | |||
20 | 20 | ||
21 | EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" | 21 | EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" |
22 | 22 | ||
23 | INITRAMFS_FSTYPES = "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'ext4.gz.u-boot', 'ext4.gz')}" | 23 | OSTREE_INITRAMFS_FSTYPES ?= "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'ext4.gz.u-boot', 'ext4.gz')}" |
24 | 24 | ||
25 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo | 25 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo |
26 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" | 26 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" |
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb index e77499e..b2d9e27 100644 --- a/recipes-core/images/initramfs-ostree-image.bb +++ b/recipes-core/images/initramfs-ostree-image.bb | |||
@@ -13,7 +13,7 @@ IMAGE_LINGUAS = "" | |||
13 | 13 | ||
14 | LICENSE = "MIT" | 14 | LICENSE = "MIT" |
15 | 15 | ||
16 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" | 16 | IMAGE_FSTYPES = "${OSTREE_INITRAMFS_FSTYPES}" |
17 | 17 | ||
18 | inherit core-image | 18 | inherit core-image |
19 | 19 | ||