diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2019-10-16 16:54:55 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2019-10-21 13:01:42 +0200 |
commit | 8ce94fd8c78d4836a429229a9842e917b30b39ae (patch) | |
tree | 72faea6ad53d7db551a2f3ff6387d0a998d5d3b9 | |
parent | 53b55b7d281171217b29731d293025cb7555995d (diff) | |
download | meta-updater-8ce94fd8c78d4836a429229a9842e917b30b39ae.tar.gz |
Specify more configs as MACHINE_ARCH.
If they depend on MACHINE, that's what we gotta do. Still haven't sorted
out aktualizr-device-prov-creds, though.
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-hwid.bb | 1 | ||||
-rw-r--r-- | recipes-test/demo-config/secondary-config.bb | 3 | ||||
-rw-r--r-- | recipes-test/demo-network-config/network-config.inc | 3 |
3 files changed, 7 insertions, 0 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-hwid.bb b/recipes-sota/aktualizr/aktualizr-hwid.bb index 64b1bda..fd3e395 100644 --- a/recipes-sota/aktualizr/aktualizr-hwid.bb +++ b/recipes-sota/aktualizr/aktualizr-hwid.bb | |||
@@ -4,6 +4,7 @@ SECTION = "base" | |||
4 | LICENSE = "MPL-2.0" | 4 | LICENSE = "MPL-2.0" |
5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" | 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" |
6 | 6 | ||
7 | # Because of the dependency on MACHINE. | ||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 8 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
8 | 9 | ||
9 | SRC_URI = "" | 10 | SRC_URI = "" |
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb index 55358b7..ddbed89 100644 --- a/recipes-test/demo-config/secondary-config.bb +++ b/recipes-test/demo-config/secondary-config.bb | |||
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
4 | 4 | ||
5 | require shared-conf.inc | 5 | require shared-conf.inc |
6 | 6 | ||
7 | # Because of the dependency on MACHINE. | ||
8 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
9 | |||
7 | SECONDARY_SERIAL_ID ?= "" | 10 | SECONDARY_SERIAL_ID ?= "" |
8 | SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" | 11 | SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" |
9 | SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" | 12 | SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" |
diff --git a/recipes-test/demo-network-config/network-config.inc b/recipes-test/demo-network-config/network-config.inc index a231a24..b023f51 100644 --- a/recipes-test/demo-network-config/network-config.inc +++ b/recipes-test/demo-network-config/network-config.inc | |||
@@ -2,6 +2,9 @@ SRC_URI_append = "\ | |||
2 | file://26-${CONF_TYPE}-client.network \ | 2 | file://26-${CONF_TYPE}-client.network \ |
3 | " | 3 | " |
4 | 4 | ||
5 | # Because of the dependency on MACHINE. | ||
6 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
7 | |||
5 | SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}" | 8 | SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}" |
6 | 9 | ||
7 | do_install_append() { | 10 | do_install_append() { |