summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatti Vacek <pattivacek@gmail.com>2021-04-06 12:18:06 +0200
committerGitHub <noreply@github.com>2021-04-06 12:18:06 +0200
commit5d49b28570ed030924ed5d45fbced24d3cb6e588 (patch)
tree7027c93991f0d60b8212d6d6bec3a3bbca3d5b0f
parent1a4a7214d5ee3e1ffe55883cc0649f2df9fd1364 (diff)
parentdf2cb1afbaf39855252daed11e19e60132f09bfa (diff)
downloadmeta-updater-5d49b28570ed030924ed5d45fbced24d3cb6e588.tar.gz
Merge pull request #807 from shr-project/jansa/dunfell-fixes-from-master
Backport few fixes from master branch
-rw-r--r--recipes-sota/fit-conf/fit-conf.bb2
-rw-r--r--recipes-sota/ostree-initrd/ostree-initrd.bb2
-rw-r--r--recipes-support/slcand-start/slcand-start.bb4
-rw-r--r--recipes-test/big-update/big-update_2.0.bb7
4 files changed, 7 insertions, 8 deletions
diff --git a/recipes-sota/fit-conf/fit-conf.bb b/recipes-sota/fit-conf/fit-conf.bb
index f24a94a..f409b9b 100644
--- a/recipes-sota/fit-conf/fit-conf.bb
+++ b/recipes-sota/fit-conf/fit-conf.bb
@@ -1,6 +1,6 @@
1SUMMARY = "FIT image configuration for u-boot to use" 1SUMMARY = "FIT image configuration for u-boot to use"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 4
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb
index 26525c8..e7bd929 100644
--- a/recipes-sota/ostree-initrd/ostree-initrd.bb
+++ b/recipes-sota/ostree-initrd/ostree-initrd.bb
@@ -1,6 +1,6 @@
1SUMMARY = "Initramfs for booting into libostree managed system" 1SUMMARY = "Initramfs for booting into libostree managed system"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 4
5SRC_URI = "file://init.sh" 5SRC_URI = "file://init.sh"
6 6
diff --git a/recipes-support/slcand-start/slcand-start.bb b/recipes-support/slcand-start/slcand-start.bb
index dfefaea..566507b 100644
--- a/recipes-support/slcand-start/slcand-start.bb
+++ b/recipes-support/slcand-start/slcand-start.bb
@@ -1,8 +1,6 @@
1SUMMARY = "Mock smartcard for aktualizr" 1SUMMARY = "Mock smartcard for aktualizr"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6 4
7inherit systemd 5inherit systemd
8 6
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 6fffbc1..690e62c 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -1,15 +1,16 @@
1DESCRIPTION = "Example Package with 12MB of random, seeded content" 1DESCRIPTION = "Example Package with 12MB of random, seeded content"
2LICENSE = "MPL-2.0" 2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
3 4
4SRC_URI = "file://rand_file.py" 5SRC_URI = "file://rand_file.py"
5 6
6FILES_${PN} = "/usr/lib/big-update" 7FILES_${PN} = "${libdir}/big-update"
7 8
8DEPENDS = "coreutils-native" 9DEPENDS = "coreutils-native"
9 10
10inherit python3native 11inherit python3native
11 12
12do_install() { 13do_install() {
13 install -d ${D}/usr/lib/big-update 14 install -d ${D}${libdir}/big-update
14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 15 python3 ${S}/../rand_file.py ${D}${libdir}/big-update/a-big-file $(numfmt --from=iec 12M)
15} 16}